summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-12-09 11:18:25 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2023-12-09 11:27:54 +0100
commit8e461e08a0fc724a1aec7199f9708fb22f0dd7f9 (patch)
tree557b873d729358927e813c747880cd4f68ba1cc3 /kde-apps
parentkde-apps/dolphin-plugins-mercurial: 23.08.4 version bump (diff)
downloadgentoo-8e461e08a0fc724a1aec7199f9708fb22f0dd7f9.tar.gz
gentoo-8e461e08a0fc724a1aec7199f9708fb22f0dd7f9.tar.bz2
gentoo-8e461e08a0fc724a1aec7199f9708fb22f0dd7f9.zip
kde-apps/dolphin-plugins-subversion: 23.08.4 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps')
-rw-r--r--kde-apps/dolphin-plugins-subversion/Manifest1
-rw-r--r--kde-apps/dolphin-plugins-subversion/dolphin-plugins-subversion-23.08.4.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/kde-apps/dolphin-plugins-subversion/Manifest b/kde-apps/dolphin-plugins-subversion/Manifest
index cfa31e9bc967..1ead8cb42484 100644
--- a/kde-apps/dolphin-plugins-subversion/Manifest
+++ b/kde-apps/dolphin-plugins-subversion/Manifest
@@ -1,2 +1,3 @@
DIST dolphin-plugins-23.04.3.tar.xz 272912 BLAKE2B f0eb8bbab16d66f1e964131b436af7d3ae8febc26cf4fe394489a978c701ef2f5689bea7daf9eed8d7ef2f1f2bdba000a487cf7f0704ad30bd25e2d403ce5fae SHA512 8f487ba0bcbe561915064247ddb2327c3b7c8fa6ffc5c511d9c9ef37bd4f28a624533ce7a2da2a86b10b65f37915ca10840517872b40c2fd014cead6da5972c8
DIST dolphin-plugins-23.08.3.tar.xz 273396 BLAKE2B 3a07eb2daf0a24ff5aabbc268fcf2724b116827ac17b04edb643e78abad89c5a30d1729234b718108bc4c6faa7c44ef36206b19a8573d439a0632c1ef180b666 SHA512 6ff3ddd08782b076927251afaf2e581a730c56db6b80647e6005267fd9f99ffa2bbce4a59dfe422dc6ad21fd1603245cfeb97db2fde582c83df552104f6a536d
+DIST dolphin-plugins-23.08.4.tar.xz 274180 BLAKE2B 586c697b5c292ed78e826b1adabb26ee1daebe995d8fac4fc64bbc84c4490387a8100f895934783180da02ad9f008c0ef98b938e8f0cb6b1a8c1dd5be31b7c1f SHA512 7cb3365221aabe411e1339230633a37d674c6e2a77e675f8a1d9c61928bd0d2b75e5d289ba8d7765bcbea47afea56e2b629726fbdcf6e0e4248c4380ce33f40e
diff --git a/kde-apps/dolphin-plugins-subversion/dolphin-plugins-subversion-23.08.4.ebuild b/kde-apps/dolphin-plugins-subversion/dolphin-plugins-subversion-23.08.4.ebuild
new file mode 100644
index 000000000000..cc9d4d07a291
--- /dev/null
+++ b/kde-apps/dolphin-plugins-subversion/dolphin-plugins-subversion-23.08.4.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_HANDBOOK="false"
+KDE_ORG_NAME="dolphin-plugins"
+MY_PLUGIN_NAME="svn"
+PVCUT=$(ver_cut 1-3)
+KFMIN=5.106.0
+QTMIN=5.15.9
+inherit ecm gear.kde.org
+
+DESCRIPTION="Dolphin plugin for Subversion integration"
+HOMEPAGE="https://apps.kde.org/dolphin_plugins/"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+IUSE=""
+
+DEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-apps/dolphin-${PVCUT}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/ktextwidgets-${KFMIN}:5
+"
+RDEPEND="${DEPEND}
+ dev-vcs/subversion
+ >=kde-apps/kompare-${PVCUT}:5
+"
+
+src_prepare() {
+ ecm_src_prepare
+ # solid, qtdbus only required by mountiso
+ ecm_punt_qt_module DBus
+ ecm_punt_kf_module Solid
+ # kxmlgui, qtnetwork only required by dropbox
+ ecm_punt_qt_module Network
+ ecm_punt_kf_module XmlGui
+ # delete non-${PN} translations
+ find po -type f -name "*po" -and -not -name "*${MY_PLUGIN_NAME}plugin" -delete || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_${MY_PLUGIN_NAME}=ON
+ -DBUILD_bazaar=OFF
+ -DBUILD_dropbox=OFF
+ -DBUILD_git=OFF
+ -DBUILD_hg=OFF
+ -DBUILD_mountiso=OFF
+ )
+ ecm_src_configure
+}
+
+src_install() {
+ ecm_src_install
+ rm "${D}"/usr/share/metainfo/org.kde.dolphin-plugins.metainfo.xml || die
+}