summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-10-13 13:50:53 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2022-10-13 15:13:37 +0200
commit92c34280ef5c4f46413d6afd7e04830896db6f37 (patch)
tree9c0d0832f0e77193bc7d759fcc0837507b0a928d /kde-apps
parentkde-apps/dolphin-plugins-mercurial: 22.08.2 version bump (diff)
downloadgentoo-92c34280ef5c4f46413d6afd7e04830896db6f37.tar.gz
gentoo-92c34280ef5c4f46413d6afd7e04830896db6f37.tar.bz2
gentoo-92c34280ef5c4f46413d6afd7e04830896db6f37.zip
kde-apps/dolphin-plugins-subversion: 22.08.2 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps')
-rw-r--r--kde-apps/dolphin-plugins-subversion/Manifest1
-rw-r--r--kde-apps/dolphin-plugins-subversion/dolphin-plugins-subversion-22.08.2.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/kde-apps/dolphin-plugins-subversion/Manifest b/kde-apps/dolphin-plugins-subversion/Manifest
index 338561623bd8..45754212a40c 100644
--- a/kde-apps/dolphin-plugins-subversion/Manifest
+++ b/kde-apps/dolphin-plugins-subversion/Manifest
@@ -1,2 +1,3 @@
DIST dolphin-plugins-22.04.3.tar.xz 257356 BLAKE2B e3d084e628920a08c9e1173c754002f6b0ecfad07bd4d89a64f5b29a7e93362a814ead6aeff80412b01e7198adce78c36f36428560a1ea9e555027113f7d8e6f SHA512 1b96511fbf8ec93b03a5f204c2e4cff232ca0d09e4d1599c89d4d514deb3fb889dfd3050a5cabe4e35b6e65a5283ad09635a13931c8484eebc98a22ba9057b42
DIST dolphin-plugins-22.08.1.tar.xz 257836 BLAKE2B 3ad0ebe22478b5540dbe4128df718cb428259e2c28d5586a2625c15f63fa9a1e8ca35d45397a9446e8a7bed66ecbc65f13137174a565792ba217158a2c71cd0f SHA512 9eee9e33640dfba94530bd538a0915cdf49257dd68934835056f2e9b0906e7e5884a83bb5095fd6b66e7fb86d5ae5cc77d319439a491cd424fc4fd01fb9097c5
+DIST dolphin-plugins-22.08.2.tar.xz 259816 BLAKE2B 0a7202e1a2397058b34d32976542e58a26602d4791bf2b6e1efcfb4fb5170393c768f7288dcdc00261e80f176c47ead3f299d8f6f2969d9ca36be338b85f7825 SHA512 8636ded42f0bed07cd26986032c111f98e6e5225176d6221cb7691fe4cc5cd29ba2512e741240c64ba7c4bd72cfdb5f21c4762dd45c1493b9f3aefff63936889
diff --git a/kde-apps/dolphin-plugins-subversion/dolphin-plugins-subversion-22.08.2.ebuild b/kde-apps/dolphin-plugins-subversion/dolphin-plugins-subversion-22.08.2.ebuild
new file mode 100644
index 000000000000..4d7b0456fb96
--- /dev/null
+++ b/kde-apps/dolphin-plugins-subversion/dolphin-plugins-subversion-22.08.2.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_HANDBOOK="false"
+KDE_ORG_NAME="dolphin-plugins"
+MY_PLUGIN_NAME="svn"
+PVCUT=$(ver_cut 1-3)
+KFMIN=5.96.0
+QTMIN=5.15.5
+inherit ecm gear.kde.org
+
+DESCRIPTION="Dolphin plugin for Subversion integration"
+HOMEPAGE="https://apps.kde.org/dolphin_plugins/"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+IUSE=""
+
+DEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-apps/dolphin-${PVCUT}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/ktextwidgets-${KFMIN}:5
+"
+RDEPEND="${DEPEND}
+ dev-vcs/subversion
+ >=kde-apps/kompare-${PVCUT}:5
+"
+
+src_prepare() {
+ ecm_src_prepare
+ # solid, qtdbus only required by mountiso
+ ecm_punt_qt_module DBus
+ ecm_punt_kf_module Solid
+ # kxmlgui, qtnetwork only required by dropbox
+ ecm_punt_qt_module Network
+ ecm_punt_kf_module XmlGui
+ # delete non-${PN} translations
+ if [[ ${KDE_BUILD_TYPE} = release ]]; then
+ find po -type f -name "*po" -and -not -name "*${MY_PLUGIN_NAME}plugin" -delete || die
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_${MY_PLUGIN_NAME}=ON
+ -DBUILD_bazaar=OFF
+ -DBUILD_dropbox=OFF
+ -DBUILD_git=OFF
+ -DBUILD_hg=OFF
+ -DBUILD_mountiso=OFF
+ )
+ ecm_src_configure
+}
+
+src_install() {
+ ecm_src_install
+ rm "${D}"/usr/share/metainfo/org.kde.dolphin-plugins.metainfo.xml || die
+}