summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /kde-misc/kdeconnect
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'kde-misc/kdeconnect')
-rw-r--r--kde-misc/kdeconnect/Manifest2
-rw-r--r--kde-misc/kdeconnect/kdeconnect-0.7.3.ebuild54
-rw-r--r--kde-misc/kdeconnect/kdeconnect-0.8.ebuild53
-rw-r--r--kde-misc/kdeconnect/metadata.xml5
4 files changed, 114 insertions, 0 deletions
diff --git a/kde-misc/kdeconnect/Manifest b/kde-misc/kdeconnect/Manifest
new file mode 100644
index 000000000000..7a0e58038311
--- /dev/null
+++ b/kde-misc/kdeconnect/Manifest
@@ -0,0 +1,2 @@
+DIST kdeconnect-kde-0.7.3.tar.xz 133580 SHA256 e44d943b8d302dbfbe3c0164557f0100f696204beb96bde2ee5317bc0e0139ef SHA512 ea42d970afe6ee871560406f11375a2ee0b06c032a06fb3521eed30e4d6466f48f7c2ac8f5d35669f07f292b11f675537a1ae3054fa5031df8c57e51e2c78a88 WHIRLPOOL a75fd33e38c957bd1c1303292c2b2d1d7f850231aaad96c921ffd1054d6e9dee17345595263f7f4348abcee2a9bc43a60fc93c4f427a9491ab6d4009d9266c24
+DIST kdeconnect-kde-0.8.tar.xz 141916 SHA256 c33611c076a327a67f9974ffa5662f2c093dda6ad14024e434027f9f19d9a0ab SHA512 7c7c460648960dde501596c85282eddd4d9add3b1be291b6d22a75f316cce6cdee0015d81b275eaa7c66758dcf16fa21da1be9b79f12b68c76bad343eef7250e WHIRLPOOL 0d302b4c6005100db9bc44ca590ee330bc6f432af02bfd1d2f27b367f38b6d4993828a3726c2bf3acaafcaa00c1724a9592ee8a652152f6b811923c351d3f499
diff --git a/kde-misc/kdeconnect/kdeconnect-0.7.3.ebuild b/kde-misc/kdeconnect/kdeconnect-0.7.3.ebuild
new file mode 100644
index 000000000000..71e176bdc640
--- /dev/null
+++ b/kde-misc/kdeconnect/kdeconnect-0.7.3.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MY_PN=${PN}-kde
+DECLARATIVE_REQUIRED="always"
+KDE_LINGUAS="bg bs ca cs da de es fi fr gl hu it ja ko lt nl pl pt pt_BR ro ru sk sv tr uk"
+
+inherit kde4-base
+
+if [[ ${KDE_BUILD_TYPE} != live ]]; then
+ MY_P=${MY_PN}-${PV}
+ SRC_URI="mirror://kde/unstable/${PN}/${PV}/src/${MY_P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+else
+ EGIT_REPO_URI="git://anongit.kde.org/${MY_PN}"
+ KEYWORDS=""
+fi
+
+DESCRIPTION="Adds communication between KDE and your smartphone"
+HOMEPAGE="http://www.kde.org/"
+
+LICENSE="GPL-2+"
+SLOT="4"
+IUSE="debug"
+
+DEPEND="
+ app-crypt/qca:2[qt4(+)]
+ dev-libs/qjson
+ x11-libs/libfakekey
+"
+RDEPEND="${DEPEND}
+ $(add_kdebase_dep plasma-workspace)
+ app-crypt/qca:2[openssl]
+"
+
+[[ ${KDE_BUILD_TYPE} != live ]] && S=${WORKDIR}/${MY_P}
+
+src_prepare(){
+ sed -i -e "s:QtCrypto/QtCrypto:QtCrypto:" core/networkpackage.cpp || die
+ kde4-base_src_prepare
+}
+
+pkg_postinst(){
+ elog
+ elog "Optional dependency:"
+ elog "sys-fs/sshfs-fuse (for 'remote filesystem browser' plugin)"
+ elog
+ elog "The Android .apk file is available via"
+ elog "https://play.google.com/store/apps/details?id=org.kde.kdeconnect_tp"
+ elog
+}
diff --git a/kde-misc/kdeconnect/kdeconnect-0.8.ebuild b/kde-misc/kdeconnect/kdeconnect-0.8.ebuild
new file mode 100644
index 000000000000..9a4907b2ac72
--- /dev/null
+++ b/kde-misc/kdeconnect/kdeconnect-0.8.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MY_PN="${PN}-kde"
+DECLARATIVE_REQUIRED="always"
+KDE_LINGUAS="ar bg bs ca cs da de es fi fr gl hu it ja ko lt nl pl pt pt_BR ro ru sk sv tr uk"
+inherit kde4-base
+
+if [[ ${KDE_BUILD_TYPE} != live ]]; then
+ MY_P="${MY_PN}-${PV}"
+ SRC_URI="mirror://kde/unstable/${PN}/${PV}/src/${MY_P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+else
+ EGIT_REPO_URI="git://anongit.kde.org/${MY_PN}"
+ KEYWORDS=""
+fi
+
+DESCRIPTION="Adds communication between KDE and your smartphone"
+HOMEPAGE="http://www.kde.org/"
+
+LICENSE="GPL-2+"
+SLOT="4"
+IUSE="debug"
+
+COMMON_DEPEND="
+ app-crypt/qca:2[qt4(+)]
+ dev-libs/qjson
+ x11-libs/libfakekey
+ x11-libs/libX11
+ x11-libs/libXtst
+"
+RDEPEND="${COMMON_DEPEND}
+ $(add_kdebase_dep plasma-workspace)
+ app-crypt/qca:2[openssl]
+"
+DEPEND="${COMMON_DEPEND}
+ sys-devel/gettext
+"
+
+[[ ${KDE_BUILD_TYPE} != live ]] && S=${WORKDIR}/${MY_P}
+
+pkg_postinst(){
+ elog
+ elog "Optional dependency:"
+ elog "sys-fs/sshfs-fuse (for 'remote filesystem browser' plugin)"
+ elog
+ elog "The Android .apk file is available via"
+ elog "https://play.google.com/store/apps/details?id=org.kde.kdeconnect_tp"
+ elog
+}
diff --git a/kde-misc/kdeconnect/metadata.xml b/kde-misc/kdeconnect/metadata.xml
new file mode 100644
index 000000000000..a23f444b67d6
--- /dev/null
+++ b/kde-misc/kdeconnect/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>kde</herd>
+</pkgmetadata>