summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2016-07-21 05:58:40 +1000
committerMichael Palimaka <kensington@gentoo.org>2016-07-21 06:03:20 +1000
commite5a0398b8ea72f146c06a4b208ceef93587352a5 (patch)
tree6b6e54cd2e0499e117e2f6d8a43c0b22a264bbd4 /kde-misc/kdiff3
parentsci-physics/hoomd-blue: drop keywords (diff)
downloadgentoo-e5a0398b8ea72f146c06a4b208ceef93587352a5.tar.gz
gentoo-e5a0398b8ea72f146c06a4b208ceef93587352a5.tar.bz2
gentoo-e5a0398b8ea72f146c06a4b208ceef93587352a5.zip
kde-misc/kdiff3: restore 0.9.97-r2
This reverts commit 047c73f0b2503ad56a6de2ef46ec6b2df727d94b. Gentoo-bug: 546494
Diffstat (limited to 'kde-misc/kdiff3')
-rw-r--r--kde-misc/kdiff3/Manifest1
-rw-r--r--kde-misc/kdiff3/files/kdiff3-0.9.97-relativepath.patch66
-rw-r--r--kde-misc/kdiff3/kdiff3-0.9.97-r2.ebuild96
3 files changed, 163 insertions, 0 deletions
diff --git a/kde-misc/kdiff3/Manifest b/kde-misc/kdiff3/Manifest
index dc41d54ee8c7..a06addf167ef 100644
--- a/kde-misc/kdiff3/Manifest
+++ b/kde-misc/kdiff3/Manifest
@@ -1 +1,2 @@
+DIST kdiff3-0.9.97.tar.gz 1803769 SHA256 e3b716bb449c814d8c30817ec1ca23fba0ed9eee5a635e766c1f2b90ddb75a2a SHA512 8f4e89e594894a3fbfaa2e5c9cc345ab16e6787c4efc4324fffe55fbe45b94c2ff10ba411279d2b433a0a5fa752653f7b3e663577cc0d658dfc4d5b797a22fab WHIRLPOOL 190590f3c4290afee73672a77ec4f16a923d156f097bcbb4dce1893f57b1199d1f7ed19166a8173292a7bedda5e54f792474f169a50ed8eb47a92b24f7b1c57c
DIST kdiff3-0.9.98.tar.gz 1762715 SHA256 802c1ababa02b403a5dca15955c01592997116a24909745016931537210fd668 SHA512 867f0b1d5beb421f1bf84e6044d8d9279d434900faa1962fd5417653ef6b1cc71a8f5dd6c29cd4826a1c70a6075786faeaee780548521ce2ce221d83229b52e6 WHIRLPOOL 4099488985182d36fc4ecf532914c1439273036e38b66f7584282b6b232c3c4a738ecab35dd8b1a30b9a368cf6a6f9aeebea38e921063b55ac3972f46e118c98
diff --git a/kde-misc/kdiff3/files/kdiff3-0.9.97-relativepath.patch b/kde-misc/kdiff3/files/kdiff3-0.9.97-relativepath.patch
new file mode 100644
index 000000000000..f0f43e8a8f1a
--- /dev/null
+++ b/kde-misc/kdiff3/files/kdiff3-0.9.97-relativepath.patch
@@ -0,0 +1,66 @@
+
+
+--- a/kdiff3/src-QT4/fileaccess.cpp
++++ b/kdiff3/src-QT4/fileaccess.cpp
+@@ -183,7 +183,8 @@
+
+ void FileAccess::setFile( const QFileInfo& fi, FileAccess* pParent )
+ {
+- m_filePath = nicePath( fi.filePath() ); // remove "./" at start
++ m_filePath = pParent == 0 ? fi.absoluteFilePath() :
++ nicePath( fi.filePath() ); // remove "./" at start
+
+ m_bSymLink = fi.isSymLink();
+ if ( m_bSymLink || (!m_bExists && m_filePath.contains("@@") ) )
+@@ -566,7 +567,16 @@
+ if ( parent() != 0 )
+ return parent()->absoluteFilePath() + "/" + m_filePath;
+ else
+- return m_filePath;
++ {
++ if ( m_filePath.isEmpty() )
++ return QString();
++
++ QFileInfo fi( m_filePath );
++ if ( fi.isAbsolute() )
++ return m_filePath;
++ else
++ return fi.absoluteFilePath(); // Probably never reached
++ }
+ } // Full abs path
+
+ // Just the name-part of the path, without parent directories
+@@ -1184,7 +1194,7 @@
+ m_bSuccess = false;
+ KIO::FileCopyJob* pJob = KIO::file_move( m_pFileAccess->url(), kurl, permissions, KIO::HideProgressInfo );
+ connect( pJob, SIGNAL(result(KJob*)), this, SLOT(slotSimpleJobResult(KJob*)));
+- connect( pJob, SIGNAL(percent(KJob*,unsigned long)), this, SLOT(slotPercent(KJob*, unsigned long)));
++ connect( pJob, SIGNAL(percent(KJob*,unsigned long)), &pp, SLOT(slotPercent(KJob*, unsigned long)));
+
+ ProgressProxy::enterEventLoop( pJob,
+ i18n("Renaming file: %1 -> %2",m_pFileAccess->prettyAbsPath(),dest) );
+@@ -1673,7 +1683,7 @@
+ &pp, SLOT( slotListDirInfoMessage(KJob*, const QString&) ));
+
+ // This line makes the transfer via fish unreliable.:-(
+- //connect( pListJob, SIGNAL(percent(KJob*,unsigned long)), this, SLOT(slotPercent(KJob*, unsigned long)));
++ //connect( pListJob, SIGNAL(percent(KJob*,unsigned long)), &pp, SLOT(slotPercent(KJob*, unsigned long)));
+
+ ProgressProxy::enterEventLoop( pListJob,
+ i18n("Listing directory: %1",m_pFileAccess->prettyAbsPath()) );
+
+kdiff3/src-QT4/kdiff3.cpp Diff
+
+--- a/kdiff3/src-QT4/kdiff3.cpp
++++ b/kdiff3/src-QT4/kdiff3.cpp
+@@ -211,6 +211,8 @@
+ m_outputFilename = args->getOption("output");
+ if ( m_outputFilename.isEmpty() )
+ m_outputFilename = args->getOption("out");
++ if ( ! m_outputFilename.isEmpty() )
++ m_outputFilename = FileAccess( m_outputFilename, true ).absoluteFilePath();
+ }
+
+ m_bAutoFlag = args!=0 && args->isSet("auto");
+
+
diff --git a/kde-misc/kdiff3/kdiff3-0.9.97-r2.ebuild b/kde-misc/kdiff3/kdiff3-0.9.97-r2.ebuild
new file mode 100644
index 000000000000..941e98f36565
--- /dev/null
+++ b/kde-misc/kdiff3/kdiff3-0.9.97-r2.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+if [[ ${PV} != *9999* ]]; then
+ KDE_LINGUAS="ar bg br bs ca ca@valencia cs cy da de el en_GB eo es et fr ga
+ gl hi hne hr hu is it ja ka lt mai ml nb nds nl nn pl pt pt_BR ro ru rw sk
+ sv ta tg tr ug uk zh_CN zh_TW"
+ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+ KEYWORDS="amd64 x86 ~amd64-linux"
+ KDE_HANDBOOK="optional"
+else
+ ESVN_REPO_URI="https://kdiff3.svn.sourceforge.net/svnroot/kdiff3/trunk/kdiff3"
+ KEYWORDS=""
+fi
+
+KDE_REQUIRED="optional"
+inherit kde4-base qt4-r2
+
+DESCRIPTION="Qt/KDE based frontend to diff3"
+HOMEPAGE="http://kdiff3.sourceforge.net/"
+
+LICENSE="GPL-2"
+SLOT="4"
+IUSE="debug kde"
+
+CDEPEND="
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ kde? ( $(add_kdebase_dep kdelibs) )
+"
+DEPEND="${CDEPEND}
+ sys-devel/gettext
+"
+RDEPEND="${CDEPEND}
+ sys-apps/diffutils
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.9.97-relativepath.patch"
+)
+
+RESTRICT="!kde? ( test )"
+
+src_unpack(){
+ if [[ ${PV} == *9999* ]]; then
+ subversion_src_unpack
+ elif use kde; then
+ kde4-base_src_unpack
+ else
+ qt4-r2_src_unpack
+ fi
+}
+
+src_prepare() {
+ if ! use kde; then
+ # adapt to Gentoo paths
+ sed -e s,documentation.path.*$,documentation.path\ =\ "${EPREFIX}"/usr/share/doc/"${PF}", \
+ -e s,target.path.*$,target.path\ =\ "${EPREFIX}"/usr/bin, \
+ "${S}"/src-QT4/kdiff3.pro > "${S}"/src-QT4/kdiff3_fixed.pro
+ else
+ kde4-base_src_prepare
+ fi
+}
+
+src_configure() {
+ if use kde; then
+ kde4-base_src_configure
+ else
+ eqmake4 "${S}"/src-QT4/kdiff3_fixed.pro
+ fi
+}
+
+src_compile() {
+ if use kde; then
+ kde4-base_src_compile
+ else
+ qt4-r2_src_compile
+ fi
+}
+
+src_install() {
+ if use kde; then
+ kde4-base_src_install
+ else
+ qt4-r2_src_install
+ fi
+}
+
+src_test() {
+ if use kde; then
+ kde4-base_src_test
+ fi
+}