summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2016-03-26 17:27:31 +0100
committerJohannes Huber <johu@gentoo.org>2016-03-26 17:27:31 +0100
commitd4660af6942221712f4498abe74f5f0b0eb2cb27 (patch)
treedaf3edaefbb0bd07e6898f6908cd6d5c50572828 /kde-misc/openofficeorg-thumbnail
parentnet-irc/quassel: Restore x86 (diff)
downloadgentoo-d4660af6942221712f4498abe74f5f0b0eb2cb27.tar.gz
gentoo-d4660af6942221712f4498abe74f5f0b0eb2cb27.tar.bz2
gentoo-d4660af6942221712f4498abe74f5f0b0eb2cb27.zip
kde-misc/openofficeorg-thumbnail: Revision bump
Adds support for KF5/Plasma5. Import from kde overlay. Package-Manager: portage-2.2.28
Diffstat (limited to 'kde-misc/openofficeorg-thumbnail')
-rw-r--r--kde-misc/openofficeorg-thumbnail/files/openofficeorg-thumbnail-1.0.0-kf5-support.patch78
-rw-r--r--kde-misc/openofficeorg-thumbnail/openofficeorg-thumbnail-1.0.0-r500.ebuild28
2 files changed, 106 insertions, 0 deletions
diff --git a/kde-misc/openofficeorg-thumbnail/files/openofficeorg-thumbnail-1.0.0-kf5-support.patch b/kde-misc/openofficeorg-thumbnail/files/openofficeorg-thumbnail-1.0.0-kf5-support.patch
new file mode 100644
index 000000000000..53be8ecc2888
--- /dev/null
+++ b/kde-misc/openofficeorg-thumbnail/files/openofficeorg-thumbnail-1.0.0-kf5-support.patch
@@ -0,0 +1,78 @@
+diff -r 16f0dcf220bc CMakeLists.txt
+--- a/CMakeLists.txt Fri Jan 22 18:13:03 2010 -0300
++++ b/CMakeLists.txt Tue Oct 14 10:47:20 2014 +0200
+@@ -1,8 +1,19 @@
+ project(OpenDocumentThumbnail)
+
+-find_package(KDE4 REQUIRED)
+-include (KDE4Defaults)
++cmake_minimum_required(VERSION 2.8.12 FATAL_ERROR)
++set(QT_MIN_VERSION "5.2.0")
+
+-include_directories( ${KDE4_INCLUDES} ${QT_INCLUDES} )
++find_package(ECM 1.0.0 REQUIRED NO_MODULE)
++set(CMAKE_MODULE_PATH ${ECM_MODULE_PATH} ${ECM_KDE_MODULE_DIR})
+
+-add_subdirectory( src )
++include(FeatureSummary)
++include(WriteBasicConfigVersionFile)
++include(KDEInstallDirs)
++include(KDECMakeSettings)
++include(KDECompilerSettings)
++
++find_package(Qt5 ${QT_MIN_VERSION} CONFIG REQUIRED COMPONENTS Gui)
++find_package(KF5 REQUIRED COMPONENTS KIO)
++find_package(KF5Archive)
++
++add_subdirectory(src)
+diff -r 16f0dcf220bc src/CMakeLists.txt
+--- a/src/CMakeLists.txt Fri Jan 22 18:13:03 2010 -0300
++++ b/src/CMakeLists.txt Tue Oct 14 10:47:20 2014 +0200
+@@ -1,12 +1,9 @@
+
+ set(OpenOfficeorgThumbnail_SRCS openofficeorgcreator.cpp)
+
+-qt4_add_resources(OpenOfficeorgThumbnail_SRCS openofficeorgthumbnail.qrc)
++qt5_add_resources(OpenOfficeorgThumbnail_SRCS openofficeorgthumbnail.qrc)
+
+-kde4_add_plugin(openofficeorgthumbnail ${OpenOfficeorgThumbnail_SRCS})
+-
+-target_link_libraries(openofficeorgthumbnail ${KDE4_KIO_LIBS} )
+-
+-install(TARGETS openofficeorgthumbnail DESTINATION ${PLUGIN_INSTALL_DIR} )
+-
++add_library(openofficeorgthumbnail MODULE ${OpenOfficeorgThumbnail_SRCS})
++target_link_libraries(openofficeorgthumbnail KF5::KIOWidgets KF5::Archive)
++install(TARGETS openofficeorgthumbnail DESTINATION ${PLUGIN_INSTALL_DIR})
+ install(FILES openofficeorgthumbnail.desktop DESTINATION ${SERVICES_INSTALL_DIR})
+diff -r 16f0dcf220bc src/opendocumentcreator.cpp
+--- a/src/openofficeorgcreator.cpp Fri Jan 22 18:13:03 2010 -0300
++++ b/src/openofficeorgcreator.cpp Tue Oct 14 10:47:20 2014 +0200
+@@ -28,7 +28,7 @@
+
+ extern "C"
+ {
+- KDE_EXPORT ThumbCreator *new_creator()
++ Q_DECL_EXPORT ThumbCreator *new_creator()
+ {
+ return new OOoCreator;
+ }
+@@ -95,7 +95,7 @@
+
+ ThumbCreator::Flags OOoCreator::flags() const
+ {
+- return (Flags)(DrawFrame | BlendIcon);
++ return (Flags)(DrawFrame);
+ }
+
+
+diff -r 16f0dcf220bc src/opendocumentthumbnail.desktop
+--- a/src/openofficeorgthumbnail.desktop Fri Jan 22 18:13:03 2010 -0300
++++ b/src/openofficeorgthumbnail.desktop Tue Oct 14 10:47:20 2014 +0200
+@@ -5,5 +5,6 @@
+ X-KDE-ServiceTypes=ThumbCreator
+ MimeType=application/vnd.oasis.opendocument.text;application/vnd.oasis.opendocument.text-template;application/vnd.oasis.opendocument.text-master;application/vnd.oasis.opendocument.spreadsheet;application/vnd.oasis.opendocument.spreadsheet-template;application/vnd.oasis.opendocument.graphics;application/vnd.oasis.opendocument.graphics-template;application/vnd.oasis.opendocument.presentation;application/vnd.oasis.opendocument.presentation-template;application/vnd.oasis.opendocument.formula;application/vnd.oasis.opendocument.formula-template;application/vnd.oasis.opendocument.chart;application/vnd.oasis.opendocument.chart-template;
+ X-KDE-Library=openofficeorgthumbnail
++ServiceTypes=ThumbCreator
+ CacheThumbnail=true
+ IgnoreMaximumSize=true
diff --git a/kde-misc/openofficeorg-thumbnail/openofficeorg-thumbnail-1.0.0-r500.ebuild b/kde-misc/openofficeorg-thumbnail/openofficeorg-thumbnail-1.0.0-r500.ebuild
new file mode 100644
index 000000000000..d756db74b3ac
--- /dev/null
+++ b/kde-misc/openofficeorg-thumbnail/openofficeorg-thumbnail-1.0.0-r500.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+MY_PN="OpenOfficeorgThumbnail"
+MY_P="${MY_PN}-${PV}"
+inherit kde5
+
+DESCRIPTION="KDE thumbnail-plugin that generates thumbnails for ODF files"
+HOMEPAGE="http://www.kde-apps.org/content/show.php?content=110864"
+SRC_URI="http://arielch.fedorapeople.org/devel/src/${MY_P}.tar.gz"
+
+LICENSE="LGPL-3"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep karchive)
+ $(add_frameworks_dep kio)
+ $(add_qt_dep qtgui)
+"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+PATCHES=( "${FILESDIR}"/${P}-kf5-support.patch )