summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /kde-plasma/kinfocenter
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'kde-plasma/kinfocenter')
-rw-r--r--kde-plasma/kinfocenter/Manifest2
-rw-r--r--kde-plasma/kinfocenter/files/kcm-about-distrorc4
-rw-r--r--kde-plasma/kinfocenter/kinfocenter-5.3.2.ebuild85
-rw-r--r--kde-plasma/kinfocenter/metadata.xml12
4 files changed, 103 insertions, 0 deletions
diff --git a/kde-plasma/kinfocenter/Manifest b/kde-plasma/kinfocenter/Manifest
new file mode 100644
index 000000000000..a298d8db3dc6
--- /dev/null
+++ b/kde-plasma/kinfocenter/Manifest
@@ -0,0 +1,2 @@
+DIST glogo-small.png 24583 SHA256 0afc3eca084c327f8059166b86769f03c9c23e1e765bb47dc3229505abbac0c6 SHA512 648be463ec3812a2edcdab54d7a230bf2bd7e6895f4ffe72321d8fca28a5e1e0980f6e3b9a32f369c8369943ceb802a65a94b9dad820dcf2c81d4581d814cb48 WHIRLPOOL e161bf40c5e16180fa65217cb49314fb230c45329f4c518d6014083bd71da82d4aa048811ee814fde7fa300105cef16c182688445164ae84d0d700e23641b342
+DIST kinfocenter-5.3.2.tar.xz 1073160 SHA256 79c6ac792c330142f66b1ab01f32e010aa44303bf4d8e3ba422fd02c704f18f1 SHA512 b415e810081f474045ed951e2d20ba9fb75279adfb60a83e0525404449542c707a58f403bbdc37e890957662a3a5e5001b226532bbf4e2f34136819e3df265cc WHIRLPOOL 4d31741943f789803a3c1d401c96a83fc219bcadd1e6c6f86376df2854697f3f2fa273dd7ae277f27ec8954b3434be1bba33a922efcfb0c45142f95661bfb729
diff --git a/kde-plasma/kinfocenter/files/kcm-about-distrorc b/kde-plasma/kinfocenter/files/kcm-about-distrorc
new file mode 100644
index 000000000000..bdae77a9c687
--- /dev/null
+++ b/kde-plasma/kinfocenter/files/kcm-about-distrorc
@@ -0,0 +1,4 @@
+[General]
+Name=Gentoo Linux
+LogoPath=/usr/share/kinfocenter/glogo-small.png
+Website=http://www.gentoo.org/
diff --git a/kde-plasma/kinfocenter/kinfocenter-5.3.2.ebuild b/kde-plasma/kinfocenter/kinfocenter-5.3.2.ebuild
new file mode 100644
index 000000000000..d2a0dcca9fd8
--- /dev/null
+++ b/kde-plasma/kinfocenter/kinfocenter-5.3.2.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KDE_HANDBOOK="true"
+inherit kde5
+
+DESCRIPTION="A utility that provides information about a computer system"
+HOMEPAGE="http://www.kde.org/applications/system/kinfocenter/"
+SRC_URI+=" https://www.gentoo.org/assets/img/logo/gentoo-3d-small.png -> glogo-small.png"
+KEYWORDS="~amd64"
+IUSE="egl gles ieee1394 +opengl +pci samba nfs wayland X"
+
+REQUIRED_USE="egl? ( || ( gles opengl ) )"
+
+COMMON_DEPEND="
+ $(add_frameworks_dep kcmutils)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep kdelibs4support)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep solid)
+ dev-qt/qtgui:5[opengl(+)]
+ dev-qt/qtwidgets:5
+ gles? (
+ dev-qt/qtgui:5[gles2]
+ || (
+ media-libs/mesa[egl,gles1]
+ media-libs/mesa[egl,gles2]
+ )
+ )
+ ieee1394? ( sys-libs/libraw1394 )
+ nfs? ( net-fs/nfs-utils )
+ opengl? (
+ virtual/glu
+ virtual/opengl
+ )
+ pci? ( sys-apps/pciutils )
+ samba? ( net-fs/samba[server(+)] )
+ wayland? ( $(add_plasma_dep kwayland) )
+ X? ( x11-libs/libX11 )
+ !kde-base/kcontrol
+ !kde-base/kinfocenter
+ !kde-misc/about-distro
+"
+RDEPEND="${COMMON_DEPEND}
+ $(add_plasma_dep kde-cli-tools)
+"
+DEPEND="${COMMON_DEPEND}
+ $(add_frameworks_dep plasma)
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package egl EGL)
+ $(cmake-utils_use_find_package gles OpenGLES)
+ $(cmake-utils_use_find_package ieee1394 RAW1394)
+ $(cmake-utils_use_find_package opengl OpenGL)
+ $(cmake-utils_use_find_package pci PCIUTILS)
+ $(cmake-utils_use_find_package wayland KF5Wayland)
+ $(cmake-utils_use_find_package X X11)
+ )
+
+ kde5_src_configure
+}
+
+src_install() {
+ kde5_src_install
+
+ insinto /etc/xdg
+ doins "${FILESDIR}"/kcm-about-distrorc
+
+ insinto /usr/share/${PN}
+ doins "${DISTDIR}"/glogo-small.png
+}
diff --git a/kde-plasma/kinfocenter/metadata.xml b/kde-plasma/kinfocenter/metadata.xml
new file mode 100644
index 000000000000..99dbac6bf0d7
--- /dev/null
+++ b/kde-plasma/kinfocenter/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>kde</herd>
+ <use>
+ <flag name="egl">Retrieve information about OpenGL via EGL</flag>
+ <flag name="gles">Show OpenGL ES information in kinfocenter</flag>
+ <flag name="nfs">Show information about NFS mounts, shares and log entries</flag>
+ <flag name="pci">Show advanced PCI information</flag>
+ <flag name="samba">Show information about Samba mounts, shares and log entries</flag>
+ </use>
+</pkgmetadata>