summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-07-12 16:23:15 -0500
committerAustin English <wizardedit@gentoo.org>2016-07-25 13:25:11 -0500
commitd68b3eb31e7a76f8f94be296fc6c5fa61dc31fcb (patch)
tree65d687c6ab816f60d0fd4797e81a48bf21d1e9a4 /lxqt-base/liblxqt
parentdev-libs/grantlee: keyword ~ppc (diff)
downloadgentoo-d68b3eb31e7a76f8f94be296fc6c5fa61dc31fcb.tar.gz
gentoo-d68b3eb31e7a76f8f94be296fc6c5fa61dc31fcb.tar.bz2
gentoo-d68b3eb31e7a76f8f94be296fc6c5fa61dc31fcb.zip
lxqt-base/liblxqt: fix gcc version check
Also update to EAPI 6 Gentoo-Bug: https://bugs.gentoo.org/588230 Package-Manager: portage-2.3.0
Diffstat (limited to 'lxqt-base/liblxqt')
-rw-r--r--lxqt-base/liblxqt/liblxqt-0.10.0.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/lxqt-base/liblxqt/liblxqt-0.10.0.ebuild b/lxqt-base/liblxqt/liblxqt-0.10.0.ebuild
index 1d47614aad8b..579019e11935 100644
--- a/lxqt-base/liblxqt/liblxqt-0.10.0.ebuild
+++ b/lxqt-base/liblxqt/liblxqt-0.10.0.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
inherit cmake-utils
DESCRIPTION="Common base library for the LXQt desktop environment"
@@ -34,7 +34,7 @@ DEPEND="${RDEPEND}
pkg_pretend() {
if [[ ${MERGE_TYPE} != binary ]]; then
- [[ $(gcc-version) < 4.8 ]] && \
+ tc-is-gcc && [[ $(gcc-version) < 4.8 ]] && \
die 'The active compiler needs to be gcc 4.8 (or newer)'
fi
}