summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2017-12-10 20:37:16 -0500
committerAnthony G. Basile <blueness@gentoo.org>2017-12-10 20:37:32 -0500
commitc27e67813ed4ccb87f255479ec708f58f00a882b (patch)
tree98765a23d701d6e484c703d68d01c55638042c67 /lxqt-base
parentdev-util/qbs: version bump (diff)
downloadgentoo-c27e67813ed4ccb87f255479ec708f58f00a882b.tar.gz
gentoo-c27e67813ed4ccb87f255479ec708f58f00a882b.tar.bz2
gentoo-c27e67813ed4ccb87f255479ec708f58f00a882b.zip
lxqt-base/lxqt-panel: fix build error reported in bug #634222
Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'lxqt-base')
-rw-r--r--lxqt-base/lxqt-panel/files/lxqt-panel-0.11.0-fix-undef-explicit.patch32
-rw-r--r--lxqt-base/lxqt-panel/lxqt-panel-0.11.0.ebuild4
2 files changed, 36 insertions, 0 deletions
diff --git a/lxqt-base/lxqt-panel/files/lxqt-panel-0.11.0-fix-undef-explicit.patch b/lxqt-base/lxqt-panel/files/lxqt-panel-0.11.0-fix-undef-explicit.patch
new file mode 100644
index 000000000000..c6349c25cba0
--- /dev/null
+++ b/lxqt-base/lxqt-panel/files/lxqt-panel-0.11.0-fix-undef-explicit.patch
@@ -0,0 +1,32 @@
+From ec62109e0fa678875a9b10fc6f1975267432712d Mon Sep 17 00:00:00 2001
+From: Palo Kisa <palo.kisa@gmail.com>
+Date: Mon, 30 Jan 2017 12:21:10 +0100
+Subject: [PATCH] plugin-kbindicator: Undef the "explicit" workaround
+
+..after include and add explanation of the workaround.
+
+closes lxde/lxqt#1251
+---
+ plugin-kbindicator/src/x11/kbdlayout.cpp | 7 +++++++
+ 1 file changed, 7 insertions(+)
+
+diff --git a/plugin-kbindicator/src/x11/kbdlayout.cpp b/plugin-kbindicator/src/x11/kbdlayout.cpp
+index c4aa4e27..883df074 100644
+--- a/plugin-kbindicator/src/x11/kbdlayout.cpp
++++ b/plugin-kbindicator/src/x11/kbdlayout.cpp
+@@ -33,8 +33,15 @@
+
+ #include <xkbcommon/xkbcommon-x11.h>
+ #include <xcb/xcb.h>
++
++// Note: We need to override "explicit" as this is a C++ keyword. But it is
++// used as variable name in xkb.h. This is causing a failure in C++ compile
++// time.
++// Similar bug here: https://bugs.freedesktop.org/show_bug.cgi?id=74080
+ #define explicit _explicit
+ #include <xcb/xkb.h>
++#undef explicit
++
+ #include "../kbdinfo.h"
+ #include "../controls.h"
+
diff --git a/lxqt-base/lxqt-panel/lxqt-panel-0.11.0.ebuild b/lxqt-base/lxqt-panel/lxqt-panel-0.11.0.ebuild
index 65f1bebbd9a6..39ae731adb21 100644
--- a/lxqt-base/lxqt-panel/lxqt-panel-0.11.0.ebuild
+++ b/lxqt-base/lxqt-panel/lxqt-panel-0.11.0.ebuild
@@ -55,6 +55,10 @@ RDEPEND="${CDEPEND}
dev-qt/qtsvg:5
>=lxde-base/lxmenu-data-0.1.2"
+PATCHES=(
+ ${FILESDIR}/${P}-fix-undef-explicit.patch
+)
+
src_configure() {
local mycmakeargs i y
mycmakeargs=( -DPULL_TRANSLATIONS=OFF )