summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNP-Hardass <NP-Hardass@gentoo.org>2019-05-12 16:20:06 -0400
committerGöktürk Yüksek <gokturk@gentoo.org>2019-05-12 17:01:08 -0400
commite67b031e0b6c09919330131da8b46d1c17022094 (patch)
treee87aa35e1f8bbb4c0a94b7da6956e208187d65ab /mate-base
parentsys-apps/xdg-desktop-portal: x86 stable (bug #685438) (diff)
downloadgentoo-e67b031e0b6c09919330131da8b46d1c17022094.tar.gz
gentoo-e67b031e0b6c09919330131da8b46d1c17022094.tar.bz2
gentoo-e67b031e0b6c09919330131da8b46d1c17022094.zip
mate-base/mate-desktop: Bump to 1.22.1
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Göktürk Yüksek <gokturk@gentoo.org>
Diffstat (limited to 'mate-base')
-rw-r--r--mate-base/mate-desktop/Manifest1
-rw-r--r--mate-base/mate-desktop/mate-desktop-1.22.1.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/mate-base/mate-desktop/Manifest b/mate-base/mate-desktop/Manifest
index b86c7237f338..ce2a847ee5e7 100644
--- a/mate-base/mate-desktop/Manifest
+++ b/mate-base/mate-desktop/Manifest
@@ -1 +1,2 @@
DIST mate-desktop-1.22.0.tar.xz 962580 BLAKE2B 0bc3418ab25fd9f30e216a5b845722327449f8d05944c028b4cb967acd6415ca9c3c560856485f34e90752c9a3263ba093e1eb69daaea2586c6371ad4c4ee22f SHA512 3950249c0bc026163da7f38a6fd5551c0e1e863e298e9d2ca224679b6c802d1deaf12e16ea873a2ea0539a7989a523d0495fb0dc4c556857203c0b04ab6edf7a
+DIST mate-desktop-1.22.1.tar.xz 901764 BLAKE2B 9da94899d48aa5b949dae466d9a581cd090feeba8b12949cbd9df20e79b8597420fb99785aab14f6a6faf2865e4a4b8356b2a2cc44d5eae087f37e7ec7957541 SHA512 bb2bf9de05439a0fcd4ab01ac628a2a235808cd07c1b7ce9abfbf2e64f98dc572603dfbd4a52bca5f03446825fba199715d7e08fcdc84f0df8d2ffeb4c87da62
diff --git a/mate-base/mate-desktop/mate-desktop-1.22.1.ebuild b/mate-base/mate-desktop/mate-desktop-1.22.1.ebuild
new file mode 100644
index 000000000000..5e9e06c3e18d
--- /dev/null
+++ b/mate-base/mate-desktop/mate-desktop-1.22.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MATE_LA_PUNT="yes"
+
+inherit mate
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+DESCRIPTION="Libraries for the MATE desktop that are not part of the UI"
+LICENSE="GPL-2 FDL-1.1 LGPL-2"
+SLOT="0"
+
+IUSE="X debug +introspection startup-notification"
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.50:2
+ >=gnome-base/dconf-0.13.4
+ x11-libs/cairo
+ x11-libs/libX11
+ >=x11-libs/libXrandr-1.3
+ virtual/libintl
+ >=x11-libs/gtk+-3.22:3[introspection?]
+ introspection? ( >=dev-libs/gobject-introspection-0.9.7:= )
+ startup-notification? ( >=x11-libs/startup-notification-0.5:0 )"
+
+RDEPEND="${COMMON_DEPEND}"
+
+DEPEND="${COMMON_DEPEND}
+ app-text/docbook-xml-dtd:4.1.2
+ app-text/iso-codes
+ dev-util/gtk-doc
+ dev-util/gtk-doc-am
+ >=dev-util/intltool-0.40:*
+ gnome-base/librsvg
+ sys-devel/gettext:*
+ x11-base/xorg-proto
+ virtual/pkgconfig:*"
+
+src_configure() {
+ mate_src_configure \
+ --enable-mate-about \
+ $(use_with X x) \
+ $(use_enable debug) \
+ $(use_enable introspection) \
+ $(use_enable startup-notification)
+}