summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2019-04-03 23:09:01 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2019-04-03 23:29:44 +0200
commit338577317f00d40c4e9e5050fa30c3da62b4ae88 (patch)
tree73b6ab30f86d074ca62164f3baebe9ed4491eac5 /media-gfx/displaycal
parentgnustep-apps/sogo: 4.0.7 bump (diff)
downloadgentoo-338577317f00d40c4e9e5050fa30c3da62b4ae88.tar.gz
gentoo-338577317f00d40c4e9e5050fa30c3da62b4ae88.tar.bz2
gentoo-338577317f00d40c4e9e5050fa30c3da62b4ae88.zip
media-gfx/displaycal: 3.7.2.0 bump
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'media-gfx/displaycal')
-rw-r--r--media-gfx/displaycal/Manifest1
-rw-r--r--media-gfx/displaycal/displaycal-3.7.2.0.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/media-gfx/displaycal/Manifest b/media-gfx/displaycal/Manifest
index 8febbdc91223..5ea4db7b908d 100644
--- a/media-gfx/displaycal/Manifest
+++ b/media-gfx/displaycal/Manifest
@@ -1,3 +1,4 @@
DIST DisplayCAL-3.7.1.2.tar.gz 10472879 BLAKE2B a0722af9c8a6df8af57c0a66e792886b6aecb78bec79d0bed22567bd6ce540793ed6dd51437cbf1974b9070b9adb3708f841cf8cfae0e482056d90783be6ddbd SHA512 d708110e0528ffada5fd4a0ca7da9cf02a54964bc7d5af2b98738aa3e34079c0a4890f2cf6086750045915e06d6c943fc954e0f03653d25c080522a4b24795bd
DIST DisplayCAL-3.7.1.3.tar.gz 10474328 BLAKE2B 9c305809a9f46f3ad76eec728026b2abbd1dec3bee46db92bfe9fe4e7c31f24d61eafaca0bda12f510002d3c5d51bfba4c6d4b1bae5e1ce105a8b75d84672ef8 SHA512 9718f589ee1842f6247ea110c4c6defaf767313fb2fd9ce9fb1b35775141774ce9084c2cbf00d9c432162e8b32c8d789e5a52ca385976c4772bf644738257926
DIST DisplayCAL-3.7.1.4.tar.gz 10478572 BLAKE2B 9f646caea40a22804877f168c2a88a2b3069b8d0e4688c9676bd4d6d873a3528797dd3aadde26da40a4945e224504b2f8673f0c176ced687747ef23d8ca20044 SHA512 d60a240714cf32f1f8084caf74cbccc613263612b7192ad766216ec8253c5682079f32d9cf501e91bf7795ddcce4d9f2f0b023117719d0cc05f203d51dc3ef42
+DIST DisplayCAL-3.7.2.0.tar.gz 10536990 BLAKE2B c3e0c1b75c10911b1624d56f4e5d612eba8c257b5abd8a4632f13d91285283d870d928ad3eb17a9cd620b7fed4b9e5414495e12227fb2b94e3da2551d14042bd SHA512 f516376a84680daa2baffa0b4738f52e5dc6df374ae5d97ed385430e2744a087e044faa4929fdc84b01d79878b44e15eda5fa75b40b8a78e6962f66fc06876d4
diff --git a/media-gfx/displaycal/displaycal-3.7.2.0.ebuild b/media-gfx/displaycal/displaycal-3.7.2.0.ebuild
new file mode 100644
index 000000000000..d6063154f815
--- /dev/null
+++ b/media-gfx/displaycal/displaycal-3.7.2.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 gnome2-utils xdg
+
+MY_PN="DisplayCAL"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Display calibration and characterization powered by Argyll CMS"
+HOMEPAGE="https://displaycal.net/"
+SRC_URI="mirror://sourceforge/dispcalgui/${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ >=media-gfx/argyllcms-1.1.0
+ dev-python/wxpython:3.0
+ >=x11-libs/libX11-1.3.3
+ >=x11-apps/xrandr-1.3.2
+ >=x11-libs/libXxf86vm-1.1.0
+ >=x11-libs/libXinerama-1.1
+"
+RDEPEND="${DEPEND}
+ >=dev-python/numpy-1.2.1
+"
+
+# Just in case someone renames the ebuild
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ # Do not generate udev/hotplug files
+ sed -e '/if os.path.isdir/s#/etc/udev/rules.d\|/etc/hotplug#\0-non-existant#' \
+ -i DisplayCAL/setup.py || die
+ # Prohibit setup from running xdg-* programs, resulting to sandbox violation
+ sed -e '/if which/s#xdg-icon-resource#\0-non-existant#' \
+ -e '/if which/s#xdg-desktop-menu#\0-non-existant#' \
+ -i DisplayCAL/postinstall.py || die
+
+ # Remove deprecated Encoding key from .desktop file
+ sed -e '/Encoding=UTF-8/d' -i misc/*.desktop || die
+
+ # Remove x-world Media Type
+ sed -e 's/x\-world\/x\-vrml\;//g' \
+ -i misc/displaycal-vrml-to-x3d-converter.desktop || die
+
+ distutils-r1_src_prepare
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_icon_cache_update
+}