summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2020-03-02 10:01:22 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2020-03-02 10:01:22 +0100
commit3f4b652e1f9f4598fdada2956e1572bc50e189ea (patch)
treef9167867f91edacde40e5e2d3d965f02989fec80 /media-gfx/displaycal
parentdev-python/tld: 0.11.10 bump (diff)
downloadgentoo-3f4b652e1f9f4598fdada2956e1572bc50e189ea.tar.gz
gentoo-3f4b652e1f9f4598fdada2956e1572bc50e189ea.tar.bz2
gentoo-3f4b652e1f9f4598fdada2956e1572bc50e189ea.zip
media-gfx/displaycal: 3.8.9.3 bump
Not run-tested as it is still python2-only sadly Package-Manager: Portage-2.3.91, Repoman-2.3.20 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'media-gfx/displaycal')
-rw-r--r--media-gfx/displaycal/Manifest1
-rw-r--r--media-gfx/displaycal/displaycal-3.8.9.3.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/media-gfx/displaycal/Manifest b/media-gfx/displaycal/Manifest
index 0a6d3db0067d..109e794f17a6 100644
--- a/media-gfx/displaycal/Manifest
+++ b/media-gfx/displaycal/Manifest
@@ -1 +1,2 @@
DIST DisplayCAL-3.8.8.1.tar.gz 10625317 BLAKE2B 3e988221ee7d75d5a34b1cd69ab80737017c7e7a0fa16c3bc1587210b6b1108e623a3ccada3be8b99fae4c0a70f2cf45293222232f87f0ac13fedf2a1f22fcbd SHA512 e16cdc4590274f10fc122e18a5d94a1d326c43bc132e7af97c6f28c5a656f02203cfb7c73b92fa98d3ee2a8bbf560514615bc9b34c881d2758a5a6f2867092b3
+DIST DisplayCAL-3.8.9.3.tar.gz 10639277 BLAKE2B b99d2a39eb707654799b089a8f14891b257a27cb209511ed04ea6e2de7ec4bc3e68db884ebc460e25325495645d1a851b936f91632c571a385e009ea6b9cd6d2 SHA512 cece09605c12be6a154d8d8b088005e527a9e6674a89ec2787b0687a92b7f424749681f149a07bb798df6729c9f4c37e8760abeec115a014c06f94f25fc2f904
diff --git a/media-gfx/displaycal/displaycal-3.8.9.3.ebuild b/media-gfx/displaycal/displaycal-3.8.9.3.ebuild
new file mode 100644
index 000000000000..09d6133dd94c
--- /dev/null
+++ b/media-gfx/displaycal/displaycal-3.8.9.3.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 gnome2-utils xdg
+
+MY_PN="DisplayCAL"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Display calibration and characterization powered by Argyll CMS"
+HOMEPAGE="https://displaycal.net/"
+SRC_URI="mirror://sourceforge/dispcalgui/${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ >=media-gfx/argyllcms-1.1.0
+ dev-python/wxpython:3.0[${PYTHON_USEDEP}]
+ >=x11-libs/libX11-1.3.3
+ >=x11-apps/xrandr-1.3.2
+ >=x11-libs/libXxf86vm-1.1.0
+ >=x11-libs/libXinerama-1.1
+"
+RDEPEND="${DEPEND}
+ dev-python/faulthandler[${PYTHON_USEDEP}]
+ || (
+ dev-python/numpy-python2[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.2.1[${PYTHON_USEDEP}]
+ )
+"
+
+# Just in case someone renames the ebuild
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ # Do not generate udev/hotplug files
+ sed -e '/if os.path.isdir/s#/etc/udev/rules.d\|/etc/hotplug#\0-non-existant#' \
+ -i DisplayCAL/setup.py || die
+ # Prohibit setup from running xdg-* programs, resulting to sandbox violation
+ sed -e '/if which/s#xdg-icon-resource#\0-non-existant#' \
+ -e '/if which/s#xdg-desktop-menu#\0-non-existant#' \
+ -i DisplayCAL/postinstall.py || die
+
+ # Remove deprecated Encoding key from .desktop file
+ sed -e '/Encoding=UTF-8/d' -i misc/*.desktop || die
+
+ # Remove x-world Media Type
+ sed -e 's/x\-world\/x\-vrml\;//g' \
+ -i misc/displaycal-vrml-to-x3d-converter.desktop || die
+
+ distutils-r1_src_prepare
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_icon_cache_update
+}