summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2018-11-29 13:22:21 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2018-11-29 13:26:16 +0100
commita2befc95d38ae80a0c183d83c6d3239c4d12d1bb (patch)
tree076bec11d2a487aee7fa7c46fb0bc0c845797681 /media-gfx/displaycal
parentmedia-gfx/displaycal: drop old (diff)
downloadgentoo-a2befc95d38ae80a0c183d83c6d3239c4d12d1bb.tar.gz
gentoo-a2befc95d38ae80a0c183d83c6d3239c4d12d1bb.tar.bz2
gentoo-a2befc95d38ae80a0c183d83c6d3239c4d12d1bb.zip
media-gfx/displaycal: 3.7.1.2 bump
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'media-gfx/displaycal')
-rw-r--r--media-gfx/displaycal/Manifest1
-rw-r--r--media-gfx/displaycal/displaycal-3.7.1.2.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/media-gfx/displaycal/Manifest b/media-gfx/displaycal/Manifest
index db365fbae68c..6caad1828f6b 100644
--- a/media-gfx/displaycal/Manifest
+++ b/media-gfx/displaycal/Manifest
@@ -1,2 +1,3 @@
DIST DisplayCAL-3.6.2.0.tar.gz 10437261 BLAKE2B c476c7834e2c723c48fb9ad9d2ea7f4919c2636814078d8f1a83a6af0e91586e0762ea3787c90f8625cba672ac72ef5e1d2dd6906fd3fd7f3b67637a180b81e3 SHA512 e66a20edf46d460caf5d2f7ddbc93cfe7c37937cd4933d2a2b7d141676696c6f22aadc07d229fbaefe0ced62066fc99d3290352c3e8fc9db4b95a8d0541f0be7
DIST DisplayCAL-3.7.1.1.tar.gz 10472440 BLAKE2B 2e53537a7570c37120a462102269b5c042299df3de0926b0221bef8b5c29d75e7983b359d9ad162e2d9df2819c624d5f0c00c65fa181cce3fa831f1791d7a1fd SHA512 d5d18b25dd4ce6a2b328db6adb55c43ffcb3e3a495be38004d9e6a6e5c8d576b9477dc895668f82210ce955e7854a578218cb8c9ca2c206f58c47a011ad99c09
+DIST DisplayCAL-3.7.1.2.tar.gz 10472879 BLAKE2B a0722af9c8a6df8af57c0a66e792886b6aecb78bec79d0bed22567bd6ce540793ed6dd51437cbf1974b9070b9adb3708f841cf8cfae0e482056d90783be6ddbd SHA512 d708110e0528ffada5fd4a0ca7da9cf02a54964bc7d5af2b98738aa3e34079c0a4890f2cf6086750045915e06d6c943fc954e0f03653d25c080522a4b24795bd
diff --git a/media-gfx/displaycal/displaycal-3.7.1.2.ebuild b/media-gfx/displaycal/displaycal-3.7.1.2.ebuild
new file mode 100644
index 000000000000..02f4e0b4a7e5
--- /dev/null
+++ b/media-gfx/displaycal/displaycal-3.7.1.2.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 gnome2-utils xdg
+
+MY_PN="DisplayCAL"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Display calibration and characterization powered by Argyll CMS"
+HOMEPAGE="https://displaycal.net/"
+SRC_URI="mirror://sourceforge/dispcalgui/${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ >=media-gfx/argyllcms-1.1.0
+ dev-python/wxpython:3.0
+ >=x11-libs/libX11-1.3.3
+ >=x11-apps/xrandr-1.3.2
+ >=x11-libs/libXxf86vm-1.1.0
+ >=x11-libs/libXinerama-1.1
+"
+RDEPEND="${DEPEND}
+ >=dev-python/numpy-1.2.1
+"
+
+# Just in case someone renames the ebuild
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ # Do not generate udev/hotplug files
+ sed -e '/if os.path.isdir/s#/etc/udev/rules.d\|/etc/hotplug#\0-non-existant#' \
+ -i DisplayCAL/setup.py || die
+ # Prohibit setup from running xdg-* programs, resulting to sandbox violation
+ sed -e '/if which/s#xdg-icon-resource#\0-non-existant#' \
+ -e '/if which/s#xdg-desktop-menu#\0-non-existant#' \
+ -i DisplayCAL/postinstall.py || die
+
+ # Remove deprecated Encoding key from .desktop file
+ sed -e '/Encoding=UTF-8/d' -i misc/*.desktop || die
+
+ # Remove x-world Media Type
+ sed -e 's/x\-world\/x\-vrml\;//g' \
+ -i misc/displaycal-vrml-to-x3d-converter.desktop || die
+
+ distutils-r1_src_prepare
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_icon_cache_update
+}