summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-05-21 02:37:52 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-05-21 02:38:31 +0200
commitb951f8c8f6b31320104e5bdca3bedeafe24b47ea (patch)
treea97b65d15a6be1b40e831b090d1a7a2bf9cada91 /media-gfx/fotowall
parentmedia-gfx/fotowall: EAPI-7 bump (diff)
downloadgentoo-b951f8c8f6b31320104e5bdca3bedeafe24b47ea.tar.gz
gentoo-b951f8c8f6b31320104e5bdca3bedeafe24b47ea.tar.bz2
gentoo-b951f8c8f6b31320104e5bdca3bedeafe24b47ea.zip
media-gfx/fotowall: Fix build w/ Qt 5.15
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-gfx/fotowall')
-rw-r--r--media-gfx/fotowall/files/fotowall-1.0-qt-5.11.patch2
-rw-r--r--media-gfx/fotowall/files/fotowall-1.0-qt-5.15.patch24
-rw-r--r--media-gfx/fotowall/fotowall-1.0.ebuild5
3 files changed, 29 insertions, 2 deletions
diff --git a/media-gfx/fotowall/files/fotowall-1.0-qt-5.11.patch b/media-gfx/fotowall/files/fotowall-1.0-qt-5.11.patch
index db619771b476..b3ce481cbf49 100644
--- a/media-gfx/fotowall/files/fotowall-1.0-qt-5.11.patch
+++ b/media-gfx/fotowall/files/fotowall-1.0-qt-5.11.patch
@@ -2,7 +2,7 @@ Fix build with Qt 5.11.
Bug: https://bugs.gentoo.org/661596
---- a/App/tmp/CanvasAppliance.h
+--- a/App/CanvasAppliance.h
+++ b/App/CanvasAppliance.h
@@ -17,6 +17,9 @@
diff --git a/media-gfx/fotowall/files/fotowall-1.0-qt-5.15.patch b/media-gfx/fotowall/files/fotowall-1.0-qt-5.15.patch
new file mode 100644
index 000000000000..12f0e988ee23
--- /dev/null
+++ b/media-gfx/fotowall/files/fotowall-1.0-qt-5.15.patch
@@ -0,0 +1,24 @@
+From 72f7a502cb2397b0ef459e6e8f429db1d3482be6 Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Thu, 21 May 2020 02:33:38 +0200
+Subject: [PATCH] Fix build with Qt 5.15 (missing QPainterPath include)
+
+---
+ 3rdparty/posterazor/paintcanvas.cpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/3rdparty/posterazor/paintcanvas.cpp b/3rdparty/posterazor/paintcanvas.cpp
+index df33b8a..fd0f319 100644
+--- a/3rdparty/posterazor/paintcanvas.cpp
++++ b/3rdparty/posterazor/paintcanvas.cpp
+@@ -23,6 +23,7 @@
+ #include "paintcanvas.h"
+ #include <QImage>
+ #include <QPainter>
++#include <QPainterPath>
+
+ PaintCanvas::PaintCanvas(QWidget *parent)
+ : QWidget(parent)
+--
+2.26.2
+
diff --git a/media-gfx/fotowall/fotowall-1.0.ebuild b/media-gfx/fotowall/fotowall-1.0.ebuild
index 2b3595f6cebd..2433ced68ec4 100644
--- a/media-gfx/fotowall/fotowall-1.0.ebuild
+++ b/media-gfx/fotowall/fotowall-1.0.ebuild
@@ -28,7 +28,10 @@ DEPEND="${RDEPEND}
webcam? ( media-libs/libv4l )
"
-PATCHES=( "${FILESDIR}/${P}-qt-5.11.patch" )
+PATCHES=(
+ "${FILESDIR}/${P}-qt-5.11.patch"
+ "${FILESDIR}/${P}-qt-5.15.patch"
+)
src_prepare() {
default