summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Bock <nicolasbock@gentoo.org>2017-12-24 07:34:42 -0700
committerNicolas Bock <nicolasbock@gentoo.org>2017-12-24 07:35:01 -0700
commitee82f539e45e70384b920dc7ddcd9e8e5f4f8010 (patch)
tree8fe7f9d402f625edde30986694decf222811aa54 /media-gfx/shotwell
parentdev-libs/capstone: add missing 'setuptools' DEPEND, bug #640266 (diff)
downloadgentoo-ee82f539e45e70384b920dc7ddcd9e8e5f4f8010.tar.gz
gentoo-ee82f539e45e70384b920dc7ddcd9e8e5f4f8010.tar.bz2
gentoo-ee82f539e45e70384b920dc7ddcd9e8e5f4f8010.zip
media-gfx/shotwell: Version bump to shotwell-0.27.2
Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'media-gfx/shotwell')
-rw-r--r--media-gfx/shotwell/Manifest1
-rw-r--r--media-gfx/shotwell/shotwell-0.27.2.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/media-gfx/shotwell/Manifest b/media-gfx/shotwell/Manifest
index cf2e7619a3ec..8570abe1f8e6 100644
--- a/media-gfx/shotwell/Manifest
+++ b/media-gfx/shotwell/Manifest
@@ -7,3 +7,4 @@ DIST shotwell-0.26.3.tar.xz 5581204 BLAKE2B 1b28be1bef1b5b9305020d92bca8b535b7a4
DIST shotwell-0.26.4.tar.xz 5619280 BLAKE2B 0ca9ecf6e96019aa8e9bd4bae09d1b888902fc054633271854e09e1fa9b474774b7b5f2e6e3bcfed60a5b0f3ba30a2d89133d2676a94db5f4da6ee6a0af41102 SHA512 6a0772a40759d636807652ef27814306cbc2217119b071590db36c628b6e9d04f876ae1748c88476fbebc1db0c83e6a108c9f74261b7faa348c6bd37c1da198d
DIST shotwell-0.27.0.tar.xz 5574988 BLAKE2B 30ab9ebe5fa12f8d7be3775d044b983c644b1b88e6ca4a69522db0c3859f55846b785761ced8e1af8da8c4ec72c4b46925c6a77dd2f995936c12638913856c2c SHA512 e7b5fe153fff96e04507588b4b8a1e71c121787cb6d28b7e14bb31824f1a09ca1948edc4bccfa069b2ffebe1ac753580257c1af4b7aec0ed49af74944ee91fbb
DIST shotwell-0.27.1.tar.xz 5619824 BLAKE2B 7ba1606b1604ca156aacd71d014bdec507abd2a5447696b60ce4400cf835dd484b39e737ec7659a8744e0a5f72b9e9a561fb297db6f256db7008ca5e4b2ae0d8 SHA512 b26c25b45af305903cf0698e65d5230820dda447b70175c92a66e25148e47d620847b3fa2b3bdb8d70656186d5b30d98edf3eee4138f07db9f8260e81a95a7d6
+DIST shotwell-0.27.2.tar.xz 5619692 BLAKE2B 0a532d6d2f7391f0783cb0fb91fbc15a681e87041d12355ca75581d4b7f4ebe7fe3feeaca7fc12b0fd82710bf2d906c1d3abd382b61a5dfac3041cec482edd38 SHA512 a64fec52ff1ba3bca0e4b07be557ea3b838845998ae64ac7504cd9a8c976380cf0d7aae4aaccf931f1f40b5d247e081ec98472da8e8835363779dd39d9d2f69b
diff --git a/media-gfx/shotwell/shotwell-0.27.2.ebuild b/media-gfx/shotwell/shotwell-0.27.2.ebuild
new file mode 100644
index 000000000000..0cafa2080fcf
--- /dev/null
+++ b/media-gfx/shotwell/shotwell-0.27.2.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+VALA_MIN_API_VERSION="0.28"
+
+inherit gnome2 multilib toolchain-funcs vala versionator
+
+MY_PV=$(get_version_component_range 1-2)
+DESCRIPTION="Open source photo manager for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Shotwell"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="
+ >=app-crypt/gcr-3[gtk]
+ >=dev-db/sqlite-3.5.9:3
+ >=dev-libs/glib-2.40.0:2
+ >=dev-libs/json-glib-0.7.6
+ >=dev-libs/libgee-0.8.5:0.8
+ >=dev-libs/libxml2-2.6.32:2
+ gnome-base/dconf
+ >=media-libs/gexiv2-0.10.4
+ media-libs/gst-plugins-base:1.0
+ media-libs/gst-plugins-good:1.0
+ media-libs/gstreamer:1.0
+ media-libs/lcms:2
+ >=media-libs/libexif-0.6.16:=
+ >=media-libs/libgphoto2-2.5:=
+ >=media-libs/libraw-0.13.2:=
+ media-plugins/gst-plugins-gdkpixbuf:1.0
+ >=net-libs/libsoup-2.42.0:2.4
+ net-libs/webkit-gtk:4
+ virtual/libgudev:=[introspection]
+ >=x11-libs/gtk+-3.14.0:3[X]
+ dev-libs/libgdata
+
+"
+DEPEND="${RDEPEND}
+ $(vala_depend)
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.7
+ >=sys-devel/m4-1.4.13
+ virtual/pkgconfig
+"
+
+# This probably comes from libraries that
+# shotwell-video-thumbnailer links to.
+# Nothing we can do at the moment. #435048
+QA_FLAGS_IGNORED="/usr/libexec/${PN}/${PN}-video-thumbnailer"
+
+src_prepare() {
+ vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure --disable-static
+}