summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-12-05 17:10:05 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2017-12-05 17:15:10 +0100
commit4c6eada07c811dc3bd34ce06907d3a5cd8cafe54 (patch)
treebe37efc9906a247550dd429433900972590bde4f /media-gfx
parentapp-forensics/sleuthkit: remove unused patch (diff)
downloadgentoo-4c6eada07c811dc3bd34ce06907d3a5cd8cafe54.tar.gz
gentoo-4c6eada07c811dc3bd34ce06907d3a5cd8cafe54.tar.bz2
gentoo-4c6eada07c811dc3bd34ce06907d3a5cd8cafe54.zip
media-gfx/exiv2: Fix crash with Pentax/Nikon exif data
Bug: https://bugs.gentoo.org/626214 Package-Manager: Portage-2.3.13, Repoman-2.3.4
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/exiv2/Manifest2
-rw-r--r--media-gfx/exiv2/exiv2-0.26_p20171104-r1.ebuild129
-rw-r--r--media-gfx/exiv2/files/exiv2-0.26-pentaxnikon-crash.patch52
3 files changed, 182 insertions, 1 deletions
diff --git a/media-gfx/exiv2/Manifest b/media-gfx/exiv2/Manifest
index 44859a8fee71..a9b1bd775e2b 100644
--- a/media-gfx/exiv2/Manifest
+++ b/media-gfx/exiv2/Manifest
@@ -1 +1 @@
-DIST exiv2-0.26_p20171104.tar.gz 28368697 SHA256 f7a46c0b1d3d3c30518202e62dbe086029f584a064bbb531a0ab11270a454007 SHA512 6f6a884d7978e54dceb9ce45248cd0425ff469887c85ef52b0e38cb755970f69fce96b4b5317c8e8070b833f72ca214696042aac71292a6f9c3440f6a369d474 WHIRLPOOL 7baf5fcde327b2e1decde48f44b616f98fab7c65d22ee5e94e0b356fad4d7950c116db17a94b3c91954ac1565c3fe2853b83262c0a4597744dea708b304dce09
+DIST exiv2-0.26_p20171104.tar.gz 28368697 BLAKE2B 50013cf0bf30a2a476b02d5db4027fca268a4b38733762eb4c08e5f3bdfaf737038e9a62f7ef471fecb10250d8ae686ef683f9b0ea4ccc5d109440ba534371e4 SHA512 6f6a884d7978e54dceb9ce45248cd0425ff469887c85ef52b0e38cb755970f69fce96b4b5317c8e8070b833f72ca214696042aac71292a6f9c3440f6a369d474
diff --git a/media-gfx/exiv2/exiv2-0.26_p20171104-r1.ebuild b/media-gfx/exiv2/exiv2-0.26_p20171104-r1.ebuild
new file mode 100644
index 000000000000..f7eb67dc5bf2
--- /dev/null
+++ b/media-gfx/exiv2/exiv2-0.26_p20171104-r1.ebuild
@@ -0,0 +1,129 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+LINGUAS="bs de es fi fr gl ms pl pt ru sk sv ug uk vi"
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+if [[ ${PV} = *9999 ]]; then
+ EGIT_REPO_URI="https://github.com/Exiv2/exiv2.git"
+ EGIT_BRANCH="0.26"
+ GIT_ECLASS=git-r3
+else
+ COMMIT=900d2417dbeb46e14cbf65fc2798ed1d043ab76d
+ SRC_URI="https://github.com/Exiv2/${PN}/tarball/${COMMIT} -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x64-solaris ~x86-solaris"
+fi
+inherit cmake-multilib python-any-r1 vcs-snapshot
+
+DESCRIPTION="EXIF, IPTC and XMP metadata C++ library and command line utility"
+HOMEPAGE="http://www.exiv2.org/"
+
+LICENSE="GPL-2"
+SLOT="0/26"
+IUSE="doc examples nls png webready xmp $(printf 'linguas_%s ' ${LINGUAS})"
+
+RDEPEND="
+ >=virtual/libiconv-0-r1[${MULTILIB_USEDEP}]
+ nls? ( >=virtual/libintl-0-r1[${MULTILIB_USEDEP}] )
+ png? ( >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}] )
+ webready? (
+ net-libs/libssh[${MULTILIB_USEDEP}]
+ net-misc/curl[${MULTILIB_USEDEP}]
+ )
+ xmp? ( >=dev-libs/expat-2.1.0-r3[${MULTILIB_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ doc? (
+ ${PYTHON_DEPS}
+ app-doc/doxygen
+ dev-libs/libxslt
+ media-gfx/graphviz
+ virtual/pkgconfig
+ )
+ nls? ( sys-devel/gettext )
+"
+
+DOCS=( README doc/ChangeLog doc/cmd.txt )
+
+PATCHES=(
+ # TODO: Take to upstream
+ "${FILESDIR}"/${PN}-0.26-fix-docs.patch
+ "${FILESDIR}"/${PN}-0.26-tools-optional.patch
+ "${FILESDIR}"/${PN}-0.26-pentaxnikon-crash.patch
+)
+
+pkg_setup() {
+ use doc && python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ if [[ ${PV} != *9999 ]] ; then
+ if [[ -d po ]] ; then
+ pushd po > /dev/null || die
+ local lang
+ for lang in *.po; do
+ if [[ -e ${lang} ]] && ! has ${lang/.po/} ${LINGUAS} ; then
+ case ${lang} in
+ CMakeLists.txt | \
+ ${PN}.pot) ;;
+ *) rm -r ${lang} || die ;;
+ esac
+ fi
+ done
+ popd > /dev/null || die
+ else
+ die "Failed to prepare LINGUAS - po directory moved?"
+ fi
+ fi
+
+ # FIXME @upstream:
+ einfo "Converting doc/cmd.txt to UTF-8"
+ iconv -f LATIN1 -t UTF-8 doc/cmd.txt > doc/cmd.txt.tmp || die
+ mv -f doc/cmd.txt.tmp doc/cmd.txt || die
+
+ if use doc; then
+ einfo "Updating doxygen config"
+ doxygen &>/dev/null -u config/Doxyfile || die
+ fi
+
+ cmake-utils_src_prepare
+}
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DEXIV2_ENABLE_BUILD_SAMPLES=NO
+ -DEXIV2_ENABLE_BUILD_PO=$(usex nls)
+ -DEXIV2_ENABLE_NLS=$(usex nls)
+ -DEXIV2_ENABLE_PNG=$(usex png)
+ -DEXIV2_ENABLE_CURL=$(usex webready)
+ -DEXIV2_ENABLE_SSH=$(usex webready)
+ -DEXIV2_ENABLE_WEBREADY=$(usex webready)
+ -DEXIV2_ENABLE_XMP=$(usex xmp)
+ -DEXIV2_ENABLE_LIBXMP=NO
+ $(multilib_is_native_abi || echo -DEXIV2_ENABLE_TOOLS=NO)
+ )
+
+ cmake-utils_src_configure
+}
+
+multilib_src_compile() {
+ cmake-utils_src_compile
+
+ if multilib_is_native_abi; then
+ use doc && emake -j1 doc
+ fi
+}
+
+multilib_src_install_all() {
+ use xmp && DOCS+=( doc/{COPYING-XMPSDK,README-XMP,cmdxmp.txt} )
+ use doc && HTML_DOCS=( "${S}"/doc/html/. )
+
+ einstalldocs
+ find "${D}" -name '*.la' -delete || die
+
+ if use examples; then
+ docinto examples
+ dodoc samples/*.cpp
+ fi
+}
diff --git a/media-gfx/exiv2/files/exiv2-0.26-pentaxnikon-crash.patch b/media-gfx/exiv2/files/exiv2-0.26-pentaxnikon-crash.patch
new file mode 100644
index 000000000000..a66af8d5dc96
--- /dev/null
+++ b/media-gfx/exiv2/files/exiv2-0.26-pentaxnikon-crash.patch
@@ -0,0 +1,52 @@
+From 2dc166b04ca6152d01bff6627a332e89ddef24d1 Mon Sep 17 00:00:00 2001
+From: clanmills <robin@clanmills.com>
+Date: Tue, 12 Sep 2017 09:14:42 +0100
+Subject: [PATCH 1/2] Fix http://dev.exiv2.org/issues/1305
+
+---
+ src/pentaxmn.cpp | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/src/pentaxmn.cpp b/src/pentaxmn.cpp
+index 4fc38be0..b22cb43b 100644
+--- a/src/pentaxmn.cpp
++++ b/src/pentaxmn.cpp
+@@ -1167,6 +1167,8 @@ namespace Exiv2 {
+
+ std::ostream& PentaxMakerNote::printShutterCount(std::ostream& os, const Value& value, const ExifData* metadata)
+ {
++ if ( ! metadata ) return os << "undefined" ;
++
+ ExifData::const_iterator dateIt = metadata->findKey(
+ ExifKey("Exif.PentaxDng.Date"));
+ if (dateIt == metadata->end()) {
+--
+2.13.6
+
+
+From 3bc0b91bcecefdad531129b1a934be1251021c95 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?M=C4=81ris=20Narti=C5=A1s?= <mn@sungis.lv>
+Date: Mon, 18 Sep 2017 23:37:40 +0300
+Subject: [PATCH 2/2] Fix crash on undefined metadata on some Nikon images.
+ Identical to commit:5405d61623e82896e498c5c8342dd6f42e689115
+
+---
+ src/nikonmn.cpp | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/src/nikonmn.cpp b/src/nikonmn.cpp
+index 571ab806..34bf601c 100644
+--- a/src/nikonmn.cpp
++++ b/src/nikonmn.cpp
+@@ -299,6 +299,8 @@ namespace Exiv2 {
+ const Value& value,
+ const ExifData* exifData)
+ {
++ if ( ! exifData ) return os << "undefined" ;
++
+ if ( value.count() >= 9 ) {
+ ByteOrder bo = getKeyString("Exif.MakerNote.ByteOrder",exifData) == "MM" ? bigEndian : littleEndian;
+ byte p[4];
+--
+2.13.6
+