summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2015-09-19 18:39:33 +0200
committerThomas Beierlein <tomjbe@gentoo.org>2015-09-19 18:42:00 +0200
commit21ca65c01c7a57a599cdb999cdd3612bffc579d5 (patch)
treee50dcffb82e009b58ed225ede27fbd219ef2d701 /media-libs/hamlib/hamlib-3.0.ebuild
parentsys-devel/binutils: add alpha keyword (diff)
downloadgentoo-21ca65c01c7a57a599cdb999cdd3612bffc579d5.tar.gz
gentoo-21ca65c01c7a57a599cdb999cdd3612bffc579d5.tar.bz2
gentoo-21ca65c01c7a57a599cdb999cdd3612bffc579d5.zip
media-libs/hamlib: Major version bump
Diffstat (limited to 'media-libs/hamlib/hamlib-3.0.ebuild')
-rw-r--r--media-libs/hamlib/hamlib-3.0.ebuild83
1 files changed, 83 insertions, 0 deletions
diff --git a/media-libs/hamlib/hamlib-3.0.ebuild b/media-libs/hamlib/hamlib-3.0.ebuild
new file mode 100644
index 000000000000..ad9ec0a406a3
--- /dev/null
+++ b/media-libs/hamlib/hamlib-3.0.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit autotools-utils eutils multilib python-single-r1
+
+DESCRIPTION="Ham radio backend rig control libraries"
+HOMEPAGE="http://sourceforge.net/apps/mediawiki/hamlib"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2 GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE="doc perl python tcl"
+
+RESTRICT="test"
+
+RDEPEND="
+ =virtual/libusb-0*
+ dev-libs/libxml2
+ sys-libs/readline:0
+ perl? ( dev-lang/perl )
+ python? ( ${PYTHON_DEPS} )
+ tcl? ( dev-lang/tcl:0= )"
+
+DEPEND=" ${RDEPEND}
+ virtual/pkgconfig
+ dev-lang/swig
+ >=sys-devel/libtool-2.2
+ doc? ( app-doc/doxygen )"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DOCS=(AUTHORS NEWS PLAN README README.betatester README.developer TODO)
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ # fix hardcoded libdir paths
+ sed -i -e "s#fix}/lib#fix}/$(get_libdir)/hamlib#" \
+ -e "s#fix}/include#fix}/include/hamlib#" \
+ hamlib.pc.in || die "sed failed"
+
+ # make building of documentation compatible with autotools-utils
+ sed -i -e "s/doc:/html:/g" doc/Makefile.am || die "sed failed"
+
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --libdir=/usr/$(get_libdir)/hamlib
+ --disable-static
+ --with-xml-support
+ $(use_with perl perl-binding)
+ $(use_with python python-binding)
+ $(use_with tcl tcl-binding)
+ --disable-silent-rules
+ )
+ autotools-utils_src_configure
+}
+
+src_compile() {
+ autotools-utils_src_compile
+ use doc && autotools-utils_src_compile html
+}
+
+src_install() {
+ use doc && HTML_DOCS=("${AUTOTOOLS_BUILD_DIR}/doc/html/")
+ autotools-utils_src_install
+
+ insinto /usr/$(get_libdir)/pkgconfig
+ doins "${AUTOTOOLS_BUILD_DIR}"/hamlib.pc || die "doins failed"
+
+ echo "LDPATH=/usr/$(get_libdir)/hamlib" > "${T}"/73hamlib
+ doenvd "${T}"/73hamlib || die "doenvd failed"
+}