summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-radio/xwxapt
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-radio/xwxapt')
-rw-r--r--media-radio/xwxapt/Manifest2
-rw-r--r--media-radio/xwxapt/metadata.xml8
-rw-r--r--media-radio/xwxapt/xwxapt-2.1.ebuild45
-rw-r--r--media-radio/xwxapt/xwxapt-2.2.ebuild43
4 files changed, 98 insertions, 0 deletions
diff --git a/media-radio/xwxapt/Manifest b/media-radio/xwxapt/Manifest
new file mode 100644
index 000000000000..80b1ee6e32d8
--- /dev/null
+++ b/media-radio/xwxapt/Manifest
@@ -0,0 +1,2 @@
+DIST xwxapt-2.1.tar.bz2 63986 SHA256 59e20721e70710ab99b78070b4ff5cae1ec4ed8b86f5bbd2a82a909856ad4a9d SHA512 17c31bf2732fb8215e139488551c5b4185a401c1f9d455f425e2373b7afc1ec401c536a832635501018415c64b71763a927e16ab05d8723fab932e9031775d5c WHIRLPOOL c432fcca1da233a98cb6efc31e40d7490d61b26e733fa5c8a7f398f3f6b0190f4bd33caa508960084fb49aeeb6e35242a3f889e469f99755fdebe29b050e54dd
+DIST xwxapt-2.2.tar.bz2 145635 SHA256 2ed1d7a2c7e7c4142fa0562ec17bb220ba3bd7a53412a7fac2bb6dc1ddac883e SHA512 debb539d57df4cf2bc550ad6000bd0aa8ad9acb107d3854fcf83c35b967f9feec7ae4d04a2998ecd9eaf91864bae7b48b88299e4f92cde2d0795077b24fc07a7 WHIRLPOOL 065813228f9f8fd212f367ccea8054d7b065f1f48b1cd2727099804a6949683caf5e592381e84abb2467933b04e27acc28aed904d0a5221f95b45a412b288cd6
diff --git a/media-radio/xwxapt/metadata.xml b/media-radio/xwxapt/metadata.xml
new file mode 100644
index 000000000000..28bcc7249968
--- /dev/null
+++ b/media-radio/xwxapt/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>tomjbe@gentoo.org</email>
+ <name>Thomas Beierlein</name>
+</maintainer>
+</pkgmetadata>
diff --git a/media-radio/xwxapt/xwxapt-2.1.ebuild b/media-radio/xwxapt/xwxapt-2.1.ebuild
new file mode 100644
index 000000000000..02f6344d8228
--- /dev/null
+++ b/media-radio/xwxapt/xwxapt-2.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit autotools
+
+DESCRIPTION="GTK+ linux weather satellite APT image decoder software"
+HOMEPAGE="http://5b4az.chronos.org.uk/pages/apt.html"
+SRC_URI="http://5b4az.chronos.org.uk/pkg/apt/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ media-libs/alsa-lib
+ dev-libs/glib:2
+ x11-libs/gtk+:2"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ # create missing mkinstalldir and prepare package
+ glib-gettextize --force --copy || die "gettextize failed"
+ eautoreconf
+}
+
+src_install() {
+ default
+ dohtml doc/xwxapt.html
+ insinto /usr/share/${PN}
+ doins xwxapt/xwxaptrc
+ dodir /usr/share/${PN}/images /usr/share/${PN}/records
+}
+
+pkg_postinst() {
+ einfo "You must copy the /usr/share/xwxapt directory into your home directory"
+ einfo "and configure the contained xwxaptrc file before starting the program"
+}
diff --git a/media-radio/xwxapt/xwxapt-2.2.ebuild b/media-radio/xwxapt/xwxapt-2.2.ebuild
new file mode 100644
index 000000000000..878db36ce722
--- /dev/null
+++ b/media-radio/xwxapt/xwxapt-2.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit autotools
+
+DESCRIPTION="GTK+ linux weather satellite APT image decoder software"
+HOMEPAGE="http://5b4az.chronos.org.uk/pages/apt.html"
+SRC_URI="http://5b4az.chronos.org.uk/pkg/apt/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ media-libs/alsa-lib
+ dev-libs/glib:2
+ x11-libs/gtk+:2"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_prepare() {
+ # create missing mkinstalldir and prepare package
+ glib-gettextize --force --copy || die "gettextize failed"
+ eautoreconf
+}
+
+src_install() {
+ default
+ dohtml doc/xwxapt.html
+ insinto /usr/share/${PN}
+ doins xwxapt/xwxaptrc
+ dodir /usr/share/${PN}/images /usr/share/${PN}/records
+}
+
+pkg_postinst() {
+ einfo "You must copy the /usr/share/xwxapt directory into your home directory"
+ einfo "and configure the contained xwxaptrc file before starting the program"
+}