summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/ifp-gnome
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/ifp-gnome')
-rw-r--r--media-sound/ifp-gnome/Manifest1
-rw-r--r--media-sound/ifp-gnome/files/ifp-gnome-0.7-file-locations.patch47
-rw-r--r--media-sound/ifp-gnome/ifp-gnome-0.7.ebuild40
-rw-r--r--media-sound/ifp-gnome/metadata.xml8
4 files changed, 96 insertions, 0 deletions
diff --git a/media-sound/ifp-gnome/Manifest b/media-sound/ifp-gnome/Manifest
new file mode 100644
index 000000000000..2d41b036ef84
--- /dev/null
+++ b/media-sound/ifp-gnome/Manifest
@@ -0,0 +1 @@
+DIST ifp-gnome-0.7.tar.gz 11287 SHA256 274793f76a667e1e5ee982aa04f9eea14068cdcb1b7adeb945412ea7e16770ba
diff --git a/media-sound/ifp-gnome/files/ifp-gnome-0.7-file-locations.patch b/media-sound/ifp-gnome/files/ifp-gnome-0.7-file-locations.patch
new file mode 100644
index 000000000000..95e055b3a89c
--- /dev/null
+++ b/media-sound/ifp-gnome/files/ifp-gnome-0.7-file-locations.patch
@@ -0,0 +1,47 @@
+--- ifp-gnome.py
++++ ifp-gnome.py
+@@ -21,7 +21,7 @@
+
+ class GiRiverApp:
+ def __init__(self):
+- gladefile="ifp-gnome.glade"
++ gladefile="/usr/share/ifp-gnome/ifp-gnome.glade"
+ windowname="window1"
+ progresswinname="winProgress"
+
+@@ -46,7 +46,7 @@
+ self.wTree.signal_autoconnect(dic)
+ self.mainWindow = self.wTree.get_widget(windowname)
+ self.mainWindow.hide()
+- self.mainWindow.set_icon_from_file('ifp-gnome.png')
++ self.mainWindow.set_icon_from_file('/usr/share/ifp-gnome/ifp-gnome.png')
+
+ # Progress Window
+ self.progressWindow = self.progTree.get_widget(progresswinname)
+@@ -55,7 +55,7 @@
+
+
+ self.progressWindow.hide()
+- self.progressWindow.set_icon_from_file('ifp-gnome.png')
++ self.progressWindow.set_icon_from_file('/usr/share/ifp-gnome/ifp-gnome.png')
+
+ # Transfer Window
+ self.interrupted = False
+@@ -67,7 +67,7 @@
+ self.verDialog.signal_autoconnect(dictt)
+ self.verifyWindow = self.verDialog.get_widget("winTransfer")
+ self.verifyWindow.hide()
+- self.verifyWindow.set_icon_from_file('ifp-gnome.png')
++ self.verifyWindow.set_icon_from_file('/usr/share/ifp-gnome/ifp-gnome.png')
+
+ self.lblBattery = self.wTree.get_widget("lblBattery")
+ self.lblSpace = self.wTree.get_widget("lblSpace")
+@@ -752,7 +752,7 @@
+ gnome.ui.About("iFP-Gnome","0.7", "Copyright 2006 Billy Charlton",
+ "A GNOME file manager for some iRiver Flash devices",
+ ["Billy Charlton <billy@trigby.com>"],[],"",
+- gtk.gdk.pixbuf_new_from_file("ifp-gnome.png")).show()
++ gtk.gdk.pixbuf_new_from_file("/usr/share/ifp-gnome/ifp-gnome.png")).show()
+
+
+ # MAIN ENTRY POINT ---------------------
diff --git a/media-sound/ifp-gnome/ifp-gnome-0.7.ebuild b/media-sound/ifp-gnome/ifp-gnome-0.7.ebuild
new file mode 100644
index 000000000000..b4cdd74ba986
--- /dev/null
+++ b/media-sound/ifp-gnome/ifp-gnome-0.7.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+
+PYTHON_DEPEND=2
+inherit eutils python
+
+DESCRIPTION="Gnome front-end for file management on iRiver iFP MP3 players"
+HOMEPAGE="http://ifp-gnome.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-python/libgnome-python-2
+ >=dev-python/pygtk-2
+ >=dev-python/pyifp-0.2.2"
+DEPEND=""
+
+S=${WORKDIR}/${PN}
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ python_convert_shebangs 2 ${PN}.py
+ epatch "${FILESDIR}"/${P}-file-locations.patch
+}
+
+src_install() {
+ insinto /usr/share/${PN}
+ doins ${PN}.{glade,png} || die
+ newbin ${PN}.py ${PN} || die
+}
diff --git a/media-sound/ifp-gnome/metadata.xml b/media-sound/ifp-gnome/metadata.xml
new file mode 100644
index 000000000000..5ddd82b6cb49
--- /dev/null
+++ b/media-sound/ifp-gnome/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+ <upstream>
+ <remote-id type="sourceforge">ifp-gnome</remote-id>
+ </upstream>
+</pkgmetadata>