summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/karlyriceditor
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/karlyriceditor')
-rw-r--r--media-sound/karlyriceditor/Manifest2
-rw-r--r--media-sound/karlyriceditor/files/karlyriceditor-1.3-libav.patch10
-rw-r--r--media-sound/karlyriceditor/files/karlyriceditor-1.4-ffmpeg_compat.patch37
-rw-r--r--media-sound/karlyriceditor/files/karlyriceditor-1.4-qmin.patch13
-rw-r--r--media-sound/karlyriceditor/karlyriceditor-1.3.ebuild31
-rw-r--r--media-sound/karlyriceditor/karlyriceditor-1.4.ebuild40
-rw-r--r--media-sound/karlyriceditor/metadata.xml9
7 files changed, 142 insertions, 0 deletions
diff --git a/media-sound/karlyriceditor/Manifest b/media-sound/karlyriceditor/Manifest
new file mode 100644
index 000000000000..109d80eb6599
--- /dev/null
+++ b/media-sound/karlyriceditor/Manifest
@@ -0,0 +1,2 @@
+DIST karlyriceditor-1.3.tar.gz 215564 SHA256 f59bc9352e30a02228db65d47e190aa00e6f8e7f6ec18b093a30841548b90e57 SHA512 23e91e6f950b4f3d5ddaa474380dfd5904bd29f262144df6d587efbba070e1c84bd6d364981e0babb75aa4562c375734b16944817e49ad83ab0c169cf9d2e0e5 WHIRLPOOL d71b7111e2bf57a995acb10de14c39bce37c8f8072936812d8d672540dd22650ce1259cffccecfe6231ca0a3cba87546cd00247247bdc2b6deeb58f2e6c11c10
+DIST karlyriceditor-1.4.tar.gz 236662 SHA256 b458eb21087cd0d92e8ea87b4ac094a2126cfbcf6471b0b1ea03173cec0ebfef SHA512 ac92e8f67be46880e71082ae1b2d099deb15ca1abca1fdf7eb8539d0346ca223ee50d9739f7879699fb190e7bc544c2a753402804df20c9b4c35eefae2d3bdbb WHIRLPOOL 9072da5010deb34fe9e09dee165f824b3aeace89a3fd0c1b464def17cf767a5ee84a77d7b2f8696f81364be5bc54003243faba3870198ba084b98e3bc2207984
diff --git a/media-sound/karlyriceditor/files/karlyriceditor-1.3-libav.patch b/media-sound/karlyriceditor/files/karlyriceditor-1.3-libav.patch
new file mode 100644
index 000000000000..d3f63d51b522
--- /dev/null
+++ b/media-sound/karlyriceditor/files/karlyriceditor-1.3-libav.patch
@@ -0,0 +1,10 @@
+--- src/ffmpeg_headers.h
++++ src/ffmpeg_headers.h
+@@ -32,6 +32,7 @@
+
+ #include "libavcodec/avcodec.h"
+ #include "libavformat/avformat.h"
++#include "libavutil/mathematics.h"
+ #include "libswscale/swscale.h"
+
+ };
diff --git a/media-sound/karlyriceditor/files/karlyriceditor-1.4-ffmpeg_compat.patch b/media-sound/karlyriceditor/files/karlyriceditor-1.4-ffmpeg_compat.patch
new file mode 100644
index 000000000000..9711f9e556f9
--- /dev/null
+++ b/media-sound/karlyriceditor/files/karlyriceditor-1.4-ffmpeg_compat.patch
@@ -0,0 +1,37 @@
+Index: karlyriceditor-1.4/src/ffmpegvideoencoder.cpp
+===================================================================
+--- karlyriceditor-1.4.orig/src/ffmpegvideoencoder.cpp
++++ karlyriceditor-1.4/src/ffmpegvideoencoder.cpp
+@@ -397,6 +397,13 @@ int FFMpegVideoEncoderPriv::encodeImage(
+ // SWS conversion
+ convertImage_sws(img);
+
++#if LIBAVCODEC_VERSION_INT < AV_VERSION_INT(54,2,0)
++ int out_size = avcodec_encode_video(pVideoCodecCtx,outbuf,outbuf_size,ppicture);
++
++ if (out_size > 0)
++ {
++ av_init_packet(&pkt);
++#else
+ av_init_packet( &pkt );
+ pkt.data = NULL;
+ pkt.size = 0;
+@@ -408,6 +415,7 @@ int FFMpegVideoEncoderPriv::encodeImage(
+
+ if ( got_packet )
+ {
++#endif
+ if ( pVideoCodecCtx->coded_frame->pts != (int64_t) (0x8000000000000000LL) )
+ pkt.pts= av_rescale_q(pVideoCodecCtx->coded_frame->pts, pVideoCodecCtx->time_base, pVideoStream->time_base);
+
+@@ -415,6 +423,10 @@ int FFMpegVideoEncoderPriv::encodeImage(
+ pkt.flags |= AV_PKT_FLAG_KEY;
+
+ pkt.stream_index = pVideoStream->index;
++#if LIBAVCODEC_VERSION_INT < AV_VERSION_INT(54,2,0)
++ pkt.data = outbuf;
++ pkt.size = out_size;
++#endif
+
+ int ret = av_interleaved_write_frame(pOutputCtx, &pkt);
+
diff --git a/media-sound/karlyriceditor/files/karlyriceditor-1.4-qmin.patch b/media-sound/karlyriceditor/files/karlyriceditor-1.4-qmin.patch
new file mode 100644
index 000000000000..b7835e5973ac
--- /dev/null
+++ b/media-sound/karlyriceditor/files/karlyriceditor-1.4-qmin.patch
@@ -0,0 +1,13 @@
+Index: karlyriceditor-1.4/src/kfn_file_parser.cpp
+===================================================================
+--- karlyriceditor-1.4.orig/src/kfn_file_parser.cpp
++++ karlyriceditor-1.4/src/kfn_file_parser.cpp
+@@ -311,7 +311,7 @@ QByteArray KFNFileParser::extract( const
+
+ while ( total_in < entry.length_in )
+ {
+- int toRead = qMin( sizeof(buffer), (unsigned int) entry.length_in - total_in );
++ int toRead = qMin( sizeof(buffer), (size_t) entry.length_in - total_in );
+ int bytesRead = m_file.read( buffer, toRead );
+
+ // We might need to write less than we read since the file is rounded to 16 bytes
diff --git a/media-sound/karlyriceditor/karlyriceditor-1.3.ebuild b/media-sound/karlyriceditor/karlyriceditor-1.3.ebuild
new file mode 100644
index 000000000000..b9afaa040457
--- /dev/null
+++ b/media-sound/karlyriceditor/karlyriceditor-1.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils qt4-r2
+
+DESCRIPTION="A program which lets you edit and synchronize lyrics with karaoke songs in varions formats"
+HOMEPAGE="http://www.karlyriceditor.com/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-libs/openssl:0
+ media-libs/libsdl
+ >=virtual/ffmpeg-0.9
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${P}-libav.patch" )
+
+src_install() {
+ dodoc Changelog
+ dobin bin/${PN}
+ doicon packages/${PN}.png
+ make_desktop_entry ${PN} 'Karaoke Lyrics Editor'
+}
diff --git a/media-sound/karlyriceditor/karlyriceditor-1.4.ebuild b/media-sound/karlyriceditor/karlyriceditor-1.4.ebuild
new file mode 100644
index 000000000000..b564adff9553
--- /dev/null
+++ b/media-sound/karlyriceditor/karlyriceditor-1.4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils qt4-r2
+
+DESCRIPTION="Application to edit and synchronize lyrics with karaoke songs in various formats"
+HOMEPAGE="http://www.ulduzsoft.com/linux/karaoke-lyrics-editor/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-libs/openssl:0
+ media-libs/libsdl
+ >=virtual/ffmpeg-0.10
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.3-libav.patch"
+ "${FILESDIR}/${PN}-1.4-ffmpeg_compat.patch"
+ "${FILESDIR}/${PN}-1.4-qmin.patch"
+ )
+
+src_install() {
+ dodoc Changelog
+ dobin bin/${PN}
+ doicon packages/${PN}.png
+ make_desktop_entry ${PN} 'Karaoke Lyrics Editor'
+}
diff --git a/media-sound/karlyriceditor/metadata.xml b/media-sound/karlyriceditor/metadata.xml
new file mode 100644
index 000000000000..b060190a0f50
--- /dev/null
+++ b/media-sound/karlyriceditor/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+ <herd>qt</herd>
+ <upstream>
+ <remote-id type="sourceforge">karlyriceditor</remote-id>
+ </upstream>
+</pkgmetadata>