summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/mpfc
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/mpfc')
-rw-r--r--media-sound/mpfc/Manifest2
-rw-r--r--media-sound/mpfc/files/mpfc-1.3.7-INT_MAX.patch20
-rw-r--r--media-sound/mpfc/files/mpfc-1.3.7-asneeded.patch26
-rw-r--r--media-sound/mpfc/files/mpfc-1.3.7-libdir.patch113
-rw-r--r--media-sound/mpfc/files/mpfc-1.3.7-mathlib.patch20
-rw-r--r--media-sound/mpfc/files/mpfc-gcc4.patch13
-rw-r--r--media-sound/mpfc/metadata.xml11
-rw-r--r--media-sound/mpfc/mpfc-1.3.7-r1.ebuild56
-rw-r--r--media-sound/mpfc/mpfc-1.3.8.1-r1.ebuild46
-rw-r--r--media-sound/mpfc/mpfc-1.3.8.1.ebuild45
10 files changed, 352 insertions, 0 deletions
diff --git a/media-sound/mpfc/Manifest b/media-sound/mpfc/Manifest
new file mode 100644
index 000000000000..7606073518f7
--- /dev/null
+++ b/media-sound/mpfc/Manifest
@@ -0,0 +1,2 @@
+DIST mpfc-1.3.7.tar.gz 869364 SHA256 256ec3a9ebe3296e614b937d3e9044ba11d27c863f723fc939beb82daf54ec8d
+DIST mpfc-1.3.8.1.tar.gz 1042027 SHA256 e8a498ba390bd4ad91d4a36a84d676bcdd9525264ed34548df1d94118abc1116
diff --git a/media-sound/mpfc/files/mpfc-1.3.7-INT_MAX.patch b/media-sound/mpfc/files/mpfc-1.3.7-INT_MAX.patch
new file mode 100644
index 000000000000..8bca2f380366
--- /dev/null
+++ b/media-sound/mpfc/files/mpfc-1.3.7-INT_MAX.patch
@@ -0,0 +1,20 @@
+--- plugins/input/audiocd/audiocd.c
++++ plugins/input/audiocd/audiocd.c
+@@ -21,6 +21,7 @@
+ */
+
+ #include <stdio.h>
++#include <limits.h> /* cdrom.h and INT_MAX */
+ #include <linux/cdrom.h>
+ #include <errno.h>
+ #include <string.h>
+--- plugins/input/audiocd/audiocd.h
++++ plugins/input/audiocd/audiocd.h
+@@ -23,6 +23,7 @@
+ #ifndef __SG_MPFC_AUDIOCD_H__
+ #define __SG_MPFC_AUDIOCD_H__
+
++#include <limits.h> /* cdrom.h and INT_MAX */
+ #include <linux/cdrom.h>
+ #include "types.h"
+ #include "logger.h"
diff --git a/media-sound/mpfc/files/mpfc-1.3.7-asneeded.patch b/media-sound/mpfc/files/mpfc-1.3.7-asneeded.patch
new file mode 100644
index 000000000000..d681e8784f74
--- /dev/null
+++ b/media-sound/mpfc/files/mpfc-1.3.7-asneeded.patch
@@ -0,0 +1,26 @@
+Index: mpfc-1.3.7/libmpfc/Makefile.am
+===================================================================
+--- mpfc-1.3.7.orig/libmpfc/Makefile.am
++++ mpfc-1.3.7/libmpfc/Makefile.am
+@@ -18,6 +18,6 @@ libmpfc_la_SOURCES = cfg.c charset.c fil
+ song_info.c string.c vfs.c logger.c cfg_rcfile.c \
+ plugin.c plugin_general.c command.c \
+ $(libmpfchdr_HEADERS)
+-libmpfc_la_LIBADD = @COMMON_LIBS@ @RESOLV_LIBS@
++libmpfc_la_LIBADD = @COMMON_LIBS@ @RESOLV_LIBS@ @DL_LIBS@
+ INCLUDES = -I$(top_builddir)/src -I$(top_builddir)/libmpfcwnd
+ localedir = $(datadir)/locale
+Index: mpfc-1.3.7/src/Makefile.am
+===================================================================
+--- mpfc-1.3.7.orig/src/Makefile.am
++++ mpfc-1.3.7/src/Makefile.am
+@@ -13,6 +13,7 @@ localedir = $(datadir)/locale
+ DEFS = -DLOCALEDIR=\"$(localedir)\" -DLIBDIR=\"$(libdir)\" \
+ -DSYSCONFDIR=\"$(sysconfdir)\" @DEFS@
+ INCLUDES = -I$(top_builddir)/libmpfcwnd/
+-mpfc_LDADD = @COMMON_LIBS@ @PTHREAD_LIBS@ @DL_LIBS@ @MATH_LIBS@ \
++mpfc_LDADD = \
+ $(top_builddir)/libmpfc/libmpfc.la \
+- $(top_builddir)/libmpfcwnd/libmpfcwnd.la
++ $(top_builddir)/libmpfcwnd/libmpfcwnd.la \
++ @COMMON_LIBS@ @PTHREAD_LIBS@ @DL_LIBS@ @MATH_LIBS@
diff --git a/media-sound/mpfc/files/mpfc-1.3.7-libdir.patch b/media-sound/mpfc/files/mpfc-1.3.7-libdir.patch
new file mode 100644
index 000000000000..52a318463154
--- /dev/null
+++ b/media-sound/mpfc/files/mpfc-1.3.7-libdir.patch
@@ -0,0 +1,113 @@
+Index: mpfc-1.3.7/libmpfc/Makefile.am
+===================================================================
+--- mpfc-1.3.7.orig/libmpfc/Makefile.am
++++ mpfc-1.3.7/libmpfc/Makefile.am
+@@ -1,7 +1,5 @@
+ lib_LTLIBRARIES = libmpfc.la
+
+-libdir = $(prefix)/lib/
+-
+ libmpfchdrdir = $(prefix)/include/mpfc
+ libmpfchdr_HEADERS = ../mpfc-config.h ../src/types.h ../src/cfg.h \
+ ../src/charset.h \
+Index: mpfc-1.3.7/libmpfcwnd/Makefile.am
+===================================================================
+--- mpfc-1.3.7.orig/libmpfcwnd/Makefile.am
++++ mpfc-1.3.7/libmpfcwnd/Makefile.am
+@@ -1,5 +1,4 @@
+ lib_LTLIBRARIES = libmpfcwnd.la
+-libdir = $(prefix)/lib/
+ libmpfcwndhdrdir = $(prefix)/include/mpfc/libmpfcwnd
+ libmpfcwndhdr_HEADERS = wnd.h wnd_print.h wnd_msg.h wnd_kbd.h \
+ wnd_def_handlers.h wnd_root.h wnd_mouse.h wnd_types.h \
+Index: mpfc-1.3.7/plugins/input/audiocd/Makefile.am
+===================================================================
+--- mpfc-1.3.7.orig/plugins/input/audiocd/Makefile.am
++++ mpfc-1.3.7/plugins/input/audiocd/Makefile.am
+@@ -1,6 +1,6 @@
+-lib_LTLIBRARIES = libaudiocd.la
++plugin_LTLIBRARIES = libaudiocd.la
+
+-libdir = $(prefix)/lib/mpfc/input
++plugindir = $(libdir)/mpfc/input
+
+ libaudiocd_la_SOURCES = audiocd.c audiocd.h cddb.c cddb.h
+ libaudiocd_la_LIBADD = @COMMON_LIBS@ @RESOLV_LIBS@
+Index: mpfc-1.3.7/plugins/input/mp3/Makefile.am
+===================================================================
+--- mpfc-1.3.7.orig/plugins/input/mp3/Makefile.am
++++ mpfc-1.3.7/plugins/input/mp3/Makefile.am
+@@ -1,6 +1,6 @@
+-lib_LTLIBRARIES = libmp3.la
++plugin_LTLIBRARIES = libmp3.la
+
+-libdir = $(prefix)/lib/mpfc/input
++plugindir = $(libdir)/mpfc/input
+
+ libmp3_la_SOURCES = mp3.c mp3.h
+ INCLUDES = -I$(top_builddir)/src -I$(top_builddir)/libmpfcwnd
+Index: mpfc-1.3.7/plugins/input/ogg/Makefile.am
+===================================================================
+--- mpfc-1.3.7.orig/plugins/input/ogg/Makefile.am
++++ mpfc-1.3.7/plugins/input/ogg/Makefile.am
+@@ -1,6 +1,6 @@
+-lib_LTLIBRARIES = libogg_vorbis.la
++plugin_LTLIBRARIES = libogg_vorbis.la
+
+-libdir = $(prefix)/lib/mpfc/input
++plugindir = $(libdir)/mpfc/input
+
+ libogg_vorbis_la_SOURCES = ogg.c vcedit.c vcedit.h
+ INCLUDES = -I$(top_builddir)/src -I$(top_builddir)/libmpfcwnd
+Index: mpfc-1.3.7/plugins/input/wav/Makefile.am
+===================================================================
+--- mpfc-1.3.7.orig/plugins/input/wav/Makefile.am
++++ mpfc-1.3.7/plugins/input/wav/Makefile.am
+@@ -1,6 +1,6 @@
+-lib_LTLIBRARIES = libwav.la
++plugin_LTLIBRARIES = libwav.la
+
+-libdir = $(prefix)/lib/mpfc/input
++plugindir = $(libdir)/mpfc/input
+
+ libwav_la_SOURCES = wav.c wav.h
+ libwav_la_LIBADD = @COMMON_LIBS@
+Index: mpfc-1.3.7/plugins/output/alsa/Makefile.am
+===================================================================
+--- mpfc-1.3.7.orig/plugins/output/alsa/Makefile.am
++++ mpfc-1.3.7/plugins/output/alsa/Makefile.am
+@@ -1,6 +1,6 @@
+-lib_LTLIBRARIES = libalsa.la
++plugin_LTLIBRARIES = libalsa.la
+
+-libdir = $(prefix)/lib/mpfc/output
++plugindir = $(libdir)/mpfc/output
+
+ libalsa_la_SOURCES = alsa.c
+ INCLUDES = -I$(top_builddir)/src -I$(top_builddir)/libmpfcwnd
+Index: mpfc-1.3.7/plugins/output/disk_writer/Makefile.am
+===================================================================
+--- mpfc-1.3.7.orig/plugins/output/disk_writer/Makefile.am
++++ mpfc-1.3.7/plugins/output/disk_writer/Makefile.am
+@@ -1,6 +1,6 @@
+-lib_LTLIBRARIES = libdisk_writer.la
++plugin_LTLIBRARIES = libdisk_writer.la
+
+-libdir = $(prefix)/lib/mpfc/output
++plugindir = $(libdir)/mpfc/output
+
+ libdisk_writer_la_SOURCES = writer.c
+ libdisk_writer_la_LIBADD = @COMMON_LIBS@
+Index: mpfc-1.3.7/plugins/output/oss/Makefile.am
+===================================================================
+--- mpfc-1.3.7.orig/plugins/output/oss/Makefile.am
++++ mpfc-1.3.7/plugins/output/oss/Makefile.am
+@@ -1,6 +1,6 @@
+-lib_LTLIBRARIES = liboss.la
++plugin_LTLIBRARIES = liboss.la
+
+-libdir = $(prefix)/lib/mpfc/output
++plugindir = $(libdir)/mpfc/output
+
+ liboss_la_SOURCES = oss.c
+ liboss_la_LIBADD = @COMMON_LIBS@
diff --git a/media-sound/mpfc/files/mpfc-1.3.7-mathlib.patch b/media-sound/mpfc/files/mpfc-1.3.7-mathlib.patch
new file mode 100644
index 000000000000..09471407398b
--- /dev/null
+++ b/media-sound/mpfc/files/mpfc-1.3.7-mathlib.patch
@@ -0,0 +1,20 @@
+Index: mpfc-1.3.7/configure.in
+===================================================================
+--- mpfc-1.3.7.orig/configure.in
++++ mpfc-1.3.7/configure.in
+@@ -66,7 +66,6 @@ LIBS=$LIBS_save
+ AC_ARG_ENABLE(mp3,
+ [ --disable-mp3 Disable mp3 input plugin [default=enabled]],,
+ enable_mp3="yes")
+-if test "x$enable_mp3" = xyes; then
+ # Check for math lib
+ LIBS_save=$LIBS
+ AC_CHECK_HEADERS([math.h],,[AC_MSG_ERROR(*** Can't find math header ***)])
+@@ -75,6 +74,7 @@ if test "x$enable_mp3" = xyes; then
+ AC_SUBST(MATH_LIBS)
+ LIBS=$LIBS_save
+
++if test "x$enable_mp3" = xyes; then
+ # Check for libmad
+ LIBS_save=$LIBS
+ AC_CHECK_HEADERS([mad.h],,[AC_MSG_ERROR(*** Can't find libmad header ***)])
diff --git a/media-sound/mpfc/files/mpfc-gcc4.patch b/media-sound/mpfc/files/mpfc-gcc4.patch
new file mode 100644
index 000000000000..5cb1efb6834b
--- /dev/null
+++ b/media-sound/mpfc/files/mpfc-gcc4.patch
@@ -0,0 +1,13 @@
+--- mpfc-1.3.7/plugins/input/audiocd/audiocd.c.old 2006-11-05 21:13:25.000000000 +0100
++++ mpfc-1.3.7/plugins/input/audiocd/audiocd.c 2006-11-05 21:13:35.000000000 +0100
+@@ -60,8 +60,8 @@
+ /* Tracks information array */
+ struct acd_trk_info_t acd_tracks_info[ACD_MAX_TRACKS];
+ int acd_num_tracks = 0;
+-static int acd_cur_track = -1;
+-static bool_t acd_info_read = FALSE;
++int acd_cur_track = -1;
++bool_t acd_info_read = FALSE;
+
+ /* Current time */
+ static int acd_time = 0;
diff --git a/media-sound/mpfc/metadata.xml b/media-sound/mpfc/metadata.xml
new file mode 100644
index 000000000000..2227ff7a1ff4
--- /dev/null
+++ b/media-sound/mpfc/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+ <use>
+ <flag name="wav">Enable wav audio codec support</flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge">mpfc</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/media-sound/mpfc/mpfc-1.3.7-r1.ebuild b/media-sound/mpfc/mpfc-1.3.7-r1.ebuild
new file mode 100644
index 000000000000..8f7936c4670d
--- /dev/null
+++ b/media-sound/mpfc/mpfc-1.3.7-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+inherit autotools eutils
+
+DESCRIPTION="Music Player For Console"
+HOMEPAGE="http://mpfc.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="alsa gpm mad vorbis oss wav cdda nls"
+
+RDEPEND="alsa? ( >=media-libs/alsa-lib-0.9.0 )
+ gpm? ( >=sys-libs/gpm-1.19.3 )
+ mad? ( media-libs/libmad )
+ vorbis? ( media-libs/libvorbis )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ sed -i \
+ -e 's:../src/file.h ../src/file.h:../src/file.h:' \
+ libmpfc/Makefile.am || die #335449
+
+ epatch "${FILESDIR}"/${P}-libdir.patch \
+ "${FILESDIR}"/${PN}-gcc4.patch \
+ "${FILESDIR}"/${P}-mathlib.patch \
+ "${FILESDIR}"/${P}-asneeded.patch \
+ "${FILESDIR}"/${P}-INT_MAX.patch
+
+ AT_M4DIR="m4" eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable alsa) \
+ $(use_enable gpm) \
+ $(use_enable mad mp3) \
+ $(use_enable vorbis ogg) \
+ $(use_enable oss) \
+ $(use_enable wav) \
+ $(use_enable cdda audiocd) \
+ $(use_enable nls)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ insinto /etc
+ doins mpfcrc || die
+
+ dodoc AUTHORS ChangeLog NEWS README
+}
diff --git a/media-sound/mpfc/mpfc-1.3.8.1-r1.ebuild b/media-sound/mpfc/mpfc-1.3.8.1-r1.ebuild
new file mode 100644
index 000000000000..d8898b71610e
--- /dev/null
+++ b/media-sound/mpfc/mpfc-1.3.8.1-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="Music Player For Console"
+HOMEPAGE="http://mpfc.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="alsa cdda flac gpm mad nls oss static-libs vorbis wav"
+
+RDEPEND="alsa? ( >=media-libs/alsa-lib-0.9.0 )
+ flac? ( media-libs/flac )
+ gpm? ( >=sys-libs/gpm-1.19.3 )
+ mad? ( media-libs/libmad )
+ vorbis? ( media-libs/libvorbis )
+ sys-libs/ncurses[unicode]
+ dev-libs/icu:="
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ econf \
+ $(use_enable alsa) \
+ $(use_enable cdda audiocd) \
+ $(use_enable flac) \
+ $(use_enable gpm) \
+ $(use_enable mad mp3) \
+ $(use_enable nls) \
+ $(use_enable oss) \
+ $(use_enable static-libs static) \
+ $(use_enable vorbis ogg) \
+ $(use_enable wav)
+}
+
+src_install() {
+ default
+
+ insinto /etc
+ doins mpfcrc
+
+ find "${D}" -name '*.la' -delete || die
+}
diff --git a/media-sound/mpfc/mpfc-1.3.8.1.ebuild b/media-sound/mpfc/mpfc-1.3.8.1.ebuild
new file mode 100644
index 000000000000..4a4897b40489
--- /dev/null
+++ b/media-sound/mpfc/mpfc-1.3.8.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+
+DESCRIPTION="Music Player For Console"
+HOMEPAGE="http://mpfc.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="alsa flac gpm mad vorbis oss wav cdda nls"
+
+RDEPEND="alsa? ( >=media-libs/alsa-lib-0.9.0 )
+ flac? ( media-libs/flac )
+ gpm? ( >=sys-libs/gpm-1.19.3 )
+ mad? ( media-libs/libmad )
+ vorbis? ( media-libs/libvorbis )
+ sys-libs/ncurses[unicode]
+ dev-libs/icu"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ econf \
+ $(use_enable alsa) \
+ $(use_enable flac) \
+ $(use_enable gpm) \
+ $(use_enable mad mp3) \
+ $(use_enable vorbis ogg) \
+ $(use_enable oss) \
+ $(use_enable wav) \
+ $(use_enable cdda audiocd) \
+ $(use_enable nls)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ insinto /etc
+ doins mpfcrc || die
+
+ dodoc AUTHORS ChangeLog NEWS README || die
+}