summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-02-09 18:31:23 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-02-09 18:39:39 +0100
commitab242c068b17ec82352a34f04cefdccbe56e1b8e (patch)
tree684395cc5fcb70137d52013672a3ff6b4fd553b4 /media-sound/ncmpc
parentmedia-sound/ncmpc: Add USE=library-screen, replaces artist-screen (diff)
downloadgentoo-ab242c068b17ec82352a34f04cefdccbe56e1b8e.tar.gz
gentoo-ab242c068b17ec82352a34f04cefdccbe56e1b8e.tar.bz2
gentoo-ab242c068b17ec82352a34f04cefdccbe56e1b8e.zip
media-sound/ncmpc: Fix USE=doc man dir path
Bug: https://bugs.gentoo.org/676084 Package-Manager: Portage-2.3.59, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-sound/ncmpc')
-rw-r--r--media-sound/ncmpc/files/ncmpc-0.33-mandir.patch25
-rw-r--r--media-sound/ncmpc/ncmpc-0.33-r1.ebuild68
2 files changed, 93 insertions, 0 deletions
diff --git a/media-sound/ncmpc/files/ncmpc-0.33-mandir.patch b/media-sound/ncmpc/files/ncmpc-0.33-mandir.patch
new file mode 100644
index 000000000000..0bc3798bc5e7
--- /dev/null
+++ b/media-sound/ncmpc/files/ncmpc-0.33-mandir.patch
@@ -0,0 +1,25 @@
+From 821acdad907d1558c570bca6e2ac63d55905f363 Mon Sep 17 00:00:00 2001
+From: kaliko <kaliko@azylum.org>
+Date: Mon, 10 Dec 2018 13:46:42 +0100
+Subject: [PATCH] Fixed manual install dir
+
+---
+ doc/meson.build | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/doc/meson.build b/doc/meson.build
+index aadea58..f4b491d 100644
+--- a/doc/meson.build
++++ b/doc/meson.build
+@@ -30,9 +30,9 @@ endif
+ if get_option('manual')
+ custom_target(
+ 'Manpage documentation',
+- output: 'man',
++ output: 'man1',
+ input: ['index.rst', 'conf.py'],
+- command: [sphinx, '-q', '-b', 'man', '-d', '@OUTDIR@/man_doctrees', meson.current_source_dir(), '@OUTPUT@/man1'],
++ command: [sphinx, '-q', '-b', 'man', '-d', '@OUTDIR@/man_doctrees', meson.current_source_dir(), '@OUTPUT@'],
+ build_by_default: true,
+ install: true,
+ install_dir: get_option('mandir'),
diff --git a/media-sound/ncmpc/ncmpc-0.33-r1.ebuild b/media-sound/ncmpc/ncmpc-0.33-r1.ebuild
new file mode 100644
index 000000000000..d1eff94cb125
--- /dev/null
+++ b/media-sound/ncmpc/ncmpc-0.33-r1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="A ncurses client for the Music Player Daemon (MPD)"
+HOMEPAGE="https://www.musicpd.org/clients/ncmpc/ https://github.com/MusicPlayerDaemon/ncmpc"
+SRC_URI="https://www.musicpd.org/download/${PN}/${PV%.*}/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="async-connect chat-screen doc +help-screen key-screen +library-screen lirc lyrics-screen outputs-screen search-screen +song-screen +mouse nls pcre"
+
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( dev-python/sphinx )
+"
+RDEPEND="
+ >=media-libs/libmpdclient-2.9
+ sys-libs/ncurses:0=[unicode]
+ lirc? ( app-misc/lirc )
+ pcre? ( dev-libs/libpcre )
+"
+DEPEND="${RDEPEND}
+ >=dev-libs/boost-1.62
+"
+
+PATCHES=( "${FILESDIR}/${P}-mandir.patch" )
+
+src_prepare() {
+ default
+
+ # use correct docdir and don't install license file
+ sed \
+ -e "/^docdir =/s/meson.project_name()/'${PF}'/" \
+ -e "s/'COPYING', //" \
+ -i meson.build || die
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dcurses=ncursesw
+ -Dcolors=true
+ -Dmini=false
+ -Dlyrics_plugin_dir="${EPREFIX}/usr/$(get_libdir)/ncmpc/lyrics"
+ -Dlibrary_screen=$(usex library-screen true false)
+ -Dasync_connect=$(usex async-connect true false)
+ -Dchat_screen=$(usex chat-screen true false)
+ -Ddocumentation=$(usex doc enabled disabled)
+ -Dhelp_screen=$(usex help-screen true false)
+ -Dkey_screen=$(usex key-screen true false)
+ -Dlyrics_screen=$(usex lyrics-screen true false)
+ -Doutputs_screen=$(usex outputs-screen true false)
+ -Dsearch_screen=$(usex search-screen true false)
+ -Dsong_screen=$(usex song-screen true false)
+ -Dlocale=$(usex nls enabled disabled)
+ -Dmultibyte=$(usex nls true false)
+ -Dnls=$(usex nls enabled disabled)
+ -Dlirc=$(usex lirc enabled disabled)
+ -Dmouse=$(usex mouse enabled disabled)
+ -Dregex=$(usex pcre enabled disabled)
+ )
+
+ meson_src_configure
+}