summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarl Linden <karl.j.linden@gmail.com>2017-12-05 13:38:23 +0100
committerPatrice Clement <monsieurp@gentoo.org>2017-12-20 23:38:29 +0100
commit212ea959374c66fb8da88754737559f5d0d7f976 (patch)
tree940d2bb23493beebff5a36537bf7d2f04a6253c6 /media-sound/patchage/patchage-0.5.0-r2.ebuild
parentmedia-sound/patchage: depend on virtual/jack. (diff)
downloadgentoo-212ea959374c66fb8da88754737559f5d0d7f976.tar.gz
gentoo-212ea959374c66fb8da88754737559f5d0d7f976.tar.bz2
gentoo-212ea959374c66fb8da88754737559f5d0d7f976.zip
media-sound/patchage: bump to EAPI 6.
Package-Manager: Portage-2.3.16, Repoman-2.3.6
Diffstat (limited to 'media-sound/patchage/patchage-0.5.0-r2.ebuild')
-rw-r--r--media-sound/patchage/patchage-0.5.0-r2.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/media-sound/patchage/patchage-0.5.0-r2.ebuild b/media-sound/patchage/patchage-0.5.0-r2.ebuild
new file mode 100644
index 000000000000..ecd4516090e6
--- /dev/null
+++ b/media-sound/patchage/patchage-0.5.0-r2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE='threads(+)'
+
+inherit flag-o-matic waf-utils python-any-r1
+
+DESCRIPTION="Modular patch bay for audio and MIDI systems"
+HOMEPAGE="http://wiki.drobilla.net/Patchage"
+SRC_URI="http://download.drobilla.net/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="alsa debug lash"
+
+RDEPEND=">=media-libs/raul-0.7.0
+ >=x11-libs/flowcanvas-0.7.1
+ >=dev-cpp/gtkmm-2.11.12:2.4
+ >=dev-cpp/glibmm-2.14:2
+ >=dev-cpp/libglademm-2.6.0:2.4
+ dev-cpp/libgnomecanvasmm:2.6
+ virtual/jack
+ alsa? ( media-libs/alsa-lib )
+ lash? ( dev-libs/dbus-glib )"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ dev-libs/boost
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS README ChangeLog )
+
+PATCHES=(
+ "${FILESDIR}"/${P}-desktop.patch
+)
+
+src_configure() {
+ append-cxxflags -std=c++11
+ waf-utils_src_configure \
+ $(use debug && echo "--debug") \
+ $(use alsa || echo "--no-alsa") \
+ $(use lash || echo "--no-lash")
+}