summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-16 18:43:29 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-16 18:45:01 +0200
commit936820fcba0b87dde366a7f4f6580100f54591d1 (patch)
tree67724fdb2df955fcc1f466f9617f475c57e0ea8d /media-sound
parentmedia-sound/mpd: Restore 0.19.9-r1 as last stable (diff)
downloadgentoo-936820fcba0b87dde366a7f4f6580100f54591d1.tar.gz
gentoo-936820fcba0b87dde366a7f4f6580100f54591d1.tar.bz2
gentoo-936820fcba0b87dde366a7f4f6580100f54591d1.zip
media-sound/aqualung: fix build with ffmpeg git master.
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/aqualung/aqualung-1.0.ebuild4
-rw-r--r--media-sound/aqualung/files/ffmpeg29.patch13
2 files changed, 17 insertions, 0 deletions
diff --git a/media-sound/aqualung/aqualung-1.0.ebuild b/media-sound/aqualung/aqualung-1.0.ebuild
index b39de6ca08d2..c6954bef5a2c 100644
--- a/media-sound/aqualung/aqualung-1.0.ebuild
+++ b/media-sound/aqualung/aqualung-1.0.ebuild
@@ -50,6 +50,10 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${PN}-${MY_PV}
+src_prepare() {
+ epatch "${FILESDIR}/ffmpeg29.patch"
+}
+
src_configure() {
econf \
--enable-nls \
diff --git a/media-sound/aqualung/files/ffmpeg29.patch b/media-sound/aqualung/files/ffmpeg29.patch
new file mode 100644
index 000000000000..3cd0a0125b2e
--- /dev/null
+++ b/media-sound/aqualung/files/ffmpeg29.patch
@@ -0,0 +1,13 @@
+Index: aqualung-1.0/src/decoder/dec_lavc.c
+===================================================================
+--- aqualung-1.0.orig/src/decoder/dec_lavc.c
++++ aqualung-1.0/src/decoder/dec_lavc.c
+@@ -280,7 +280,7 @@ lavc_decoder_open(decoder_t * dec, char
+ return DECODER_OPEN_BADLIB;
+
+ pd->avCodecCtx = pd->avFormatCtx->streams[pd->audioStream]->codec;
+-#if LIBAVCODEC_VERSION_MAJOR >= 53
++#if LIBAVCODEC_VERSION_MAJOR >= 53 && LIBAVCODEC_VERSION_MAJOR < 57
+ pd->avCodecCtx->get_buffer = avcodec_default_get_buffer;
+ pd->avCodecCtx->release_buffer = avcodec_default_release_buffer;
+ #endif /* LIBAVCODEC_VERSION_MAJOR >= 53 */