summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-tv/me-tv
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-tv/me-tv')
-rw-r--r--media-tv/me-tv/Manifest1
-rw-r--r--media-tv/me-tv/files/me-tv-1.4.0.10-gcc47.patch26
-rw-r--r--media-tv/me-tv/me-tv-1.4.0.10.ebuild51
-rw-r--r--media-tv/me-tv/metadata.xml18
4 files changed, 96 insertions, 0 deletions
diff --git a/media-tv/me-tv/Manifest b/media-tv/me-tv/Manifest
new file mode 100644
index 000000000000..b64babaa8aab
--- /dev/null
+++ b/media-tv/me-tv/Manifest
@@ -0,0 +1 @@
+DIST me-tv-1.4.0.10.tar.gz 549653 SHA256 a0ee03feb3271c5cd68e5d36f938d2f967db462d28627d39b1d57be60b02f38c SHA512 98988a343f900c6b7a276ada47025f9a703a490eb499f3aad9fb7163c73113061dc205a29b454f06e817ef24d44ae58981fd5a19dfb0a48be669394e91bd5ee8 WHIRLPOOL 8f263ed8ed1dec94b67d607052ce04f2c2d62607d8fdddf1703888905512a9ced76372c81dd210552b3df512adb6b4876e131bf2d288b51444775edbe28ce119
diff --git a/media-tv/me-tv/files/me-tv-1.4.0.10-gcc47.patch b/media-tv/me-tv/files/me-tv-1.4.0.10-gcc47.patch
new file mode 100644
index 000000000000..c785e971997e
--- /dev/null
+++ b/media-tv/me-tv/files/me-tv-1.4.0.10-gcc47.patch
@@ -0,0 +1,26 @@
+ https://bugs.gentoo.org/452108
+
+ common/common.cc | 1 +
+ server/thread.cc | 1 +
+ 2 files changed, 2 insertions(+)
+
+--- a/common/common.cc
++++ b/common/common.cc
+@@ -18,6 +18,7 @@
+ * Foundation, Inc., 51 Franklin Street, Fifth Floor Boston, MA 02110-1301, USA
+ */
+
++#include <unistd.h>
+ #include "../common/common.h"
+ #include "../common/i18n.h"
+ #include "../common/exception.h"
+--- a/server/thread.cc
++++ b/server/thread.cc
+@@ -18,6 +18,7 @@
+ * Foundation, Inc., 51 Franklin Street, Fifth Floor Boston, MA 02110-1301, USA
+ */
+
++#include <unistd.h>
+ #include "thread.h"
+ #include "../common/i18n.h"
+ #include "../common/exception.h"
diff --git a/media-tv/me-tv/me-tv-1.4.0.10.ebuild b/media-tv/me-tv/me-tv-1.4.0.10.ebuild
new file mode 100644
index 000000000000..44ac0c474900
--- /dev/null
+++ b/media-tv/me-tv/me-tv-1.4.0.10.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit eutils versionator autotools gnome2
+
+DESCRIPTION="Me TV is a GTK desktop application for watching digital television"
+HOMEPAGE="http://me-tv.sourceforge.net/"
+SRC_URI="http://launchpad.net/${PN}/$(get_version_component_range 1-2)/$(get_version_component_range 1-3)/+download/${P}.tar.gz"
+RESTRICT="mirror"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="http"
+RDEPEND=">=dev-cpp/gconfmm-2.6
+ dev-cpp/gtkmm:2.4
+ dev-cpp/libxmlpp:2.6
+ dev-libs/libunique:1
+ >=dev-libs/dbus-glib-0.92
+ net-libs/gnet:2
+ =dev-db/sqlite-3*
+ >=media-video/vlc-1.1.8
+ media-libs/gstreamer:0.10
+ media-plugins/gst-plugins-xvideo:0.10
+ media-libs/gst-plugins-base:0.10"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc47.patch
+ eautoreconf
+}
+
+src_install() {
+ gnome2_src_install
+ if use http; then
+ dodoc -r http/
+ fi
+}
+
+pkg_postinst() {
+ if use http; then
+ elog "The HTTP server port, .. are hardcoded"
+ fi
+ elog "Please note that Version 1.4 has a new DB so you"
+ elog "have to re-import your channels."
+}
diff --git a/media-tv/me-tv/metadata.xml b/media-tv/me-tv/metadata.xml
new file mode 100644
index 000000000000..9541ffbf9e5a
--- /dev/null
+++ b/media-tv/me-tv/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>media-tv</herd>
+ <maintainer>
+ <email>lordvan@gentoo.org</email>
+ <name>Thomas Raschbacher</name>
+ </maintainer>
+ <longdescription>Me TV is a GTK desktop application for watching digital television services that use the DVB standard.
+
+Me TV works with DVB-T, DVB-S, DVB-C and ATSC devices that are supported by Linux kernel drivers.</longdescription>
+ <use>
+ <flag name="http">Installation of Web-frontend</flag>
+ </use>
+ <upstream>
+ <remote-id type="launchpad">me-tv</remote-id>
+ </upstream>
+</pkgmetadata>