summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2015-09-08 22:26:39 -0500
committerDoug Goldstein <cardoe@gentoo.org>2015-09-08 22:27:03 -0500
commitd817403a5e070f6c9ce8e59467b50cb7f29c5b7e (patch)
treec3da81fc0c3fce7938ad64a55980ceadfd350fd4 /media-tv/mythtv
parentsci-mathematics/rstudio: Bump to 0.99.484 (diff)
downloadgentoo-d817403a5e070f6c9ce8e59467b50cb7f29c5b7e.tar.gz
gentoo-d817403a5e070f6c9ce8e59467b50cb7f29c5b7e.tar.bz2
gentoo-d817403a5e070f6c9ce8e59467b50cb7f29c5b7e.zip
media-tv/mythtv: additional bug fixes
Fix the usage of $EPYTHON. Added call to --disable-vdpau and --disable-crystalhd when their respective USE flags are disabled. Finish conversion to python-single-r1. Package-Manager: portage-2.2.20.1 Signed-off-by: Doug Goldstein <cardoe@gentoo.org>
Diffstat (limited to 'media-tv/mythtv')
-rw-r--r--media-tv/mythtv/mythtv-0.27.5_p20150904.ebuild14
1 files changed, 4 insertions, 10 deletions
diff --git a/media-tv/mythtv/mythtv-0.27.5_p20150904.ebuild b/media-tv/mythtv/mythtv-0.27.5_p20150904.ebuild
index 23a2b365430f..9a16f8025d79 100644
--- a/media-tv/mythtv/mythtv-0.27.5_p20150904.ebuild
+++ b/media-tv/mythtv/mythtv-0.27.5_p20150904.ebuild
@@ -217,7 +217,7 @@ src_configure() {
myconf="${myconf} --without-bindings=perl,python"
fi
- use python && myconf="${myconf} --python=$(EPYTHON)"
+ use python && myconf="${myconf} --python=${EPYTHON}"
if use debug; then
myconf="${myconf} --compile-type=debug"
@@ -228,9 +228,9 @@ src_configure() {
fi
# Video
- use vdpau && myconf="${myconf} --enable-vdpau"
+ myconf="${myconf} $(use_enable vdpau)"
myconf="${myconf} $(use_enable vaapi)"
- use crystalhd && myconf="${myconf} --enable-crystalhd"
+ myconf="${myconf} $(use_enable crystalhd)"
# Input
use input_devices_joystick || myconf="${myconf} --disable-joystick-menu"
@@ -321,7 +321,7 @@ src_install() {
done
# Ensure that Python scripts are executed by Python 2
- python_convert_shebangs -q -r 2 "${ED}/usr/share/mythtv"
+ python_fix_shebang "${ED}/usr/share/mythtv"
# Make shell & perl scripts executable
find "${ED}" -type f -name '*.sh' -o -type f -name '*.pl' | \
@@ -335,8 +335,6 @@ pkg_preinst() {
}
pkg_postinst() {
- use python && python_mod_optimize MythTV
-
elog "To have this machine operate as recording host for MythTV, "
elog "mythbackend must be running. Run the following:"
elog "rc-update add mythbackend default"
@@ -352,10 +350,6 @@ pkg_postinst() {
elog "to journald via the console at the notice verbosity."
}
-pkg_postrm() {
- use python && python_mod_cleanup MythTV
-}
-
pkg_info() {
if [[ -f "${EROOT}"/usr/bin/mythfrontend ]]; then
"${EROOT}"/usr/bin/mythfrontend --version