summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Brandt <poncho@spahan.ch>2022-03-01 09:45:59 +0100
committerSam James <sam@gentoo.org>2022-05-31 05:30:52 +0100
commit21dfed0cc6d952b5bd1103c3377d354b895c4c3d (patch)
treeb565b8780c4dbae9a61dda63829dc85278277850 /media-video/pitivi
parentmedia-libs/gstreamer-editing-services: version bump (diff)
downloadgentoo-21dfed0cc6d952b5bd1103c3377d354b895c4c3d.tar.gz
gentoo-21dfed0cc6d952b5bd1103c3377d354b895c4c3d.tar.bz2
gentoo-21dfed0cc6d952b5bd1103c3377d354b895c4c3d.zip
media-video/pitivi: version bump
Closes: https://bugs.gentoo.org/749032 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Daniel Brandt <poncho@spahan.ch> Closes: https://github.com/gentoo/gentoo/pull/23101 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-video/pitivi')
-rw-r--r--media-video/pitivi/Manifest1
-rw-r--r--media-video/pitivi/files/pitivi-2021.05-meson-compatibility.patch45
-rw-r--r--media-video/pitivi/pitivi-2021.05.ebuild85
3 files changed, 131 insertions, 0 deletions
diff --git a/media-video/pitivi/Manifest b/media-video/pitivi/Manifest
index 4c40a41dfd05..6d5daf2867a2 100644
--- a/media-video/pitivi/Manifest
+++ b/media-video/pitivi/Manifest
@@ -1 +1,2 @@
DIST pitivi-0.999.tar.xz 12296928 BLAKE2B 16736fef4f2d16c02b64f8eba56f8c9ddb26f49742ee577da4e4c47077f8d5d71ce653dba366a041ba523153532728c5eb37cb2b76e11e9c51827efb990bd99d SHA512 663db84a00634f0e83f0c1dd80a4f3a6603a50826905adb24fdd567c6e8bb58e20de04c7753fa04a36692cdcf5bbbcc9a87327fd3b56ebb70caffcff13835fc8
+DIST pitivi-2021.05.tar.xz 11303884 BLAKE2B f87f16cc1ab7ea0f97bc92cdd9f1d5993051ed67b26473748aeb327a4cb51bb32510c845e1665ec3eb3b67c3f0f113c05a514076bad4e13d0fadbd725bcb6bb6 SHA512 3ecb571d501b634ca3a369d4020954cc0b2bc101ceb12bee74d6b38c9ca8f2bf15fe94030421c43503870128d8218548feca7d32cf25b4afcf610365784ca9bb
diff --git a/media-video/pitivi/files/pitivi-2021.05-meson-compatibility.patch b/media-video/pitivi/files/pitivi-2021.05-meson-compatibility.patch
new file mode 100644
index 000000000000..990f84b06795
--- /dev/null
+++ b/media-video/pitivi/files/pitivi-2021.05-meson-compatibility.patch
@@ -0,0 +1,45 @@
+From ddf2369d1fc6fddd63f676cc905a8b8e96291a4c Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Sebastian=20Dr=C3=B6ge?= <sebastian@centricular.com>
+Date: Tue, 25 Jan 2022 15:37:34 +0200
+Subject: [PATCH] Fix compatibility with meson 0.61
+
+Previously positional arguments to i18n.merge_files() were just ignored
+but this became an error.
+---
+ data/meson.build | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/data/meson.build b/data/meson.build
+index 2ea82cf12..60d23169b 100644
+--- a/data/meson.build
++++ b/data/meson.build
+@@ -6,7 +6,7 @@ install_subdir('audiopresets', install_dir: pkgdatadir)
+ install_subdir('videopresets', install_dir: pkgdatadir)
+ install_subdir('gstpresets', install_dir: pkgdatadir)
+
+-desktop_file = i18n.merge_file('org.pitivi.Pitivi.desktop',
++desktop_file = i18n.merge_file(
+ type: 'desktop',
+ output : 'org.pitivi.Pitivi.desktop',
+ input : 'org.pitivi.Pitivi.desktop.in',
+@@ -25,7 +25,7 @@ if desktop_file_validate.found()
+ )
+ endif
+
+-appdata_file = i18n.merge_file('org.pitivi.Pitivi.appdata.xml',
++appdata_file = i18n.merge_file(
+ type: 'xml',
+ output : 'org.pitivi.Pitivi.appdata.xml',
+ input : 'org.pitivi.Pitivi.appdata.xml.in',
+@@ -43,7 +43,7 @@ if appstream_util.found()
+ )
+ endif
+
+-i18n.merge_file('org.pitivi.Pitivi-mime.xml',
++i18n.merge_file(
+ output : 'org.pitivi.Pitivi-mime.xml',
+ input : 'org.pitivi.Pitivi-mime.xml.in',
+ po_dir: podir,
+--
+GitLab
+
diff --git a/media-video/pitivi/pitivi-2021.05.ebuild b/media-video/pitivi/pitivi-2021.05.ebuild
new file mode 100644
index 000000000000..e5a66ed35143
--- /dev/null
+++ b/media-video/pitivi/pitivi-2021.05.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="sqlite"
+
+inherit gnome.org meson python-single-r1 xdg
+
+DESCRIPTION="A non-linear video editor using the GStreamer multimedia framework"
+HOMEPAGE="http://www.pitivi.org"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# Do not forget to check pitivi/check.py for dependencies!!!
+# gsound, libav, libnotify and v4l are optional
+GST_VER="1.18.4"
+
+COMMON_DEPEND="
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ >=dev-python/pycairo-1.10[${PYTHON_USEDEP}]
+ ')
+ >=x11-libs/cairo-1.10
+
+ >=media-libs/gstreamer-${GST_VER}:1.0[introspection]
+"
+RDEPEND="${COMMON_DEPEND}
+ >=dev-libs/glib-2.30.0:2
+
+ >=dev-libs/gobject-introspection-1.34:=
+ $(python_gen_cond_dep '
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ >=dev-python/gst-python-1.4:1.0[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ >=dev-python/pygobject-3.8:3[${PYTHON_USEDEP}]
+ ')
+
+ gnome-base/librsvg:=
+
+ >=media-libs/gstreamer-editing-services-${GST_VER}:1.0[introspection]
+ >=media-libs/gst-plugins-base-${GST_VER}:1.0[introspection,theora]
+ >=media-libs/gst-plugins-bad-${GST_VER}:1.0
+ >=media-plugins/gst-plugins-gtk-${GST_VER}:1.0
+ >=media-libs/gst-plugins-good-${GST_VER}:1.0
+ >=media-plugins/gst-plugins-libav-${GST_VER}:1.0
+ >=media-plugins/gst-plugins-gdkpixbuf-${GST_VER}:1.0
+
+ >=x11-libs/libnotify-0.7[introspection]
+ x11-libs/libwnck:3[introspection]
+ >=x11-libs/gtk+-3.20.0:3[introspection]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ app-text/yelp-tools
+ dev-python/setuptools
+ >=dev-util/intltool-0.35.5
+ dev-util/itstool
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ # https://gitlab.gnome.org/GNOME/pitivi/-/commit/ddf2369d1fc6fddd63f676cc905a8b8e96291a4c
+ "${FILESDIR}"/${P}-meson-compatibility.patch
+)
+
+src_configure() {
+ meson_src_configure
+}
+
+src_compile() {
+ meson_src_compile
+}
+
+src_install() {
+ meson_src_install
+ python_fix_shebang "${D}"
+}