summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2015-10-27 19:58:31 +0100
committerPacho Ramos <pacho@gentoo.org>2015-10-27 19:58:31 +0100
commit4291060c3ac0c5e000c74ab8691c13ea1a3dc124 (patch)
tree2910e8326f1f212b07f3dd6ed3e9b08d87182bd2 /media-video/videotrans
parentmedia-video/dvdrip: Support libav too (#474346) (diff)
downloadgentoo-4291060c3ac0c5e000c74ab8691c13ea1a3dc124.tar.gz
gentoo-4291060c3ac0c5e000c74ab8691c13ea1a3dc124.tar.bz2
gentoo-4291060c3ac0c5e000c74ab8691c13ea1a3dc124.zip
media-video/videotrans: Support libav too (#474350)
Package-Manager: portage-2.2.23
Diffstat (limited to 'media-video/videotrans')
-rw-r--r--media-video/videotrans/files/videotrans-1.6.1-libav.patch52
-rw-r--r--media-video/videotrans/videotrans-1.6.1-r1.ebuild42
2 files changed, 94 insertions, 0 deletions
diff --git a/media-video/videotrans/files/videotrans-1.6.1-libav.patch b/media-video/videotrans/files/videotrans-1.6.1-libav.patch
new file mode 100644
index 000000000000..2b4cd0a15b8e
--- /dev/null
+++ b/media-video/videotrans/files/videotrans-1.6.1-libav.patch
@@ -0,0 +1,52 @@
+Description: Migrate from ffmpeg to avconv.
+Author: Alessio Treglia <alessio@debian.org>
+---
+ data/library.sh.in | 8 ++++----
+ src/movie-title.in | 2 +-
+ src/movie-to-dvd.in | 2 +-
+ 3 files changed, 6 insertions(+), 6 deletions(-)
+
+--- videotrans.orig/data/library.sh.in
++++ videotrans/data/library.sh.in
+@@ -250,15 +250,15 @@ audio_params()
+ then
+ if [ "${force_or_auto}" = "ac3" ]
+ then
+- msg="${msg}Converting the audio from WAV to AC3 with ${new_ch} channels using ffmpeg. "
++ msg="${msg}Converting the audio from WAV to AC3 with ${new_ch} channels using avconv. "
+ if [ "${audio_bitrate_override}" != "auto" -a "${audio_bitrate_override}" != "" ]
+ then
+- audio_encode="ffmpeg -y -v 0 -f wav -i /dev/stdin -ab ${audio_bitrate_override}k -ar 48000 -ac ${new_ch} `shellescape "${output}.ac3"`"
++ audio_encode="avconv -y -v 0 -f wav -i /dev/stdin -b:a ${audio_bitrate_override}k -ar 48000 -ac ${new_ch} `shellescape "${output}.ac3"`"
+ elif [ "${new_ch}" = "2" ]
+ then
+- audio_encode="ffmpeg -y -v 0 -f wav -i /dev/stdin -ab 192k -ar 48000 -ac ${new_ch} `shellescape "${output}.ac3"`"
++ audio_encode="avconv -y -v 0 -f wav -i /dev/stdin -b:a 192k -ar 48000 -ac ${new_ch} `shellescape "${output}.ac3"`"
+ else
+- audio_encode="ffmpeg -y -v 0 -f wav -i /dev/stdin -ab 448k -ar 48000 -ac ${new_ch} `shellescape "${output}.ac3"`"
++ audio_encode="avconv -y -v 0 -f wav -i /dev/stdin -b:a 448k -ar 48000 -ac ${new_ch} `shellescape "${output}.ac3"`"
+ fi
+ audio_ext="ac3"
+ else
+--- videotrans.orig/src/movie-title.in
++++ videotrans/src/movie-title.in
+@@ -961,7 +961,7 @@ else
+ \> "${TEMP}.mplayer" 2\>\&1 \< /dev/null \&
+ mplayer_pid="$!"
+
+- # Start mp2enc or ffmpeg to encode the audio
++ # Start mp2enc or avconv to encode the audio
+
+ {
+ < "${TEMP}.wav" $audio_filter_cmd | eval ${audio_encode}
+--- videotrans.orig/src/movie-to-dvd.in
++++ videotrans/src/movie-to-dvd.in
+@@ -698,7 +698,7 @@ do
+ } > "${TEMP}.video" 2>&1 &
+ video_enc_pid="$!"
+
+- # Start mp2enc or ffmpeg to encode the audio
++ # Start mp2enc or avconv to encode the audio
+
+ {
+ < "${TEMP}.wav" $audio_filter_cmd | eval ${audio_encode}
diff --git a/media-video/videotrans/videotrans-1.6.1-r1.ebuild b/media-video/videotrans/videotrans-1.6.1-r1.ebuild
new file mode 100644
index 000000000000..7ed341220bf1
--- /dev/null
+++ b/media-video/videotrans/videotrans-1.6.1-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils
+
+DESCRIPTION="A package to convert movies to DVD format and to build DVDs with"
+HOMEPAGE="http://videotrans.sourceforge.net/"
+SRC_URI="mirror://sourceforge/videotrans/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE="libav"
+
+DEPEND="
+ media-video/mplayer
+ media-video/mjpegtools[png]
+ media-video/dvdauthor
+ || ( media-gfx/imagemagick media-gfx/graphicsmagick[imagemagick] )
+ libav? ( media-video/libav )
+ !libav? ( media-video/ffmpeg:0 )
+"
+
+RDEPEND="${DEPEND}
+ www-client/lynx
+ app-shells/bash
+ sys-devel/bc
+"
+
+DOCS="aspects.txt CHANGES THANKS TODO"
+
+src_prepare() {
+ # fixing LDFLAGS usage
+ sed -i -e 's|^\(LDFLAGS.*=\).*\( @LIBS@.*\)|\1\2 @LDFLAGS@|' src/Makefile.in
+
+ # Debian patch to support libav
+ use libav && epatch "${FILESDIR}"/${P}-libav.patch
+}