summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-01-17 03:43:34 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-01-17 03:47:22 +0100
commit460ca8f587c7f197273db7057f27ad2d16adb487 (patch)
treeddc61c4a978095bf6724e210163373501739ef54 /media-video
parentmedia-video/x264-encoder: Switch virtual/ffmpeg -> USE ffmpeg/libav (diff)
downloadgentoo-460ca8f587c7f197273db7057f27ad2d16adb487.tar.gz
gentoo-460ca8f587c7f197273db7057f27ad2d16adb487.tar.bz2
gentoo-460ca8f587c7f197273db7057f27ad2d16adb487.zip
media-video/x264-encoder: EAPI-7 bump
Package-Manager: Portage-2.3.56, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-video')
-rw-r--r--media-video/x264-encoder/x264-encoder-9999.ebuild9
1 files changed, 4 insertions, 5 deletions
diff --git a/media-video/x264-encoder/x264-encoder-9999.ebuild b/media-video/x264-encoder/x264-encoder-9999.ebuild
index 3a0cdc8541fa..ae007c71112c 100644
--- a/media-video/x264-encoder/x264-encoder-9999.ebuild
+++ b/media-video/x264-encoder/x264-encoder-9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit flag-o-matic toolchain-funcs
@@ -12,8 +12,7 @@ if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://git.videolan.org/git/x264.git"
SRC_URI=""
else
- inherit versionator
- MY_P="x264-snapshot-$(get_version_component_range 3)-2245"
+ MY_P="x264-snapshot-$(ver_cut 3)-2245"
SRC_URI="http://download.videolan.org/pub/videolan/x264/snapshots/${MY_P}.tar.bz2"
KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
S="${WORKDIR}/${MY_P}"
@@ -38,8 +37,8 @@ ASM_DEP=">=dev-lang/nasm-2.13"
DEPEND="${RDEPEND}
amd64? ( ${ASM_DEP} )
x86? ( ${ASM_DEP} )
- x86-fbsd? ( ${ASM_DEP} )
- virtual/pkgconfig"
+ x86-fbsd? ( ${ASM_DEP} )"
+BDEPEND="virtual/pkgconfig"
PATCHES=( "${FILESDIR}/gpac.patch" )