summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2020-04-09 13:14:44 +0200
committerLars Wendler <polynomial-c@gentoo.org>2020-04-09 13:22:22 +0200
commit54a42e4bf640950e1002221314ca919bcdabd85d (patch)
treefd1ddae340358c9a3ab3144bf922308ef3f70bd1 /media-video
parentdev-libs/libressl: version bump to 3.1.0 (diff)
downloadgentoo-54a42e4bf640950e1002221314ca919bcdabd85d.tar.gz
gentoo-54a42e4bf640950e1002221314ca919bcdabd85d.tar.bz2
gentoo-54a42e4bf640950e1002221314ca919bcdabd85d.zip
media-video/simplescreenrecorder: Bump to version 0.4.0
Package-Manager: Portage-2.3.97, Repoman-2.3.22 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'media-video')
-rw-r--r--media-video/simplescreenrecorder/Manifest1
-rw-r--r--media-video/simplescreenrecorder/files/simplescreenrecorder-0.4.0-metainfo.patch37
-rw-r--r--media-video/simplescreenrecorder/simplescreenrecorder-0.4.0.ebuild114
3 files changed, 152 insertions, 0 deletions
diff --git a/media-video/simplescreenrecorder/Manifest b/media-video/simplescreenrecorder/Manifest
index 9a3f1c2fe3cf..74c8cbdd47d5 100644
--- a/media-video/simplescreenrecorder/Manifest
+++ b/media-video/simplescreenrecorder/Manifest
@@ -1 +1,2 @@
DIST simplescreenrecorder-0.3.11.tar.gz 1823944 BLAKE2B b7692ad158b4784f0222dd47227b85d33aae7eb416ed87d2eda1040027c910ec8d0ebe6a7e164e77cb9c3f6f2756e15fe97a7f05f45c92465473d2ae90e86b34 SHA512 5919774a00cd7015cd7db40561efaea43809b9465508b7770db9eb0fc87f338746e5cd4a79a0ab6c09e516257fa80184c3dcb5ab400c0ef2c0a8cf50ea2a073f
+DIST simplescreenrecorder-0.4.0.tar.gz 1867593 BLAKE2B 0997c4e72c142ebfa74658c1fd27d8d01ceb3810f659df0bf899004224d3944a58476fd6b54b318d712fa4d284684a221f387c7e3e63d4b397312ab9e0786988 SHA512 aa4970aba010884153c9d3155a0869288a5b9b8723cf617471148ad875f1af29f594403c1682303345c578cc0dc3f0a4b3596e4937d3afa949a652b83dcd0b36
diff --git a/media-video/simplescreenrecorder/files/simplescreenrecorder-0.4.0-metainfo.patch b/media-video/simplescreenrecorder/files/simplescreenrecorder-0.4.0-metainfo.patch
new file mode 100644
index 000000000000..799afe23e264
--- /dev/null
+++ b/media-video/simplescreenrecorder/files/simplescreenrecorder-0.4.0-metainfo.patch
@@ -0,0 +1,37 @@
+From 47078d2790e8c2f982dacfe27f998b7307b600c9 Mon Sep 17 00:00:00 2001
+From: Lars Wendler <polynomial-c@gentoo.org>
+Date: Thu, 9 Apr 2020 13:06:54 +0200
+Subject: [PATCH] Rename appdata to metainfo
+
+See https://www.freedesktop.org/software/appstream/docs/chap-Metadata.html
+chapter 2.1.2 "Filesystem locations"
+
+Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
+---
+ CMakeLists.txt | 4 ++--
+ ...recorder.appdata.xml => simplescreenrecorder.metainfo.xml} | 0
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+ rename data/{simplescreenrecorder.appdata.xml => simplescreenrecorder.metainfo.xml} (100%)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 7d7167b..760c889 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -86,8 +86,8 @@ if(WITH_SIMPLESCREENRECORDER)
+ DESTINATION ${CMAKE_INSTALL_FULL_DATADIR}/applications
+ )
+ install(
+- FILES data/simplescreenrecorder.appdata.xml
+- DESTINATION ${CMAKE_INSTALL_FULL_DATADIR}/appdata
++ FILES data/simplescreenrecorder.metainfo.xml
++ DESTINATION ${CMAKE_INSTALL_FULL_DATADIR}/metainfo
+ )
+
+ # icons
+diff --git a/data/simplescreenrecorder.appdata.xml b/data/simplescreenrecorder.metainfo.xml
+similarity index 100%
+rename from data/simplescreenrecorder.appdata.xml
+rename to data/simplescreenrecorder.metainfo.xml
+--
+2.26.0
+
diff --git a/media-video/simplescreenrecorder/simplescreenrecorder-0.4.0.ebuild b/media-video/simplescreenrecorder/simplescreenrecorder-0.4.0.ebuild
new file mode 100644
index 000000000000..4edd7070ece7
--- /dev/null
+++ b/media-video/simplescreenrecorder/simplescreenrecorder-0.4.0.ebuild
@@ -0,0 +1,114 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CMAKE_ECLASS=cmake
+inherit cmake-multilib flag-o-matic xdg
+
+if [[ ${PV} = 9999 ]]; then
+ inherit git-r3
+fi
+
+DESCRIPTION="A Simple Screen Recorder"
+HOMEPAGE="https://www.maartenbaert.be/simplescreenrecorder"
+LICENSE="GPL-3"
+PKGNAME="ssr"
+if [[ ${PV} = 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/MaartenBaert/${PKGNAME}.git"
+ EGIT_BOOTSTRAP=""
+else
+ SRC_URI="https://github.com/MaartenBaert/${PKGNAME}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${PKGNAME}-${PV}"
+fi
+
+SLOT="0"
+IUSE="+asm jack mp3 pulseaudio theora vorbis vpx x264"
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ media-libs/alsa-lib:0=
+ media-libs/mesa[${MULTILIB_USEDEP},X(+)]
+ || (
+ media-video/ffmpeg[vorbis?,vpx?,x264?,mp3?,theora?]
+ media-video/libav[vorbis?,vpx?,x264?,mp3?,theora?]
+ )
+ x11-libs/libX11[${MULTILIB_USEDEP}]
+ x11-libs/libXext
+ x11-libs/libXfixes[${MULTILIB_USEDEP}]
+ virtual/glu[${MULTILIB_USEDEP}]
+ jack? ( virtual/jack )
+ pulseaudio? ( media-sound/pulseaudio )
+"
+DEPEND="${RDEPEND}
+ dev-qt/linguist-tools:5
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.4.0-metainfo.patch"
+)
+
+pkg_pretend() {
+ if [[ "${ABI}" == amd64 ]]; then
+ elog "You may want to add USE flag 'abi_x86_32' when running a 64bit system"
+ elog "When added 32bit GLInject libraries are also included. This is"
+ elog "required if you want to use OpenGL recording on 32bit applications."
+ elog
+ fi
+
+ if { has_version media-video/ffmpeg[x264] || has_version media-video/libav[x264] ; } && has_version media-libs/x264[10bit] ; then
+ ewarn
+ ewarn "media-libs/x264 is currently built with 10bit useflag."
+ ewarn "This is known to prevent simplescreenrecorder from recording x264 videos"
+ ewarn "correctly. Please build media-libs/x264 without 10bit if you want to "
+ ewarn "record videos with x264."
+ ewarn
+ fi
+}
+
+pkg_setup() {
+ # QT requires -fPIC. Compile fails otherwise.
+ # Recently removed from the default compile options upstream
+ # https://github.com/MaartenBaert/ssr/commit/25fe1743058f0d1f95f6fbb39014b6ac146b5180
+ append-flags -fPIC
+}
+
+src_prepare() {
+ # required because xdg.eclass overrides default cmake_src_prepare
+ cmake_src_prepare
+}
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DENABLE_X86_ASM="$(usex asm)"
+ -DWITH_PULSEAUDIO="$(multilib_native_usex pulseaudio)"
+ -DWITH_JACK="$(multilib_native_usex jack)"
+ -DWITH_GLINJECT="true"
+ )
+
+ # libav doesn't have AVFrame::channels
+ # https://github.com/MaartenBaert/ssr/issues/195#issuecomment-45646159
+ if has_version media-video/libav ; then
+ mycmakeargs+=( -DENABLE_FFMPEG_VERSIONS="false" )
+ fi
+
+ if multilib_is_native_abi ; then
+ mycmakeargs+=(
+ -DENABLE_32BIT_GLINJECT="false"
+ -DWITH_QT5="true"
+ )
+ else
+ mycmakeargs+=(
+ # https://bugs.gentoo.org/660438
+ -DCMAKE_INSTALL_LIB32DIR="$(get_libdir)"
+ -DENABLE_32BIT_GLINJECT="true"
+ -DWITH_SIMPLESCREENRECORDER="false"
+ )
+ fi
+
+ cmake_src_configure
+}