summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-analyzer/sarg/sarg-2.3.10.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-analyzer/sarg/sarg-2.3.10.ebuild')
-rw-r--r--net-analyzer/sarg/sarg-2.3.10.ebuild69
1 files changed, 69 insertions, 0 deletions
diff --git a/net-analyzer/sarg/sarg-2.3.10.ebuild b/net-analyzer/sarg/sarg-2.3.10.ebuild
new file mode 100644
index 000000000000..6bf1111656da
--- /dev/null
+++ b/net-analyzer/sarg/sarg-2.3.10.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils
+
+DESCRIPTION="Squid Analysis Report Generator"
+HOMEPAGE="http://sarg.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="amd64 ppc x86"
+SLOT="0"
+IUSE="+gd ldap pcre"
+
+DEPEND="
+ gd? ( media-libs/gd[png,truetype] )
+ ldap? ( net-nds/openldap )
+ pcre? ( dev-libs/libpcre )
+"
+RDEPEND="${DEPEND}"
+
+DOCS=( BETA-TESTERS CONTRIBUTORS DONATIONS README ChangeLog htaccess )
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-2.3.9-configure.patch \
+ "${FILESDIR}"/${PN}-2.3.9-configure-bash.patch
+
+ sed -i \
+ -e 's:/usr/local/squid/var/logs/access.log:/var/log/squid/access.log:' \
+ -e 's:/usr/local/\(squidGuard/squidGuard.conf\):/etc/\1:' \
+ -e 's:/var/www/html/squid-reports:/var/www/localhost/htdocs/squid-reports:' \
+ -e 's:/usr/local/sarg/exclude_codes:/etc/sarg/exclude_codes:' \
+ sarg.conf || die
+
+ sed -i \
+ -e 's:"/var/www/html/squid-reports":"/var/www/localhost/htdocs/squid-reports":' \
+ log.c || die #43132
+
+ sed -i \
+ -e 's:/usr/local/sarg/passwd:/etc/sarg/passwd:' \
+ htaccess || die
+
+ sed -i \
+ -e 's:/usr/local/\(sarg/sarg.conf\):/etc/\1:' \
+ -e 's:/usr/local/squid/etc/passwd:/etc/squid/passwd:' \
+ user_limit_block || die
+
+ sed -i \
+ -e 's:/usr/local/squid/etc/block.txt:/etc/squid/etc/block.txt:' \
+ sarg-php/sarg-block-it.php || die
+
+ sed -i \
+ -e 's:/usr/local/\(sarg/sarg.conf\):/etc/\1:' \
+ -e 's:/usr/local/\(squidGuard/squidGuard.conf\):/etc/\1:' \
+ sarg.1 sarg-php/sarg-squidguard-block.php || die
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_with gd) \
+ $(use_with ldap) \
+ $(use_with pcre) \
+ --sysconfdir="${EPREFIX}/etc/sarg/"
+}