summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2017-05-14 11:36:32 +0200
committerJeroen Roovers <jer@gentoo.org>2017-05-14 11:36:32 +0200
commit48dca3295fe1d9353ecff4e155139aff7deb2351 (patch)
treef56d8b71aa5c29fd9812644d5893a2ff584ff56e /net-analyzer
parentnet-analyzer/fail2ban: Version bump. (diff)
downloadgentoo-48dca3295fe1d9353ecff4e155139aff7deb2351.tar.gz
gentoo-48dca3295fe1d9353ecff4e155139aff7deb2351.tar.bz2
gentoo-48dca3295fe1d9353ecff4e155139aff7deb2351.zip
net-analyzer/fail2ban: Update live ebuild.
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/fail2ban/fail2ban-0.9.7.ebuild1
-rw-r--r--net-analyzer/fail2ban/fail2ban-99999999.ebuild11
2 files changed, 10 insertions, 2 deletions
diff --git a/net-analyzer/fail2ban/fail2ban-0.9.7.ebuild b/net-analyzer/fail2ban/fail2ban-0.9.7.ebuild
index dfe115e9c2bf..f51e3cf37b7b 100644
--- a/net-analyzer/fail2ban/fail2ban-0.9.7.ebuild
+++ b/net-analyzer/fail2ban/fail2ban-0.9.7.ebuild
@@ -86,6 +86,7 @@ pkg_postinst() {
elog "You are upgrading from version 0.6.x, please see:"
elog "http://www.fail2ban.org/wiki/index.php/HOWTO_Upgrade_from_0.6_to_0.8"
fi
+
if ! has_version ${CATEGORY}/${PN}; then
if ! has_version dev-python/pyinotify && ! has_version app-admin/gamin; then
elog "For most jail.conf configurations, it is recommended you install either"
diff --git a/net-analyzer/fail2ban/fail2ban-99999999.ebuild b/net-analyzer/fail2ban/fail2ban-99999999.ebuild
index 34b83c3cedc9..b642ecf3d5b3 100644
--- a/net-analyzer/fail2ban/fail2ban-99999999.ebuild
+++ b/net-analyzer/fail2ban/fail2ban-99999999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
PYTHON_COMPAT=( python{2_7,3_4,3_5} pypy )
DISTUTILS_SINGLE_IMPL=1
@@ -35,10 +35,14 @@ REQUIRED_USE="systemd? ( !python_single_target_pypy )"
DOCS=( ChangeLog DEVELOP README.md THANKS TODO doc/run-rootless.txt )
python_prepare_all() {
+ eapply_user
+
# Replace /var/run with /run, but not in the top source directory
find . -mindepth 2 -type f -exec \
sed -i -e 's|/var\(/run/fail2ban\)|\1|g' {} + || die
+ sed -i -e 's|runscript|openrc-run|g' files/gentoo-initd || die
+
distutils-r1_python_prepare_all
}
@@ -82,16 +86,19 @@ pkg_postinst() {
elog "You are upgrading from version 0.6.x, please see:"
elog "http://www.fail2ban.org/wiki/index.php/HOWTO_Upgrade_from_0.6_to_0.8"
fi
+
if ! has_version ${CATEGORY}/${PN}; then
if ! has_version dev-python/pyinotify && ! has_version app-admin/gamin; then
elog "For most jail.conf configurations, it is recommended you install either"
elog "dev-python/pyinotify or app-admin/gamin (in order of preference)"
elog "to control how log file modifications are detected"
fi
+
if ! has_version dev-lang/python[sqlite]; then
elog "If you want to use ${PN}'s persistent database, then reinstall"
elog "dev-lang/python with USE=sqlite"
fi
+
if has_version sys-apps/systemd[-python]; then
elog "If you want to track logins through sys-apps/systemd's"
elog "journal backend, then reinstall sys-apps/systemd with USE=python"