summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre-Olivier Mercier <nemunaire@nemunai.re>2016-10-14 11:43:27 +0200
committerPatrice Clement <monsieurp@gentoo.org>2016-10-15 17:08:24 +0200
commiteea282ad74f5640e9775e785e68b0f05e1fb3a94 (patch)
tree541ecf072d3febc66671a724a5be5a7aba6f2798 /net-dns/knot
parentmail-filter/opensmtpd-extras: not compat with 6.0 (diff)
downloadgentoo-eea282ad74f5640e9775e785e68b0f05e1fb3a94.tar.gz
gentoo-eea282ad74f5640e9775e785e68b0f05e1fb3a94.tar.bz2
gentoo-eea282ad74f5640e9775e785e68b0f05e1fb3a94.zip
net-dns/knot: version bump to 2.3.1.
Package-Manager: portage-2.3.0 Closes: https://github.com/gentoo/gentoo/pull/2552 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'net-dns/knot')
-rw-r--r--net-dns/knot/Manifest2
-rw-r--r--net-dns/knot/files/2.3.0-added-conversion-to-wire-format-when-writing-FNV64-hash-values.patch216
-rw-r--r--net-dns/knot/knot-2.3.1.ebuild (renamed from net-dns/knot/knot-2.3.0.ebuild)8
3 files changed, 3 insertions, 223 deletions
diff --git a/net-dns/knot/Manifest b/net-dns/knot/Manifest
index 6193b8cd536e..bbe30e50cc00 100644
--- a/net-dns/knot/Manifest
+++ b/net-dns/knot/Manifest
@@ -1 +1 @@
-DIST knot-2.3.0.tar.xz 1066852 SHA256 8abf9a6562ecf2f7f4222d16ca6c75463399870db360eda7caa40530b469533c SHA512 28f0f6a00af3feb95ebd9af0c324ffeff1093f8e74136ce81f5a6e7f4434f22b9e371715b4b116de9b8faf39776be4d943c2ae09fb786e6061cc0394a767e8b6 WHIRLPOOL b0cc054c79d6b2ef7e9e0c2dba727042d92d235a08a0b15c56189c06f69087aee36d21947e1bf33304bbe0834d50421e9f01a4b4d7597aed05ed1b552c5ea52c
+DIST knot-2.3.1.tar.xz 1072808 SHA256 42e4ec64dc8f017329d1753eb074a5759d6bb380e1f2a272101adccc0552f9b4 SHA512 10d8c09d7cce88aba95b067da9b138af710864de4ef9c00d7ab165b4aca621d9ff15a49b5102e0cdd7bfb14e2806ed8587fd138b6e6af74a01e26e6d6ffe1163 WHIRLPOOL 70cdb9434a80c56b7e425b1aa3389ae22c9dea289a8081464be21abf6afebc46a9bffaa6363955a01aa3aa1bea3a71e46ef75dfce77c7e0a63dcd3c8622287c0
diff --git a/net-dns/knot/files/2.3.0-added-conversion-to-wire-format-when-writing-FNV64-hash-values.patch b/net-dns/knot/files/2.3.0-added-conversion-to-wire-format-when-writing-FNV64-hash-values.patch
deleted file mode 100644
index 60667abb21b1..000000000000
--- a/net-dns/knot/files/2.3.0-added-conversion-to-wire-format-when-writing-FNV64-hash-values.patch
+++ /dev/null
@@ -1,216 +0,0 @@
-From 84849be189c49ef9556bd84d5e5103317372e8a7 Mon Sep 17 00:00:00 2001
-From: Karel Slany <karel.slany@nic.cz>
-Date: Thu, 11 Aug 2016 11:39:39 +0200
-Subject: [PATCH] Added conversion to wire format when writing FNV64 hash values.
-
-Test on big-endian machines have been failing.
----
- src/libknot/cookies/alg-fnv64.c | 6 +++---
- tests/libknot/test_cookies-client.c | 20 ++++++++++----------
- tests/libknot/test_cookies-server.c | 20 ++++++++++----------
- 3 files changed, 23 insertions(+), 23 deletions(-)
-
-diff --git a/src/libknot/cookies/alg-fnv64.c b/src/libknot/cookies/alg-fnv64.c
-index 9989a4f..5e263c1 100644
---- a/src/libknot/cookies/alg-fnv64.c
-+++ b/src/libknot/cookies/alg-fnv64.c
-@@ -17,10 +17,10 @@
- #include <assert.h>
- #include <stdint.h>
- #include <stdlib.h>
--#include <string.h>
-
- #include "contrib/fnv/fnv.h"
- #include "contrib/sockaddr.h"
-+#include "contrib/wire.h"
- #include "libknot/attribute.h"
- #include "libknot/cookies/alg-fnv64.h"
- #include "libknot/rrtype/opt-cookie.h"
-@@ -80,7 +80,7 @@ static uint16_t cc_gen_fnv64(const struct knot_cc_input *input,
- assert(KNOT_OPT_COOKIE_CLNT == sizeof(hash_val));
-
- cc_len = sizeof(hash_val);
-- memcpy(cc_out, &hash_val, cc_len);
-+ wire_write_u64(cc_out, hash_val);
-
- return cc_len;
- }
-@@ -127,7 +127,7 @@ static uint16_t sc_gen_fnv64(const struct knot_sc_input *input,
- assert(SRVR_FNV64_HASH_SIZE == sizeof(hash_val));
-
- hash_len = sizeof(hash_val);
-- memcpy(hash_out, &hash_val, hash_len);
-+ wire_write_u64(hash_out, hash_val);
-
- return hash_len;
- }
-diff --git a/tests/libknot/test_cookies-client.c b/tests/libknot/test_cookies-client.c
-index 44be903..712dbba 100644
---- a/tests/libknot/test_cookies-client.c
-+++ b/tests/libknot/test_cookies-client.c
-@@ -110,7 +110,7 @@ int main(int argc, char *argv[])
- hash_len = knot_cc_alg_fnv64.gen_func(&cc_in, hash, hash_len);
- ok(hash_len != 0 && hash_len == knot_cc_alg_fnv64.cc_size, "cookies: FNV64 client cookie output");
- {
-- uint8_t expected[] = { 0x74, 0x31, 0xf9, 0xa8, 0x03, 0xef, 0x15, 0xb1 };
-+ uint8_t expected[] = { 0xb1, 0x15, 0xef, 0x03, 0xa8, 0xf9, 0x31, 0x74 };
- ok(sizeof(expected) == hash_len && 0 == memcmp(expected, hash, hash_len), "cookies: FNV64 client cookie content");
- }
-
-@@ -123,7 +123,7 @@ int main(int argc, char *argv[])
- hash_len = knot_cc_alg_fnv64.gen_func(&cc_in, hash, hash_len);
- ok(hash_len != 0 && hash_len == knot_cc_alg_fnv64.cc_size, "cookies: FNV64 client cookie output");
- {
-- uint8_t expected[] = { 0x7c, 0x62, 0x25, 0xd2, 0x43, 0xdd, 0x09, 0xe7 };
-+ uint8_t expected[] = { 0xe7, 0x09, 0xdd, 0x43, 0xd2, 0x25, 0x62, 0x7c };
- ok(sizeof(expected) == hash_len && 0 == memcmp(expected, hash, hash_len), "cookies: FNV64 client cookie content");
- }
-
-@@ -136,7 +136,7 @@ int main(int argc, char *argv[])
- hash_len = knot_cc_alg_fnv64.gen_func(&cc_in, hash, hash_len);
- ok(hash_len != 0 && hash_len == knot_cc_alg_fnv64.cc_size, "cookies: FNV64 client cookie output");
- {
-- uint8_t expected[] = { 0x7c, 0x62, 0x25, 0xd2, 0x43, 0xdd, 0x09, 0xe7 };
-+ uint8_t expected[] = { 0xe7, 0x09, 0xdd, 0x43, 0xd2, 0x25, 0x62, 0x7c };
- ok(sizeof(expected) == hash_len && 0 == memcmp(expected, hash, hash_len), "cookies: FNV64 client cookie content");
- }
-
-@@ -149,7 +149,7 @@ int main(int argc, char *argv[])
- hash_len = knot_cc_alg_fnv64.gen_func(&cc_in, hash, hash_len);
- ok(hash_len != 0 && hash_len == knot_cc_alg_fnv64.cc_size, "cookies: FNV64 client cookie output");
- {
-- uint8_t expected[] = { 0x05, 0xa9, 0xd1, 0x08, 0x1b, 0x98, 0xe0, 0xaa };
-+ uint8_t expected[] = { 0xaa, 0xe0, 0x98, 0x1b, 0x08, 0xd1, 0xa9, 0x05 };
- ok(sizeof(expected) == hash_len && 0 == memcmp(expected, hash, hash_len), "cookies: FNV64 client cookie content");
- }
-
-@@ -162,7 +162,7 @@ int main(int argc, char *argv[])
- hash_len = knot_cc_alg_fnv64.gen_func(&cc_in, hash, hash_len);
- ok(hash_len != 0 && hash_len == knot_cc_alg_fnv64.cc_size, "cookies: FNV64 client cookie output");
- {
-- uint8_t expected[] = { 0x05, 0xa9, 0xd1, 0x08, 0x1b, 0x98, 0xe0, 0xaa };
-+ uint8_t expected[] = { 0xaa, 0xe0, 0x98, 0x1b, 0x08, 0xd1, 0xa9, 0x05 };
- ok(sizeof(expected) == hash_len && 0 == memcmp(expected, hash, hash_len), "cookies: FNV64 client cookie content");
- }
-
-@@ -179,7 +179,7 @@ int main(int argc, char *argv[])
- }
-
- {
-- uint8_t cookie[] = { 0x33, 0x0c, 0xa6, 0x80, 0x94, 0x17, 0xe5, 0xaf };
-+ uint8_t cookie[] = { 0xaf, 0xe5, 0x17, 0x94, 0x80, 0xa6, 0x0c, 0x33 };
- ret = knot_cc_check(cookie, sizeof(cookie), NULL, &knot_cc_alg_fnv64);
- ok(ret == KNOT_EINVAL, "cookies: FNV64 client cookie check no input");
- }
-@@ -190,7 +190,7 @@ int main(int argc, char *argv[])
- cc_in.secret_data = secret;
- cc_in.secret_len = sizeof(secret);
- {
-- uint8_t cookie[] = { 0x33, 0x0c, 0xa6, 0x80, 0x94, 0x17, 0xe5, 0xaf };
-+ uint8_t cookie[] = { 0xaf, 0xe5, 0x17, 0x94, 0x80, 0xa6, 0x0c, 0x33 };
- ret = knot_cc_check(cookie, sizeof(cookie), &cc_in, NULL);
- ok(ret == KNOT_EINVAL, "cookies: FNV64 client cookie check no algorithm");
- }
-@@ -201,7 +201,7 @@ int main(int argc, char *argv[])
- cc_in.secret_data = secret;
- cc_in.secret_len = sizeof(secret);
- {
-- uint8_t cookie[] = { 0x33, 0x0c, 0xa6, 0x80, 0x94, 0x17, 0xe5, 0xaf };
-+ uint8_t cookie[] = { 0xaf, 0xe5, 0x17, 0x94, 0x80, 0xa6, 0x0c, 0x33 };
- ret = knot_cc_check(cookie, sizeof(cookie), &cc_in, &knot_cc_alg_fnv64);
- ok(ret == KNOT_EOK, "cookies: FNV64 client good cookie check");
- }
-@@ -212,7 +212,7 @@ int main(int argc, char *argv[])
- cc_in.secret_data = secret;
- cc_in.secret_len = sizeof(secret);
- {
-- uint8_t cookie[] = { 0x33, 0x0c, 0xa6, 0x80, 0x94, 0x17, 0xe5, 0xaf };
-+ uint8_t cookie[] = { 0xaf, 0xe5, 0x17, 0x94, 0x80, 0xa6, 0x0c, 0x33 };
- ret = knot_cc_check(cookie, sizeof(cookie) - 1, &cc_in, &knot_cc_alg_fnv64);
- ok(ret == KNOT_EINVAL, "cookies: FNV64 client cookie check invalid length");
- }
-@@ -223,7 +223,7 @@ int main(int argc, char *argv[])
- cc_in.secret_data = secret;
- cc_in.secret_len = sizeof(secret);
- {
-- uint8_t cookie[] = { 0x33, 0x0c, 0xa6, 0x80, 0x94, 0x17, 0xe5, 0xae };
-+ uint8_t cookie[] = { 0xaf, 0xe5, 0x17, 0x94, 0x80, 0xa6, 0x0c, 0x32 };
- ret = knot_cc_check(cookie, sizeof(cookie), &cc_in, &knot_cc_alg_fnv64);
- ok(ret == KNOT_EINVAL, "cookies: FNV64 client cookie check invalid cookie");
- }
-diff --git a/tests/libknot/test_cookies-server.c b/tests/libknot/test_cookies-server.c
-index 32001c1..66a54ba 100644
---- a/tests/libknot/test_cookies-server.c
-+++ b/tests/libknot/test_cookies-server.c
-@@ -28,10 +28,10 @@
- #include "libknot/rrtype/opt-cookie.h"
-
- const char *cookie_opts[] = {
-- "\x00\x0a" "\x00\x10" "\x00\x01\x02\x03\x04\x05\x06\x07" "\xe0\xd9\x95\x4e\xbc\xc3\x99\x18", /* 8 octets long wrong server cookie. */
-- "\x00\x0a" "\x00\x10" "\x00\x01\x02\x03\x04\x05\x06\x07" "\xe0\xd9\x95\x4e\xbc\xc3\x99\x19", /* 8 octets long OK server cookie. */
-- "\x00\x0a" "\x00\x18" "\x00\x01\x02\x03\x04\x05\x06\x07" "\x0a\x0b\x0c\x0d\x0e\x0f\x10\x11\xc0\xbd\xdb\xec\x19\x78\x88\x38", /* 8B nonce 8B hash long wrong server cookie. */
-- "\x00\x0a" "\x00\x18" "\x00\x01\x02\x03\x04\x05\x06\x07" "\x0a\x0b\x0c\x0d\x0e\x0f\x10\x11\xc0\xbd\xdb\xec\x19\x78\x88\x39" /* 8B nonce 8B hash long OK server cookie. */
-+ "\x00\x0a" "\x00\x10" "\x00\x01\x02\x03\x04\x05\x06\x07" "\x19\x99\xc3\xbc\x4e\x95\xd9\xdf", /* 8 octets long wrong server cookie. */
-+ "\x00\x0a" "\x00\x10" "\x00\x01\x02\x03\x04\x05\x06\x07" "\x19\x99\xc3\xbc\x4e\x95\xd9\xe0", /* 8 octets long OK server cookie. */
-+ "\x00\x0a" "\x00\x18" "\x00\x01\x02\x03\x04\x05\x06\x07" "\x0a\x0b\x0c\x0d\x0e\x0f\x10\x11\x39\x88\x78\x19\xec\xdb\xbd\xbf", /* 8B nonce 8B hash long wrong server cookie. */
-+ "\x00\x0a" "\x00\x18" "\x00\x01\x02\x03\x04\x05\x06\x07" "\x0a\x0b\x0c\x0d\x0e\x0f\x10\x11\x39\x88\x78\x19\xec\xdb\xbd\xc0"/* 8B nonce 8B hash long OK server cookie. */
- };
-
- #define ROPT(i) ((const uint8_t *)cookie_opts[(i)])
-@@ -193,7 +193,7 @@ int main(int argc, char *argv[])
- hash_len = knot_sc_alg_fnv64.hash_func(&sc_in, hash, hash_len);
- ok(hash_len != 0, "cookies: FNV64 server cookie output");
- {
-- uint8_t expected[] = { 0x75, 0x45, 0x7c, 0x9a, 0xe0, 0x13, 0xa8, 0xea };
-+ uint8_t expected[] = { 0xea, 0xa8, 0x13, 0xe0, 0x9a, 0x7c, 0x45, 0x75 };
- ok(sizeof(expected) == hash_len && 0 == memcmp(expected, hash, hash_len), "cookies: FNV64 server cookie content");
- }
-
-@@ -210,7 +210,7 @@ int main(int argc, char *argv[])
- hash_len = knot_sc_alg_fnv64.hash_func(&sc_in, hash, hash_len);
- ok(hash_len != 0, "cookies: FNV64 server cookie output");
- {
-- uint8_t expected[] = { 0xc0, 0xbd, 0xdb, 0xec, 0x19, 0x78, 0x88, 0x39 };
-+ uint8_t expected[] = { 0x39, 0x88, 0x78, 0x19, 0xec, 0xdb, 0xbd, 0xc0 };
- ok(sizeof(expected) == hash_len && 0 == memcmp(expected, hash, hash_len), "cookies: FNV64 server cookie content");
- }
-
-@@ -227,7 +227,7 @@ int main(int argc, char *argv[])
- hash_len = knot_sc_alg_fnv64.hash_func(&sc_in, hash, hash_len);
- ok(hash_len != 0, "cookies: FNV64 server cookie output");
- {
-- uint8_t expected[] = { 0xe0, 0xd9, 0x95, 0x4e, 0xbc, 0xc3, 0x99, 0x19 };
-+ uint8_t expected[] = { 0x19, 0x99, 0xc3, 0xbc, 0x4e, 0x95, 0xd9, 0xe0 };
- ok(sizeof(expected) == hash_len && 0 == memcmp(expected, hash, hash_len), "cookies: FNV64 server cookie content");
- }
-
-@@ -244,7 +244,7 @@ int main(int argc, char *argv[])
- hash_len = knot_sc_alg_fnv64.hash_func(&sc_in, hash, hash_len);
- ok(hash_len != 0, "cookies: FNV64 server cookie output");
- {
-- uint8_t expected[] = { 0x4d, 0xde, 0xfa, 0x22, 0xb9, 0x0a, 0xcc, 0xd8 };
-+ uint8_t expected[] = { 0xd8, 0xcc, 0x0a, 0xb9, 0x22, 0xfa, 0xde, 0x4d };
- ok(sizeof(expected) == hash_len && 0 == memcmp(expected, hash, hash_len), "cookies: FNV64 server cookie content");
- }
-
-@@ -261,7 +261,7 @@ int main(int argc, char *argv[])
- hash_len = knot_sc_alg_fnv64.hash_func(&sc_in, hash, hash_len);
- ok(hash_len != 0, "cookies: FNV64 server cookie output");
- {
-- uint8_t expected[] = { 0xa0, 0x35, 0xe3, 0xe0, 0x78, 0x7a, 0x91, 0xaf };
-+ uint8_t expected[] = { 0xaf, 0x91, 0x7a, 0x78, 0xe0, 0xe3, 0x35, 0xa0 };
- ok(sizeof(expected) == hash_len && 0 == memcmp(expected, hash, hash_len), "cookies: FNV64 server cookie content");
- }
-
-@@ -278,7 +278,7 @@ int main(int argc, char *argv[])
- hash_len = knot_sc_alg_fnv64.hash_func(&sc_in, hash, hash_len);
- ok(hash_len != 0, "cookies: FNV64 server cookie output");
- {
-- uint8_t expected[] = { 0x8e, 0xa3, 0xf8, 0x97, 0x84, 0x0a, 0x3d, 0x8b };
-+ uint8_t expected[] = { 0x8b, 0x3d, 0x0a, 0x84, 0x97, 0xf8, 0xa3, 0x8e };
- ok(sizeof(expected) == hash_len && 0 == memcmp(expected, hash, hash_len), "cookies: FNV64 server cookie content");
- }
-
---
-libgit2 0.24.0
-
diff --git a/net-dns/knot/knot-2.3.0.ebuild b/net-dns/knot/knot-2.3.1.ebuild
index 5a9cecaee3c7..67019dcf9fec 100644
--- a/net-dns/knot/knot-2.3.0.ebuild
+++ b/net-dns/knot/knot-2.3.1.ebuild
@@ -16,7 +16,7 @@ KEYWORDS="~amd64 ~x86"
IUSE="debug dnstap doc caps +fastparser idn systemd"
RDEPEND="
- >=net-libs/gnutls-3.0
+ >=net-libs/gnutls-3.3
>=dev-libs/jansson-2.3
>=dev-db/lmdb-0.9.15
>=dev-libs/userspace-rcu-0.5.4
@@ -35,10 +35,6 @@ DEPEND="${RDEPEND}
doc? ( dev-python/sphinx )
"
-PATCHES=(
- "${FILESDIR}/2.3.0-added-conversion-to-wire-format-when-writing-FNV64-hash-values.patch"
-)
-
S="${WORKDIR}/${P/_/-}"
src_configure() {
@@ -53,7 +49,7 @@ src_configure() {
$(use_enable dnstap) \
$(use_enable doc documentation) \
$(use_with idn libidn) \
- $(usex systemd --enable-systemd=yes --enable-systemd=no)
+ --enable-systemd=$(usex systemd)
}
src_compile() {