summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorQuentin Retornaz <caseoffr@outlook.com>2018-04-19 14:49:01 +0200
committerAnthony G. Basile <blueness@gentoo.org>2018-04-20 06:41:50 -0400
commit235f9534d5f6571fd67de7ec7410eb206dacf14c (patch)
tree7af02d69c2a5e232a63adffb2d66a72f0a36d076 /net-dns
parentnet-libs/gtk-vnc-0.7.2: remove gtk2 support, simplify ebuild (diff)
downloadgentoo-235f9534d5f6571fd67de7ec7410eb206dacf14c.tar.gz
gentoo-235f9534d5f6571fd67de7ec7410eb206dacf14c.tar.bz2
gentoo-235f9534d5f6571fd67de7ec7410eb206dacf14c.zip
net-dns/getdns: add dev-libs/libbsd sys-libs/libcap dependencies and static-libs use flag
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/getdns/getdns-1.4.1.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/net-dns/getdns/getdns-1.4.1.ebuild b/net-dns/getdns/getdns-1.4.1.ebuild
index 13ab6bc3b156..699abdbc82fa 100644
--- a/net-dns/getdns/getdns-1.4.1.ebuild
+++ b/net-dns/getdns/getdns-1.4.1.ebuild
@@ -12,9 +12,10 @@ SRC_URI="https://getdnsapi.net/releases/${P//./-}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="stubby +getdns_query +getdns_server_mon libressl +idn +unbound libevent libev libuv +threads"
+IUSE="stubby +getdns_query +getdns_server_mon libressl +idn +unbound libevent libev libuv +threads static-libs"
DEPEND="
+ dev-libs/libbsd:=
dev-libs/libyaml:=
!libressl? ( dev-libs/openssl:0= )
libressl? ( dev-libs/libressl:0= )
@@ -24,7 +25,10 @@ DEPEND="
libev? ( dev-libs/libev:= )
libuv? ( dev-libs/libuv:= )
"
-RDEPEND="${DEPEND}"
+RDEPEND="
+ ${DEPEND}
+ stubby? ( sys-libs/libcap:= )
+"
src_configure() {
econf \
@@ -40,6 +44,7 @@ src_configure() {
$(use_with libev) \
$(use_with libuv) \
$(use_with threads libpthread)
+ $(use_enable static-libs static)
}
src_install() {