summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre-Olivier Mercier <nemunaire@nemunai.re>2018-02-13 12:11:09 +0100
committerPatrice Clement <monsieurp@gentoo.org>2018-02-18 18:15:22 +0100
commit6b995e8923977c31e654d463397fe4666d6d789d (patch)
tree9344bbd61d82837592cc852f20b6823638150d0d /net-dns
parentsys-block/targetcli-fb: remove version 2.1.44. (diff)
downloadgentoo-6b995e8923977c31e654d463397fe4666d6d789d.tar.gz
gentoo-6b995e8923977c31e654d463397fe4666d6d789d.tar.bz2
gentoo-6b995e8923977c31e654d463397fe4666d6d789d.zip
net-dns/knot: version bump to 2.6.5.
Package-Manager: Portage-2.3.13, Repoman-2.3.3 Closes: https://github.com/gentoo/gentoo/pull/7180
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/knot/Manifest1
-rw-r--r--net-dns/knot/knot-2.6.5.ebuild102
2 files changed, 103 insertions, 0 deletions
diff --git a/net-dns/knot/Manifest b/net-dns/knot/Manifest
index c485149c96ca..18ea9bcebbf1 100644
--- a/net-dns/knot/Manifest
+++ b/net-dns/knot/Manifest
@@ -1,2 +1,3 @@
DIST knot-2.5.7.tar.xz 1084656 BLAKE2B c2d583625a19f6a61248b3b42cdf14f5bb2bdbafdb20be6b0813744095a4016a4be2eb5e2dfaff0628238c60153480175a86706db0b88569d76156f86ba33968 SHA512 96e375f556309bb89cea982dda169cef70c23d03c48282110e47a44849c1102cd37d98aa7650781b399f5d932b724b8a935f0b9e55e4920465ae7b74a0d1d55a
DIST knot-2.6.4.tar.xz 1116928 BLAKE2B 7914addec8ff1826c81c2de098ed4e3b7686c877d40c727286d2d9c8c477fb02c1d0ad38befa77ccc92c5e068d6bc4c86e5df8ad9f5541cc0e3dc6f63192af58 SHA512 7242ef76bd3a379f574ca9af8fec96b0419c2209b6d8114c3b8e675cb5459ec70dab928a5a9ba9850fe1d7201729c9ff7e4c8800674e840e1cf04544c32a6f78
+DIST knot-2.6.5.tar.xz 1118084 BLAKE2B 941d90803e51c5af003fcdaaaa22ffede326492cf60836efc09a06e18740743cc9f806e4750934f6959ced88616f46fc5dbc6667099d53eb4a21fae524497c9c SHA512 ed0d1d30e6d8d802e669aac12c4fd0cec8e315eb0e2c05b722f49ada434c82b8caebf12568881e5fbba2f61a5027c44fbde42b543c9086ff2e9614caf42a6d12
diff --git a/net-dns/knot/knot-2.6.5.ebuild b/net-dns/knot/knot-2.6.5.ebuild
new file mode 100644
index 000000000000..63edc2b56df8
--- /dev/null
+++ b/net-dns/knot/knot-2.6.5.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit systemd user
+
+DESCRIPTION="High-performance authoritative-only DNS server"
+HOMEPAGE="https://www.knot-dns.cz/"
+SRC_URI="https://secure.nic.cz/files/knot-dns/${P/_/-}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+KNOT_MODULES=(
+ "+dnsproxy"
+ "dnstap"
+ "+noudp"
+ "+onlinesign"
+ "rosedb"
+ "+rrl"
+ "+stats"
+ "+synthrecord"
+ "+whoami"
+)
+IUSE="doc caps +fastparser idn libidn2 systemd +utils ${KNOT_MODULES[@]}"
+
+RDEPEND="
+ >=dev-db/lmdb-0.9.15
+ dev-libs/libedit
+ >=dev-libs/userspace-rcu-0.5.4
+ dev-python/lmdb
+ >=net-libs/gnutls-3.3:=
+ caps? ( >=sys-libs/libcap-ng-0.6.4 )
+ dnstap? (
+ dev-libs/fstrm
+ dev-libs/protobuf-c
+ )
+ idn? (
+ !libidn2? ( net-dns/libidn )
+ libidn2? ( >=net-dns/libidn2-2.0.0 )
+ )
+ systemd? ( >=sys-apps/systemd-229 )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( dev-python/sphinx )
+"
+
+S="${WORKDIR}/${P/_/-}"
+
+src_configure() {
+ local u
+ local my_conf=()
+ for u in "${KNOT_MODULES[@]#+}"; do
+ my_conf+=("$(use_with $u module-$u)")
+ done
+
+ econf \
+ --with-storage="${EPREFIX}/var/lib/${PN}" \
+ --with-rundir="${EPREFIX}/var/run/${PN}" \
+ $(use_enable fastparser) \
+ $(use_enable dnstap) \
+ $(use_enable doc documentation) \
+ $(use_enable utils utilities) \
+ --enable-systemd=$(usex systemd) \
+ $(use_with idn libidn) \
+ "${my_conf[@]}"
+}
+
+src_compile() {
+ default
+
+ if use doc; then
+ emake -C doc html
+ HTML_DOCS=( doc/_build/html/{*.html,*.js,_sources,_static} )
+ fi
+}
+
+src_test() {
+ emake check
+}
+
+src_install() {
+ default
+
+ rmdir "${D}var/run/${PN}" "${D}var/run/" || die
+ keepdir /var/lib/${PN}
+
+ newinitd "${FILESDIR}/knot.init" knot
+ if use systemd; then
+ systemd_newunit "${FILESDIR}/knot-1.service" knot.service
+ fi
+
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ enewgroup knot 53
+ enewuser knot 53 -1 /var/lib/knot knot
+}