summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorConrad Kostecki <conrad@kostecki.com>2019-03-04 19:24:12 +0100
committerPatrice Clement <monsieurp@gentoo.org>2019-03-10 23:35:01 +0100
commit1d1eb41fa75e4492090deb011d0bc16ea4f1ba3c (patch)
tree75f8a9428911823132fb4f93510bd1e078a8acef /net-im
parentdev-python/openpyxl: version bump to 2.6.1 and EAPI 7. (diff)
downloadgentoo-1d1eb41fa75e4492090deb011d0bc16ea4f1ba3c.tar.gz
gentoo-1d1eb41fa75e4492090deb011d0bc16ea4f1ba3c.tar.bz2
gentoo-1d1eb41fa75e4492090deb011d0bc16ea4f1ba3c.zip
net-im/spectrum2: bump to version 2.0.10.1.
Also removed the debug use flag and patch. Users, who wish to enable debug mode, can still compile by adding themself the needed debug cflags to the CFLAGS variable. Closes: https://bugs.gentoo.org/674498 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Conrad Kostecki <conrad@kostecki.com> Closes: https://github.com/gentoo/gentoo/pull/11258 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'net-im')
-rw-r--r--net-im/spectrum2/Manifest1
-rw-r--r--net-im/spectrum2/spectrum2-2.0.10.1.ebuild114
2 files changed, 115 insertions, 0 deletions
diff --git a/net-im/spectrum2/Manifest b/net-im/spectrum2/Manifest
index 3503d086f653..8e32d4648ab4 100644
--- a/net-im/spectrum2/Manifest
+++ b/net-im/spectrum2/Manifest
@@ -1 +1,2 @@
+DIST spectrum2-2.0.10.1.tar.gz 844983 BLAKE2B f10a057f35ecb865497e26b6d31d37c895b351d7c93e7c00bf9d58bf855b49ee1ce0acbeab841a442ab2ab702b022675ca4478521ecac2f6d0bdb9d7e00b9060 SHA512 dde84e67b2ade8649a38027c398defd4dc911ed402e913779aca0b29aa801f1c17ef89b1b3abf91c3189e75b32e9162d6e9d52f90ce537091b65fb791a826357
DIST spectrum2-2.0.10.tar.gz 844427 BLAKE2B cb57bede4bfe996219ca5d0e62167643eb51fe44fd607400de8c2640f3892af9d089b6d62d7c25485049ef2a37066b3f6de46bfb5a6b7107fef6eb31dcf736f3 SHA512 b74f6f543aaa923a589b8b0b1007dec260af6fb66e5475c0294216713568dd93f4f52f39e6cbe4c6263efb0a479ac4d8095709d758e4faac81fc7d4712fd0b2c
diff --git a/net-im/spectrum2/spectrum2-2.0.10.1.ebuild b/net-im/spectrum2/spectrum2-2.0.10.1.ebuild
new file mode 100644
index 000000000000..317a25b2ab55
--- /dev/null
+++ b/net-im/spectrum2/spectrum2-2.0.10.1.ebuild
@@ -0,0 +1,114 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit cmake-utils python-single-r1 systemd user
+
+DESCRIPTION="An open source instant messaging transport"
+HOMEPAGE="https://www.spectrum.im"
+SRC_URI="https://github.com/SpectrumIM/spectrum2/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc frotz irc mysql postgres purple sms +sqlite test twitter whatsapp xmpp"
+REQUIRED_USE="|| ( mysql postgres sqlite )"
+
+RDEPEND="
+ dev-libs/boost:=[nls]
+ dev-libs/expat
+ dev-libs/libev:=
+ dev-libs/log4cxx
+ dev-libs/jsoncpp:=
+ dev-libs/openssl:0=
+ dev-libs/popt
+ dev-libs/protobuf:=
+ net-dns/libidn:0=
+ net-im/swift:=
+ net-misc/curl
+ sys-libs/zlib:=
+ frotz? ( !games-engines/frotz )
+ irc? ( net-im/libcommuni )
+ mysql? (
+ || (
+ dev-db/mariadb-connector-c
+ dev-db/mysql-connector-c
+ )
+ )
+ postgres? ( dev-libs/libpqxx:= )
+ purple? (
+ dev-libs/glib
+ net-im/pidgin:=
+ )
+ sms? ( app-mobilephone/smstools )
+ sqlite? ( dev-db/sqlite:3 )
+ twitter? ( net-misc/curl )
+ whatsapp? ( net-im/transwhat )"
+
+DEPEND="
+ ${PYTHON_DEPS}
+ ${RDEPEND}
+ doc? ( app-doc/doxygen )
+ test? (
+ dev-python/sleekxmpp[${PYTHON_USEDEP}]
+ dev-util/cppunit
+ net-irc/ngircd
+ )
+"
+
+# Tests are currently restricted, as they do completly fail
+RESTRICT="test"
+
+pkg_setup() {
+ enewgroup spectrum
+ enewuser spectrum -1 -1 /var/lib/spectrum2 spectrum
+
+ use test && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ # Respect users LDFLAGS
+ sed -i -e "s/-Wl,-export-dynamic/& ${LDFLAGS}/" spectrum/src/CMakeLists.txt || die
+
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_DOCS="$(usex doc)"
+ -DENABLE_FROTZ="$(usex frotz)"
+ -DENABLE_IRC="$(usex irc)"
+ -DENABLE_MYSQL="$(usex mysql)"
+ -DENABLE_PQXX="$(usex postgres)"
+ -DENABLE_PURPLE="$(usex purple)"
+ -DENABLE_SMSTOOLS3="$(usex sms)"
+ -DENABLE_SQLITE3="$(usex sqlite)"
+ -DENABLE_TESTS="$(usex test)"
+ -DENABLE_TWITTER="$(usex twitter)"
+ -DENABLE_XMPP="$(usex xmpp)"
+ -DLIB_INSTALL_DIR="$(get_libdir)"
+ )
+
+ cmake-utils_src_configure
+}
+
+src_test() {
+ cd tests/libtransport && "${EPYTHON}" ../start.py || die
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ diropts -o spectrum -g spectrum
+ keepdir /var/log/spectrum2 /var/lib/spectrum2
+ diropts
+
+ newinitd "${FILESDIR}"/spectrum2.initd spectrum2
+ systemd_newunit "${FILESDIR}"/spectrum2.service spectrum2.service
+ systemd_newtmpfilesd "${FILESDIR}"/spectrum2.tmpfiles spectrum2.conf
+
+ einstalldocs
+}