summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-irc/irc-client
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-irc/irc-client')
-rw-r--r--net-irc/irc-client/Manifest1
-rw-r--r--net-irc/irc-client/files/irc-client-2.10.3_p7-amd64-chost.patch29
-rw-r--r--net-irc/irc-client/irc-client-2.10.3_p7.ebuild47
-rw-r--r--net-irc/irc-client/metadata.xml5
4 files changed, 82 insertions, 0 deletions
diff --git a/net-irc/irc-client/Manifest b/net-irc/irc-client/Manifest
new file mode 100644
index 000000000000..97f360cbf0f6
--- /dev/null
+++ b/net-irc/irc-client/Manifest
@@ -0,0 +1 @@
+DIST irc2.10.3p7.tgz 678412 SHA256 1c7b5ba8e03d096a1b7412b6a50f2e3e00fce77193e2a66cd0ab8a9de02253b9 SHA512 84a148b95de3be32ffc2d11095c3da2e06b6fb963498020e32304f58f89d2a4c00ff9fa15816a1b54af95b54c86da4cd40846afc0e63ddd99bec9fb044873c32 WHIRLPOOL fcfb7e41fe05f5283c6da01fb2b82f8c9b88abe681f72f1df689052d53f3a4ca43acef4d8a9bdd1edcdc20663112b9516e1a02975cbaeffcaa783c42e5ceece8
diff --git a/net-irc/irc-client/files/irc-client-2.10.3_p7-amd64-chost.patch b/net-irc/irc-client/files/irc-client-2.10.3_p7-amd64-chost.patch
new file mode 100644
index 000000000000..7761a3e5e76d
--- /dev/null
+++ b/net-irc/irc-client/files/irc-client-2.10.3_p7-amd64-chost.patch
@@ -0,0 +1,29 @@
+From: Nathan Phillip Brink <binki@gentoo.org>
+Subject: Do not ignore the --host argument passed to the fake ./configure.
+
+--- a/configure
++++ b/configure
+@@ -10,6 +10,7 @@
+ -version | --version | --versio | --versi | --vers)
+ quick_fwd=yes
+ break ;;
++ --host=*)
++ rev=$(expr "${arg}" : '[^=]*=\(.*\)')
++ ;;
+- *)
+- break ;;
+ esac
+@@ -18,8 +21,10 @@
+ then
+ support/configure $*
+ else
+- echo "retrieving the system name, type and OS release..."
+- rev=`support/config.guess`
++ if ! test "${rev}"; then
++ echo "retrieving the system name, type and OS release..."
++ rev=`support/config.guess`
++ fi
+ if test "${rev}" # test for no output
+ then
+ echo " your system seems to be ${rev}."
+
diff --git a/net-irc/irc-client/irc-client-2.10.3_p7.ebuild b/net-irc/irc-client/irc-client-2.10.3_p7.ebuild
new file mode 100644
index 000000000000..7a3043fdd8a8
--- /dev/null
+++ b/net-irc/irc-client/irc-client-2.10.3_p7.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+MY_P=irc${PV/_/}
+DESCRIPTION="A simplistic RFC compliant IRC client"
+HOMEPAGE="http://www.irc.org"
+SRC_URI="ftp://ftp.irc.org/irc/server/${MY_P}.tgz"
+LICENSE="GPL-1"
+SLOT="0"
+
+KEYWORDS="~amd64 ppc x86"
+IUSE="ipv6"
+
+DEPEND="sys-libs/ncurses
+ sys-libs/zlib"
+# This and irc-client both install /usr/bin/irc #247987
+RDEPEND="${DEPEND}
+ !net-irc/irc-client"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}" || die
+ epatch "${FILESDIR}"/${P}-amd64-chost.patch
+}
+
+src_compile () {
+ econf \
+ $(use_with ipv6 ip6) \
+ --sysconfdir=/etc/ircd \
+ --localstatedir=/var/run/ircd \
+ || die "econf failed"
+ emake -C ${CHOST} client || die "client build failed"
+}
+
+src_install() {
+ make -C ${CHOST} \
+ prefix=${D}/usr \
+ client_man_dir=${D}/usr/share/man/man1 \
+ install-client || die "client installed failed"
+ dodoc doc/Etiquette doc/alt-irc-faq doc/rfc* || die
+}
diff --git a/net-irc/irc-client/metadata.xml b/net-irc/irc-client/metadata.xml
new file mode 100644
index 000000000000..6ef15e900f17
--- /dev/null
+++ b/net-irc/irc-client/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>net-irc</herd>
+</pkgmetadata>