summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-irc/muh
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-irc/muh')
-rw-r--r--net-irc/muh/Manifest1
-rw-r--r--net-irc/muh/metadata.xml11
-rw-r--r--net-irc/muh/muh-2.2a.ebuild33
3 files changed, 45 insertions, 0 deletions
diff --git a/net-irc/muh/Manifest b/net-irc/muh/Manifest
new file mode 100644
index 000000000000..2d82e9f70be7
--- /dev/null
+++ b/net-irc/muh/Manifest
@@ -0,0 +1 @@
+DIST muh-2.2a.tar.gz 130672 SHA256 d5743f18edd3dbf044a7844f32ff5dbfcda696141a7d26d182bd4394b6823680 SHA512 2e3ba080f420cf063627d4d9b1f4001c76575efb1d3e99ff9c5eee4a483d5beda6e326f0c0d60c3d848b78cac092aac51a98cabc351760ccfa38fe1549c4b4ee WHIRLPOOL dec6f1079ccebca6ee3d3265ceb75f3bfda25d1dda53e811544ff79281568d3bc758f3aca713d8520624c3340693fbacd0bc69e034c2b27eb49d406141f7870e
diff --git a/net-irc/muh/metadata.xml b/net-irc/muh/metadata.xml
new file mode 100644
index 000000000000..f0844b37b1d9
--- /dev/null
+++ b/net-irc/muh/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-irc</herd>
+ <longdescription>
+ Persistent IRC bouncer.
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">muh</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-irc/muh/muh-2.2a.ebuild b/net-irc/muh/muh-2.2a.ebuild
new file mode 100644
index 000000000000..e0c2ffaedd72
--- /dev/null
+++ b/net-irc/muh/muh-2.2a.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DESCRIPTION="Persistent IRC bouncer"
+HOMEPAGE="http://mind.riot.org/muh/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha ~amd64 ~hppa ~mips ppc ~sparc x86"
+IUSE="ipv6"
+
+DEPEND=""
+
+src_compile() {
+ econf --datadir=/usr/share/muh $(use_enable ipv6) || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog TODO
+}
+
+pkg_postinst() {
+ elog
+ elog "You'll need to configure muh before running it."
+ elog "Put your config in ~/.muh/muhrc"
+ elog "A sample config is /usr/share/muh/muhrc"
+ elog "For more information, see the documentation."
+ elog
+}