summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-irc/srvx
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-irc/srvx')
-rw-r--r--net-irc/srvx/Manifest1
-rw-r--r--net-irc/srvx/files/srvx.conf.d7
-rw-r--r--net-irc/srvx/files/srvx.init.d21
-rw-r--r--net-irc/srvx/metadata.xml11
-rw-r--r--net-irc/srvx/srvx-1.3.1.ebuild67
5 files changed, 107 insertions, 0 deletions
diff --git a/net-irc/srvx/Manifest b/net-irc/srvx/Manifest
new file mode 100644
index 000000000000..d7e19eb6cc99
--- /dev/null
+++ b/net-irc/srvx/Manifest
@@ -0,0 +1 @@
+DIST srvx-1.3.1.tar.bz2 560658 SHA256 e11347a58505f0274a54ca8f956ad21d9e5557ecfcd86f71a58be2fbc2a81d63 SHA512 6f0c4c3af48dea5bc51f673b66a8a72b9f54c2d0c40f5b00e77da0b1b48174ca671a473cd86a3aea4d3c5cb766995d5b892cc5748c47766d53414778403beb65 WHIRLPOOL f4e2f622f3bb20aee41af5b5826c5c5585be60c0ea7c1813f18e1126fa5e5f226190d8eb4411143d78795d0676dadbb7481a5267f2a1652821881be6e7f42527
diff --git a/net-irc/srvx/files/srvx.conf.d b/net-irc/srvx/files/srvx.conf.d
new file mode 100644
index 000000000000..1f5cfdc265f8
--- /dev/null
+++ b/net-irc/srvx/files/srvx.conf.d
@@ -0,0 +1,7 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# user and group to run srvx as
+SRVX_USER="srvx"
+SRVX_GROUP="srvx"
diff --git a/net-irc/srvx/files/srvx.init.d b/net-irc/srvx/files/srvx.init.d
new file mode 100644
index 000000000000..e9ae6717b25e
--- /dev/null
+++ b/net-irc/srvx/files/srvx.init.d
@@ -0,0 +1,21 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+depend() {
+ use dns net
+}
+
+start() {
+ ebegin "Starting srvx"
+ start-stop-daemon --start --chdir /var/lib/srvx --quiet \
+ --exec /usr/bin/srvx --chuid ${SRVX_USER}:${SRVX_GROUP} &>/dev/null
+ eend $?
+}
+
+stop() {
+ ebegin "Shutting down srvx"
+ start-stop-daemon --stop --quiet --pidfile /var/lib/srvx/srvx.pid
+ eend $?
+}
diff --git a/net-irc/srvx/metadata.xml b/net-irc/srvx/metadata.xml
new file mode 100644
index 000000000000..be2f91568548
--- /dev/null
+++ b/net-irc/srvx/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-irc</herd>
+ <use>
+ <flag name="bahamut">Choose bahamut protocol over p10 protocol</flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge">srvx</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-irc/srvx/srvx-1.3.1.ebuild b/net-irc/srvx/srvx-1.3.1.ebuild
new file mode 100644
index 000000000000..32096fa7dfba
--- /dev/null
+++ b/net-irc/srvx/srvx-1.3.1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils user
+
+DESCRIPTION="A complete set of services for IRCu 2.10.10+ and bahamut based networks"
+HOMEPAGE="http://www.srvx.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="bahamut debug"
+
+src_compile() {
+ local PROTOCOL="p10" MALLOC="system" DEBUG=""
+ use bahamut && PROTOCOL="bahamut"
+ use debug && MALLOC="srvx" DEBUG="--enable-debug"
+
+ econf \
+ --with-protocol=${PROTOCOL} \
+ --with-malloc=${MALLOC} \
+ --enable-modules=helpserv,memoserv,sockcheck \
+ ${DEBUG} \
+ || die "econf failed"
+ emake all-recursive || die "emake failed"
+}
+
+src_install() {
+ dobin src/srvx || die "dobin failed"
+ dodir /var/lib/srvx || die "dodir failed"
+
+ insinto /etc/srvx
+ newins srvx.conf.example srvx.conf || die "newins failed"
+ newins sockcheck.conf.example sockcheck.conf || die "newins failed"
+ dosym ../../../etc/srvx/srvx.conf /var/lib/srvx/srvx.conf || die "dosym failed"
+ dosym ../../../etc/srvx/sockcheck.conf /var/lib/srvx/sockcheck.conf || die "dosym failed"
+
+ insinto /usr/share/srvx
+ for helpfile in \
+ chanserv.help global.help mod-helpserv.help mod-memoserv.help \
+ mod-sockcheck.help modcmd.help nickserv.help opserv.help \
+ saxdb.help sendmail.help
+ do
+ doins "src/${helpfile}" || die "doins failed"
+ dosym "../../../usr/share/srvx/${helpfile}" "/var/lib/srvx/${helpfile}" || die "dosym failed"
+ done
+
+ dodoc \
+ AUTHORS INSTALL NEWS README TODO UPGRADE \
+ {sockcheck,srvx}.conf.example \
+ || die "dodoc failed"
+
+ newinitd "${FILESDIR}"/srvx.init.d srvx || die "newinitd failed"
+ newconfd "${FILESDIR}"/srvx.conf.d srvx || die "newconfd failed"
+}
+
+pkg_setup() {
+ enewgroup srvx
+ enewuser srvx -1 -1 /var/lib/srvx srvx
+}
+
+pkg_postinst() {
+ chown -R srvx:srvx "${ROOT}"/etc/srvx "${ROOT}"/var/lib/srvx
+ chmod 0700 "${ROOT}"/etc/srvx "${ROOT}"/var/lib/srvx
+}