summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2017-09-13 20:30:56 +0100
committerLars Wendler <polynomial-c@gentoo.org>2017-09-13 23:58:54 +0200
commit06322d028bd7345241a05905cb51ede2b19d713c (patch)
tree67f54d8b18d49d4bc49e682a46938d7d07be3195 /net-libs
parentapp-vim/phpdocs: clean up old. (diff)
downloadgentoo-06322d028bd7345241a05905cb51ede2b19d713c.tar.gz
gentoo-06322d028bd7345241a05905cb51ede2b19d713c.tar.bz2
gentoo-06322d028bd7345241a05905cb51ede2b19d713c.zip
net-libs/ntirpc: Version bump to 1.5.3
This release has gone unannounced by upstream as there is no download or even a tag upstream. They seem to be looking towards 1.6 instead. The only clue to the existence of this release is the git submodule found in the nfs-ganesha repository. nfs-ganesha 2.5.2 specifically requires at least 1.5.3, hence the need for this. It is the only revdep that I am aware of and it's not even in the main tree so this shouldn't do any harm. Package-Manager: Portage-2.3.8, Repoman-2.3.2 Closes: https://github.com/gentoo/gentoo/pull/5698
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/ntirpc/Manifest1
-rw-r--r--net-libs/ntirpc/ntirpc-1.5.3.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/net-libs/ntirpc/Manifest b/net-libs/ntirpc/Manifest
index 8c45a22f94f2..6808f23ee54e 100644
--- a/net-libs/ntirpc/Manifest
+++ b/net-libs/ntirpc/Manifest
@@ -1,2 +1,3 @@
DIST ntirpc-1.4.1.tar.gz 446025 SHA256 0e0a8a33f49ae91bccd73cfe7cc0ba33641df3cb9ed589dd5d81140a9d8838d0 SHA512 49a27dbd68b3e292437392acf2c010cc968b4d29b82b6e1a84e6c81a0c3979d3b38338212b391294b543ccd321073a33b16d7231ab68d797ead414d1b919137c WHIRLPOOL 01a287654bacf6a1647bb0847197ea7a427cfe6bdb6c379846ab9ca1dc872173edb8c899fe11511155fcddbafec24e4a6536607d4ce31c0b0476c872c8d41176
DIST ntirpc-1.5.2.tar.gz 433706 SHA256 94751ea3a93c880516fc06d2805399440d92e348b6b78baf35436cda8f7d73d2 SHA512 5bbc48ab5bf2aba7e4c473a6faf586c1aef27a2009bf92082495456c436c707dfdcfc5e16a56c3e31ba3fb68afc3d2d47e8d27ed03be5c0be44e22e24a0cb68e WHIRLPOOL 4e00a07b9d905a1d622fefb3040a3868bf776aaabbdb79406f6569a94f4387716f76f110d21d3bc22693e0cb747d2082e0ba3321ccbfa6146155b295612a3bb6
+DIST ntirpc-1.5.3.tar.gz 434096 SHA256 59a2c9bab3d177112b1db55988cc2eacc1d6f6fc074c0c3a2afc2fc9a740a793 SHA512 bc879e5cb9c16bf76b173f09fac50475ed7616837a625abd433175610cc16399abba2294a8657aadc71d4f45b4b53c97414a77bd52b1f81df3dd990407957363 WHIRLPOOL 5faf60782b782479ffc839c28a51c6a4aa38e9227159ffef2e0470e63aa341b0ac90c85c2def83d4fc2f20b97ca698a357de55528fdd279d1aac17e9b2e02c42
diff --git a/net-libs/ntirpc/ntirpc-1.5.3.ebuild b/net-libs/ntirpc/ntirpc-1.5.3.ebuild
new file mode 100644
index 000000000000..baba07b564de
--- /dev/null
+++ b/net-libs/ntirpc/ntirpc-1.5.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-multilib
+
+COMMIT="fadcbdedb65998925482b26c88964b4213b9e1ac"
+DESCRIPTION="Transport Independent RPC library for nfs-ganesha"
+HOMEPAGE="https://github.com/linuxbox2/ntirpc"
+SRC_URI="${HOMEPAGE}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gssapi rdma"
+
+# Since the GSS option only controls some extra files to be enabled,
+# there's nothing to list in the depend string for it.
+RDEPEND="app-crypt/mit-krb5
+ rdma? ( sys-fabric/librdmacm )"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DUSE_GSS="$(usex gssapi)"
+ -DUSE_PRC_RDMA="$(usex rdma)"
+ )
+ cmake-utils_src_configure
+}