summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2020-10-16 12:57:13 +0200
committerMarek Szuba <marecki@gentoo.org>2020-10-16 12:59:08 +0200
commit4291d4bcd51c78bf03671a9d2e7b7d9d1e5b49a8 (patch)
treea70172b11cccb27dbb649eebe22bd136a557f187 /net-libs
parentnet-libs/xrootd-ceph: remove old (diff)
downloadgentoo-4291d4bcd51c78bf03671a9d2e7b7d9d1e5b49a8.tar.gz
gentoo-4291d4bcd51c78bf03671a9d2e7b7d9d1e5b49a8.tar.bz2
gentoo-4291d4bcd51c78bf03671a9d2e7b7d9d1e5b49a8.zip
net-libs/xrootd: bump to 4.12.5
Bugfix release. Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/xrootd/Manifest1
-rw-r--r--net-libs/xrootd/xrootd-4.12.5.ebuild117
2 files changed, 118 insertions, 0 deletions
diff --git a/net-libs/xrootd/Manifest b/net-libs/xrootd/Manifest
index cd7117a12cf7..92ba6cb9b3ff 100644
--- a/net-libs/xrootd/Manifest
+++ b/net-libs/xrootd/Manifest
@@ -1,2 +1,3 @@
DIST xrootd-4.12.4.tar.gz 2577360 BLAKE2B f2e4413bcbf02dccb1ac7b0ceec8fbc2bb8b1de838cd9753c9d61f76fc2d68e845a41075b63a4afe56b1a434cf89ecf4f4b8571fa9ae866a19e6bcadcc5dcd9b SHA512 8cbc5e5f270f39c48b7c75a15e2721ebb793f13419608834777f39bc0ee7dd8c4fad481367f997172dae5029d9e5e4e9d7870843bd5c9957fa9fe439592c4364
+DIST xrootd-4.12.5.tar.gz 2580794 BLAKE2B 217abb8ad332b3eb0cbe2289f4fa7c31abce7c3122ef8d23f409a3a03b7691f0e8a1939a42c831774e6902bf0f3242a2583bbf010478a66f5a2e634008799c5b SHA512 c252866ccdc4465c9ffe3f5cb4bb83a2a70e775db5ff3a55bcd8ac70c72d280ea41fb31501f30550d8ac61b6d474ce602e0ee8a02485f1f2722617aeb25aff0d
DIST xrootd-5.0.2.tar.gz 2764503 BLAKE2B 35bc642d3601738135ff24a77f9bc8795568553856284ebe80d90315039d04109353d2e00310f8b8168f6b1176ee295c9116a7e6adaff33ca23383da9deecf17 SHA512 e58b5484c0fa9f83643e252eb8228f2061130b4f97964283a6adb8a81560841f3d44814572136023d944be6bdd97cff551e75bbfb04e6c9aafaa779ecb051255
diff --git a/net-libs/xrootd/xrootd-4.12.5.ebuild b/net-libs/xrootd/xrootd-4.12.5.ebuild
new file mode 100644
index 000000000000..105a4611edcc
--- /dev/null
+++ b/net-libs/xrootd/xrootd-4.12.5.ebuild
@@ -0,0 +1,117 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit cmake-utils python-single-r1
+
+DESCRIPTION="Extended ROOT remote file server"
+HOMEPAGE="http://xrootd.org/"
+SRC_URI="http://xrootd.org/download/v${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples fuse http kerberos python readline ssl test"
+RESTRICT="!test? ( test )"
+
+CDEPEND="acct-group/xrootd
+ acct-user/xrootd
+ sys-libs/zlib
+ fuse? ( sys-fs/fuse:= )
+ kerberos? ( virtual/krb5 )
+ python? ( ${PYTHON_DEPS} )
+ readline? ( sys-libs/readline:0= )
+ ssl? ( dev-libs/openssl:0= )
+"
+DEPEND="${CDEPEND}"
+BDEPEND="
+ doc? (
+ app-doc/doxygen[dot]
+ python? ( dev-python/sphinx )
+ )
+ test? ( dev-util/cppunit )
+"
+RDEPEND="${CDEPEND}
+ dev-lang/perl
+"
+REQUIRED_USE="
+ http? ( kerberos ssl )
+ python? ( ${PYTHON_REQUIRED_USE} )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.8.3-crc32.patch
+ "${FILESDIR}"/${PN}-4.12.4-http_secret_leakage.patch
+)
+
+# xrootd plugins are not intended to be linked with,
+# they are to be loaded at runtime by xrootd,
+# see https://github.com/xrootd/xrootd/issues/447
+QA_SONAME="/usr/lib.*/libXrd.*-$(ver_cut 1).so
+ /usr/lib.*/libXrdClTests\.so"
+
+pkg_setup() {
+ use python && python_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_CRYPTO=$(usex ssl)
+ -DENABLE_FUSE=$(usex fuse)
+ -DENABLE_HTTP=$(usex http)
+ -DENABLE_KRB5=$(usex kerberos)
+ -DENABLE_PYTHON=$(usex python)
+ -DENABLE_READLINE=$(usex readline)
+ -DENABLE_TESTS=$(usex test)
+ )
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+ if use doc; then
+ doxygen Doxyfile || die
+ if use python; then
+ emake -C bindings/python/docs html
+ fi
+ fi
+}
+
+src_install() {
+ use doc && HTML_DOCS=( doxydoc/html/. )
+ dodoc docs/ReleaseNotes.txt
+ cmake-utils_src_install
+ find "${D}" \( -iname '*.md5' -o -iname '*.map' \) -delete || die
+
+ # base configs
+ insinto /etc/xrootd
+ doins packaging/common/*.cfg
+
+ fowners root:xrootd /etc/xrootd
+ keepdir /var/log/xrootd
+ fowners xrootd:xrootd /var/log/xrootd
+
+ local i
+ for i in cmsd frm_purged frm_xfrd xrootd; do
+ newinitd "${FILESDIR}"/${i}.initd ${i}
+ done
+ # all daemons MUST use single master config file
+ newconfd "${FILESDIR}"/xrootd.confd xrootd
+
+ if use python; then
+ python_optimize "${D}/$(python_get_sitedir)"
+
+ if use doc; then
+ docinto python
+ docompress -x "/usr/share/doc/${PF}/python/html"
+ dodoc -r bindings/python/docs/build/html
+ fi
+ if use examples; then
+ docinto python
+ dodoc -r bindings/python/examples
+ fi
+ fi
+}