summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2020-05-09 22:16:08 +0300
committerMart Raudsepp <leio@gentoo.org>2020-05-09 23:39:33 +0300
commitcad04281bde21306bed8efe2fb68e6cc955bdab4 (patch)
tree0903bbc40fb3eb4b30fb6c95edd1d83083b7d237 /net-libs
parentmedia-libs/freetype: Removed old (diff)
downloadgentoo-cad04281bde21306bed8efe2fb68e6cc955bdab4.tar.gz
gentoo-cad04281bde21306bed8efe2fb68e6cc955bdab4.tar.bz2
gentoo-cad04281bde21306bed8efe2fb68e6cc955bdab4.zip
net-libs/webkit-gtk: bump to 2.28.2, fix various build issues
Fix build issue when ccache is found. Try to fix various opengl without X build issues. USE="gstreamer X" requires gst-plugins-base[X]. Includes a few patches that have been marked as 2.28.3 candidates by upstream. Closes: https://bugs.gentoo.org/717888 Bug: https://bugs.gentoo.org/712260 Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/webkit-gtk/Manifest1
-rw-r--r--net-libs/webkit-gtk/files/2.28.2-fix-ppc64-JSC.patch59
-rw-r--r--net-libs/webkit-gtk/files/2.28.2-fix-yelp-desktopless-build.patch53
-rw-r--r--net-libs/webkit-gtk/files/2.28.2-opengl-without-X-fixes.patch53
-rw-r--r--net-libs/webkit-gtk/files/2.28.2-use-gst-audiointerleave.patch55
-rw-r--r--net-libs/webkit-gtk/webkit-gtk-2.28.2.ebuild291
6 files changed, 512 insertions, 0 deletions
diff --git a/net-libs/webkit-gtk/Manifest b/net-libs/webkit-gtk/Manifest
index ba34c0352717..ec39ddf8a529 100644
--- a/net-libs/webkit-gtk/Manifest
+++ b/net-libs/webkit-gtk/Manifest
@@ -1,3 +1,4 @@
DIST webkitgtk-2.24.4.tar.xz 17575784 BLAKE2B c30683ea365a50d7def572305b49278343d67739f9bd3cfd78cb08b5cc87b5453504df9b09752f8d6483b18b9b812f3d3cddc084762cfa8990fcc651660b89c2 SHA512 1d713955a735ae2e2229beea7bda7f518a6247c6aa7f5753aeb5b5c6395339d451d0d146f7188e7ba65cb82ea5a74a5e73e956fe59d5f5f97659a44af33df112
DIST webkitgtk-2.26.4.tar.xz 19329636 BLAKE2B 9dc88bf9e2bec4f3ccc316f4967e991595fa17151ad74781ea514e72700f2bd1f3ed32c5ee662eb1d04fa023e7c33ad1215078415b67c939ee0d4f6d55358d4a SHA512 b4d96672d0a41fb7591dd312254fc1b7a85e632923bf2d954d79d395306db96d5a6b4f85e24ea4ba0a447e45e29a41882249c26f6b2d6d572225abefcf28a474
DIST webkitgtk-2.28.1.tar.xz 21427628 BLAKE2B 58f19d68598ed1aee58f9f700c84e76c9c58980e39d7fe1883c3be991f575074db3156b9a7a041bb3d59130d87d37b1bdee9cf6c122c4f0b0ba6637d66534c32 SHA512 30cfe63d202673d1f0b0ab32e062eab225e51b993d9bb0f51c02d0497423e1591b5a2e943c30d1c9ee6d9073dfbd13b8ec24bca94f380fe8886019e8185628b8
+DIST webkitgtk-2.28.2.tar.xz 21427772 BLAKE2B 0749ffac526ae90ffb8af3fbf8f9ce87db80f229b96e2daa435f9bd6e6e985bbb8c33011976213b2e4ce286c9f1d38f0b85279507cdc9c52b95fbeb32c9f676c SHA512 c7c0c55b1ebc61c0ec9cd9af96a12058a96ba9b011330b12c7c2776685736e0edf604f5eee639637cb50b2967d77c2db4dea15050a575fd34a1f6f0a8b8c56f8
diff --git a/net-libs/webkit-gtk/files/2.28.2-fix-ppc64-JSC.patch b/net-libs/webkit-gtk/files/2.28.2-fix-ppc64-JSC.patch
new file mode 100644
index 000000000000..96e4d7d0aa2c
--- /dev/null
+++ b/net-libs/webkit-gtk/files/2.28.2-fix-ppc64-JSC.patch
@@ -0,0 +1,59 @@
+From 46c7d3ea88dd77223f25c48ce4a8688db71c489b Mon Sep 17 00:00:00 2001
+From: "commit-queue@webkit.org"
+ <commit-queue@webkit.org@268f45cc-cd09-0410-ab3c-d52691b4dbfc>
+Date: Thu, 7 May 2020 19:30:28 +0000
+Subject: [PATCH] REGRESSION(r251875): Crash in JSC::StructureIDTable::get on
+ ppc64le: gcSafeMemcpy broken on JSVALUE64 platforms other than x86_64 and
+ aarch64 https://bugs.webkit.org/show_bug.cgi?id=210685
+
+Patch by Daniel Kolesa <daniel@octaforge.org> on 2020-05-07
+Reviewed by Michael Catanzaro.
+
+Fix gcSafeMemcpy on non-x86_64/aarch64 64-bit architectures.
+
+We were hitting an incorrect x86_64 assertion on values larger than
+mediumCutoff on JSVALUE64 architectures other than x86_64 and aarch64,
+as the control flow is wrong.
+
+* heap/GCMemoryOperations.h:
+(JSC::gcSafeMemcpy):
+
+git-svn-id: https://svn.webkit.org/repository/webkit/trunk@261326 268f45cc-cd09-0410-ab3c-d52691b4dbfc
+---
+ Source/JavaScriptCore/heap/GCMemoryOperations.h | 6 ++----
+ 1 file changed, 2 insertions(+), 4 deletions(-)
+
+diff --git a/Source/JavaScriptCore/heap/GCMemoryOperations.h b/Source/JavaScriptCore/heap/GCMemoryOperations.h
+index f2b9e385bc9..ff66071db20 100644
+--- a/Source/JavaScriptCore/heap/GCMemoryOperations.h
++++ b/Source/JavaScriptCore/heap/GCMemoryOperations.h
+@@ -53,7 +53,7 @@ ALWAYS_INLINE void gcSafeMemcpy(T* dst, T* src, size_t bytes)
+ bitwise_cast<volatile uint64_t*>(dst)[i] = bitwise_cast<volatile uint64_t*>(src)[i];
+ };
+
+-#if COMPILER(GCC_COMPATIBLE) && USE(JSVALUE64)
++#if COMPILER(GCC_COMPATIBLE) && (CPU(X86_64) || CPU(ARM64))
+ if (bytes <= smallCutoff)
+ slowPathForwardMemcpy();
+ else if (isARM64() || bytes <= mediumCutoff) {
+@@ -121,8 +121,6 @@ ALWAYS_INLINE void gcSafeMemcpy(T* dst, T* src, size_t bytes)
+ :
+ : "d0", "d1", "memory"
+ );
+-#else
+- slowPathForwardMemcpy();
+ #endif // CPU(X86_64)
+ } else {
+ RELEASE_ASSERT(isX86_64());
+@@ -139,7 +137,7 @@ ALWAYS_INLINE void gcSafeMemcpy(T* dst, T* src, size_t bytes)
+ }
+ #else
+ slowPathForwardMemcpy();
+-#endif // COMPILER(GCC_COMPATIBLE)
++#endif // COMPILER(GCC_COMPATIBLE) && (CPU(X86_64) || CPU(ARM64))
+ #else
+ memcpy(dst, src, bytes);
+ #endif // USE(JSVALUE64)
+--
+2.20.1
+
diff --git a/net-libs/webkit-gtk/files/2.28.2-fix-yelp-desktopless-build.patch b/net-libs/webkit-gtk/files/2.28.2-fix-yelp-desktopless-build.patch
new file mode 100644
index 000000000000..fdf9d7d4d20b
--- /dev/null
+++ b/net-libs/webkit-gtk/files/2.28.2-fix-yelp-desktopless-build.patch
@@ -0,0 +1,53 @@
+From 9cd4011a12bf658aad3776251792bacdc894643a Mon Sep 17 00:00:00 2001
+From: "berto@igalia.com"
+ <berto@igalia.com@268f45cc-cd09-0410-ab3c-d52691b4dbfc>
+Date: Mon, 27 Apr 2020 11:52:10 +0000
+Subject: [PATCH] [GTK] [2.28.0] The Yelp build crashes if DISPLAY is not set
+ https://bugs.webkit.org/show_bug.cgi?id=209431
+
+Reviewed by Carlos Garcia Campos.
+
+Don't create a PlatformDisplayLibWPE as a fallback when using
+Wayland or X11.
+
+* platform/graphics/PlatformDisplay.cpp:
+(WebCore::PlatformDisplay::createPlatformDisplay):
+
+git-svn-id: https://svn.webkit.org/repository/webkit/trunk@260750 268f45cc-cd09-0410-ab3c-d52691b4dbfc
+---
+ Source/WebCore/platform/graphics/PlatformDisplay.cpp | 12 ++++++------
+ 1 file changed, 6 insertions(+), 6 deletions(-)
+
+diff --git a/Source/WebCore/platform/graphics/PlatformDisplay.cpp b/Source/WebCore/platform/graphics/PlatformDisplay.cpp
+index 8bb47ca2b77..f9547b3af69 100644
+--- a/Source/WebCore/platform/graphics/PlatformDisplay.cpp
++++ b/Source/WebCore/platform/graphics/PlatformDisplay.cpp
+@@ -98,12 +98,6 @@ std::unique_ptr<PlatformDisplay> PlatformDisplay::createPlatformDisplay()
+ }
+ #endif // PLATFORM(GTK)
+
+-#if USE(WPE_RENDERER)
+- return PlatformDisplayLibWPE::create();
+-#elif PLATFORM(WIN)
+- return PlatformDisplayWin::create();
+-#endif
+-
+ #if PLATFORM(WAYLAND)
+ if (auto platformDisplay = PlatformDisplayWayland::create())
+ return platformDisplay;
+@@ -121,6 +115,12 @@ std::unique_ptr<PlatformDisplay> PlatformDisplay::createPlatformDisplay()
+ return PlatformDisplayX11::create(nullptr);
+ #endif
+
++#if USE(WPE_RENDERER)
++ return PlatformDisplayLibWPE::create();
++#elif PLATFORM(WIN)
++ return PlatformDisplayWin::create();
++#endif
++
+ RELEASE_ASSERT_NOT_REACHED();
+ }
+
+--
+2.20.1
+
diff --git a/net-libs/webkit-gtk/files/2.28.2-opengl-without-X-fixes.patch b/net-libs/webkit-gtk/files/2.28.2-opengl-without-X-fixes.patch
new file mode 100644
index 000000000000..6976c3ce4db0
--- /dev/null
+++ b/net-libs/webkit-gtk/files/2.28.2-opengl-without-X-fixes.patch
@@ -0,0 +1,53 @@
+From c67efa2bbe2094b40b4e104bb26497c2aff5ce68 Mon Sep 17 00:00:00 2001
+From: Mart Raudsepp <leio@gentoo.org>
+Date: Sat, 9 May 2020 23:11:52 +0300
+Subject: [PATCH] Clean up OpenGLShims.h conditionals in a few places to fix
+ some build configurations
+
+---
+ Source/WebCore/platform/graphics/GLContext.cpp | 5 ++++-
+ Source/WebKit/UIProcess/API/glib/WebKitProtocolHandler.cpp | 5 ++++-
+ 2 files changed, 8 insertions(+), 2 deletions(-)
+
+diff --git a/Source/WebCore/platform/graphics/GLContext.cpp b/Source/WebCore/platform/graphics/GLContext.cpp
+index b217988b990..1ba0eb8a482 100644
+--- a/Source/WebCore/platform/graphics/GLContext.cpp
++++ b/Source/WebCore/platform/graphics/GLContext.cpp
+@@ -28,6 +28,9 @@
+
+ #if USE(GLX)
+ #include "GLContextGLX.h"
++#endif
++
++#if !USE(OPENGL_ES) && !USE(LIBEPOXY) && !USE(ANGLE)
+ #include "OpenGLShims.h"
+ #endif
+
+@@ -57,7 +60,7 @@ inline ThreadGlobalGLContext* currentContext()
+
+ static bool initializeOpenGLShimsIfNeeded()
+ {
+-#if USE(OPENGL_ES) || USE(LIBEPOXY)
++#if USE(OPENGL_ES) || USE(LIBEPOXY) || USE(ANGLE)
+ return true;
+ #else
+ static bool initialized = false;
+diff --git a/Source/WebKit/UIProcess/API/glib/WebKitProtocolHandler.cpp b/Source/WebKit/UIProcess/API/glib/WebKitProtocolHandler.cpp
+index 3515be452b2..82cce70f14b 100644
+--- a/Source/WebKit/UIProcess/API/glib/WebKitProtocolHandler.cpp
++++ b/Source/WebKit/UIProcess/API/glib/WebKitProtocolHandler.cpp
+@@ -64,7 +64,10 @@
+
+ #if USE(GLX)
+ #include <GL/glx.h>
+-#include <WebCore/OpenGLShims.h>
++#endif
++
++#if !USE(OPENGL_ES) && !USE(LIBEPOXY) && !USE(ANGLE)
++#include "WebCore/OpenGLShims.h"
+ #endif
+
+ #if USE(GSTREAMER)
+--
+2.20.1
+
diff --git a/net-libs/webkit-gtk/files/2.28.2-use-gst-audiointerleave.patch b/net-libs/webkit-gtk/files/2.28.2-use-gst-audiointerleave.patch
new file mode 100644
index 000000000000..f4bc7291a809
--- /dev/null
+++ b/net-libs/webkit-gtk/files/2.28.2-use-gst-audiointerleave.patch
@@ -0,0 +1,55 @@
+From 43686247013a1230d47b46d637f928eb47c99609 Mon Sep 17 00:00:00 2001
+From: "commit-queue@webkit.org"
+ <commit-queue@webkit.org@268f45cc-cd09-0410-ab3c-d52691b4dbfc>
+Date: Wed, 29 Apr 2020 08:14:06 +0000
+Subject: [PATCH] [GStreamer] Switch to audiointerleave
+ https://bugs.webkit.org/show_bug.cgi?id=211124
+
+Patch by Philippe Normand <pnormand@igalia.com> on 2020-04-29
+Reviewed by Xabier Rodriguez-Calvar.
+
+The audiointerleave element is a drop-in replacement of
+interleave. It should behave a bit better in live.
+
+No new tests, existing webaudio tests cover this change.
+
+* platform/audio/gstreamer/WebKitWebAudioSourceGStreamer.cpp:
+(webKitWebAudioSrcConstructed):
+(webKitWebAudioSrcChangeState):
+
+git-svn-id: https://svn.webkit.org/repository/webkit/trunk@260886 268f45cc-cd09-0410-ab3c-d52691b4dbfc
+---
+ .../audio/gstreamer/WebKitWebAudioSourceGStreamer.cpp | 8 ++++----
+ 1 file changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/Source/WebCore/platform/audio/gstreamer/WebKitWebAudioSourceGStreamer.cpp b/Source/WebCore/platform/audio/gstreamer/WebKitWebAudioSourceGStreamer.cpp
+index 2f937f677cc..ea134b7b1b2 100644
+--- a/Source/WebCore/platform/audio/gstreamer/WebKitWebAudioSourceGStreamer.cpp
++++ b/Source/WebCore/platform/audio/gstreamer/WebKitWebAudioSourceGStreamer.cpp
+@@ -211,10 +211,10 @@ static void webKitWebAudioSrcConstructed(GObject* object)
+ ASSERT(priv->provider);
+ ASSERT(priv->sampleRate);
+
+- priv->interleave = gst_element_factory_make("interleave", nullptr);
++ priv->interleave = gst_element_factory_make("audiointerleave", nullptr);
+
+ if (!priv->interleave) {
+- GST_ERROR_OBJECT(src, "Failed to create interleave");
++ GST_ERROR_OBJECT(src, "Failed to create audiointerleave");
+ return;
+ }
+
+@@ -398,8 +398,8 @@ static GstStateChangeReturn webKitWebAudioSrcChangeState(GstElement* element, Gs
+ switch (transition) {
+ case GST_STATE_CHANGE_NULL_TO_READY:
+ if (!src->priv->interleave) {
+- gst_element_post_message(element, gst_missing_element_message_new(element, "interleave"));
+- GST_ELEMENT_ERROR(src, CORE, MISSING_PLUGIN, (nullptr), ("no interleave"));
++ gst_element_post_message(element, gst_missing_element_message_new(element, "audiointerleave"));
++ GST_ELEMENT_ERROR(src, CORE, MISSING_PLUGIN, (nullptr), ("no audiointerleave"));
+ return GST_STATE_CHANGE_FAILURE;
+ }
+ src->priv->numberOfSamples = 0;
+--
+2.20.1
+
diff --git a/net-libs/webkit-gtk/webkit-gtk-2.28.2.ebuild b/net-libs/webkit-gtk/webkit-gtk-2.28.2.ebuild
new file mode 100644
index 000000000000..2d5533bf9537
--- /dev/null
+++ b/net-libs/webkit-gtk/webkit-gtk-2.28.2.ebuild
@@ -0,0 +1,291 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+CMAKE_MAKEFILE_GENERATOR="ninja"
+PYTHON_COMPAT=( python{3_6,3_7} )
+USE_RUBY="ruby24 ruby25 ruby26 ruby27"
+CMAKE_MIN_VERSION=3.10
+
+inherit check-reqs cmake-utils flag-o-matic gnome2 pax-utils python-any-r1 ruby-single toolchain-funcs virtualx
+
+MY_P="webkitgtk-${PV}"
+DESCRIPTION="Open source web browser engine"
+HOMEPAGE="https://www.webkitgtk.org"
+SRC_URI="https://www.webkitgtk.org/releases/${MY_P}.tar.xz"
+
+LICENSE="LGPL-2+ BSD"
+SLOT="4/37" # soname version of libwebkit2gtk-4.0
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~sparc ~x86"
+
+IUSE="aqua +egl +geolocation gles2-only gnome-keyring +gstreamer gtk-doc +introspection +jpeg2k +jumbo-build libnotify +opengl seccomp spell wayland +X"
+
+# gstreamer with opengl/gles2 needs egl
+REQUIRED_USE="
+ gles2-only? ( egl !opengl )
+ gstreamer? ( opengl? ( egl ) )
+ wayland? ( egl )
+ || ( aqua wayland X )
+"
+
+# Tests fail to link for inexplicable reasons
+# https://bugs.webkit.org/show_bug.cgi?id=148210
+RESTRICT="test"
+
+# Aqua support in gtk3 is untested
+# Dependencies found at Source/cmake/OptionsGTK.cmake
+# Various compile-time optionals for gtk+-3.22.0 - ensure it
+# Missing WebRTC support, but ENABLE_MEDIA_STREAM/ENABLE_WEB_RTC is experimental upstream (PRIVATE OFF) and shouldn't be used yet in 2.26
+# >=gst-plugins-opus-1.14.4-r1 for opusparse (required by MSE)
+wpe_depend="
+ >=gui-libs/libwpe-1.3.0:1.0
+ >=gui-libs/wpebackend-fdo-1.3.1:1.0
+"
+RDEPEND="
+ >=x11-libs/cairo-1.16.0:=[X?]
+ >=media-libs/fontconfig-2.13.0:1.0
+ >=media-libs/freetype-2.9.0:2
+ >=dev-libs/libgcrypt-1.7.0:0=
+ >=x11-libs/gtk+-3.22.0:3[aqua?,introspection?,wayland?,X?]
+ >=media-libs/harfbuzz-1.4.2:=[icu(+)]
+ >=dev-libs/icu-3.8.1-r1:=
+ virtual/jpeg:0=
+ >=net-libs/libsoup-2.54:2.4[introspection?]
+ >=dev-libs/libxml2-2.8.0:2
+ >=media-libs/libpng-1.4:0=
+ dev-db/sqlite:3=
+ sys-libs/zlib:0
+ >=dev-libs/atk-2.16.0
+ media-libs/libwebp:=
+
+ >=dev-libs/glib-2.44.0:2
+ >=dev-libs/libxslt-1.1.7
+ media-libs/woff2
+ gnome-keyring? ( app-crypt/libsecret )
+ introspection? ( >=dev-libs/gobject-introspection-1.32.0:= )
+ dev-libs/libtasn1:=
+ spell? ( >=app-text/enchant-0.22:2 )
+ gstreamer? (
+ >=media-libs/gstreamer-1.14:1.0
+ >=media-libs/gst-plugins-base-1.14:1.0[egl?,opengl?,X?]
+ gles2-only? ( media-libs/gst-plugins-base:1.0[gles2] )
+ >=media-plugins/gst-plugins-opus-1.14.4-r1:1.0
+ >=media-libs/gst-plugins-bad-1.14:1.0 )
+
+ X? (
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXrender
+ x11-libs/libXt )
+
+ libnotify? ( x11-libs/libnotify )
+ dev-libs/hyphen
+ jpeg2k? ( >=media-libs/openjpeg-2.2.0:2= )
+
+ egl? ( media-libs/mesa[egl] )
+ gles2-only? ( media-libs/mesa[gles2] )
+ opengl? ( virtual/opengl )
+ wayland? (
+ dev-libs/wayland
+ >=dev-libs/wayland-protocols-1.12
+ opengl? ( ${wpe_depend} )
+ gles2-only? ( ${wpe_depend} )
+ )
+
+ seccomp? (
+ >=sys-apps/bubblewrap-0.3.1
+ sys-libs/libseccomp
+ sys-apps/xdg-dbus-proxy
+ )
+"
+unset wpe_depend
+# paxctl needed for bug #407085
+# Need real bison, not yacc
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ ${RUBY_DEPS}
+ >=app-accessibility/at-spi2-core-2.5.3
+ dev-util/glib-utils
+ >=dev-util/gperf-3.0.1
+ >=sys-devel/bison-2.4.3
+ || ( >=sys-devel/gcc-7.3 >=sys-devel/clang-5 )
+ sys-devel/gettext
+ virtual/pkgconfig
+
+ >=dev-lang/perl-5.10
+ virtual/perl-Data-Dumper
+ virtual/perl-Carp
+ virtual/perl-JSON-PP
+
+ gtk-doc? ( >=dev-util/gtk-doc-1.10 )
+ geolocation? ( dev-util/gdbus-codegen )
+"
+# test? (
+# dev-python/pygobject:3[python_targets_python2_7]
+# x11-themes/hicolor-icon-theme
+# jit? ( sys-apps/paxctl ) )
+RDEPEND="${RDEPEND}
+ geolocation? ( >=app-misc/geoclue-2.1.5:2.0 )
+"
+
+S="${WORKDIR}/${MY_P}"
+
+CHECKREQS_DISK_BUILD="18G" # and even this might not be enough, bug #417307
+
+pkg_pretend() {
+ if [[ ${MERGE_TYPE} != "binary" ]] ; then
+ if is-flagq "-g*" && ! is-flagq "-g*0" ; then
+ einfo "Checking for sufficient disk space to build ${PN} with debugging CFLAGS"
+ check-reqs_pkg_pretend
+ fi
+
+ if ! test-flag-CXX -std=c++17 ; then
+ die "You need at least GCC 7.3.x or Clang >= 5 for C++17-specific compiler flags"
+ fi
+ fi
+
+ if ! use opengl && ! use gles2-only; then
+ ewarn
+ ewarn "You are disabling OpenGL usage (USE=opengl or USE=gles2-only) completely."
+ ewarn "This is an unsupported configuration meant for very specific embedded"
+ ewarn "use cases, where there truly is no GL possible (and even that use case"
+ ewarn "is very unlikely to come by). If you have GL (even software-only), you"
+ ewarn "really really should be enabling OpenGL!"
+ ewarn
+ fi
+}
+
+pkg_setup() {
+ if [[ ${MERGE_TYPE} != "binary" ]] && is-flagq "-g*" && ! is-flagq "-g*0" ; then
+ check-reqs_pkg_setup
+ fi
+
+ python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ eapply "${FILESDIR}/${PN}-2.24.4-eglmesaext-include.patch" # bug 699054 # https://bugs.webkit.org/show_bug.cgi?id=204108
+ eapply "${FILESDIR}"/2.26.3-fix-gtk-doc.patch # bug 704550 - retest without it once we can depend on >=gtk-doc-1.32
+ eapply "${FILESDIR}"/${PV}-fix-yelp-desktopless-build.patch
+ eapply "${FILESDIR}"/${PV}-use-gst-audiointerleave.patch
+ eapply "${FILESDIR}"/${PV}-fix-ppc64-JSC.patch
+ eapply "${FILESDIR}"/${PV}-opengl-without-X-fixes.patch
+ cmake-utils_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ # Respect CC, otherwise fails on prefix #395875
+ tc-export CC
+
+ # It does not compile on alpha without this in LDFLAGS
+ # https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=648761
+ use alpha && append-ldflags "-Wl,--no-relax"
+
+ # ld segfaults on ia64 with LDFLAGS --as-needed, bug #555504
+ use ia64 && append-ldflags "-Wl,--no-as-needed"
+
+ # Sigbuses on SPARC with mcpu and co., bug #???
+ use sparc && filter-flags "-mvis"
+
+ # https://bugs.webkit.org/show_bug.cgi?id=42070 , #301634
+ use ppc64 && append-flags "-mminimal-toc"
+
+ # Try to use less memory, bug #469942 (see Fedora .spec for reference)
+ # --no-keep-memory doesn't work on ia64, bug #502492
+ if ! use ia64; then
+ append-ldflags "-Wl,--no-keep-memory"
+ fi
+
+ # We try to use gold when possible for this package
+# if ! tc-ld-is-gold ; then
+# append-ldflags "-Wl,--reduce-memory-overheads"
+# fi
+
+ # Ruby situation is a bit complicated. See bug 513888
+ local rubyimpl
+ local ruby_interpreter=""
+ for rubyimpl in ${USE_RUBY}; do
+ if has_version --host-root "virtual/rubygems[ruby_targets_${rubyimpl}]"; then
+ ruby_interpreter="-DRUBY_EXECUTABLE=$(type -P ${rubyimpl})"
+ fi
+ done
+ # This will rarely occur. Only a couple of corner cases could lead us to
+ # that failure. See bug 513888
+ [[ -z $ruby_interpreter ]] && die "No suitable ruby interpreter found"
+
+ # TODO: Check Web Audio support
+ # should somehow let user select between them?
+ #
+ # opengl needs to be explicetly handled, bug #576634
+
+ local use_wpe_renderer=OFF
+ local opengl_enabled
+ if use opengl || use gles2-only; then
+ opengl_enabled=ON
+ use wayland && use_wpe_renderer=ON
+ else
+ opengl_enabled=OFF
+ fi
+
+ local mycmakeargs=(
+ -DENABLE_UNIFIED_BUILDS=$(usex jumbo-build)
+ -DENABLE_QUARTZ_TARGET=$(usex aqua)
+ -DENABLE_API_TESTS=$(usex test)
+ -DENABLE_GTKDOC=$(usex gtk-doc)
+ -DENABLE_GEOLOCATION=$(usex geolocation) # Runtime optional (talks over dbus service)
+ $(cmake-utils_use_find_package gles2-only OpenGLES2)
+ -DENABLE_GLES2=$(usex gles2-only)
+ -DENABLE_VIDEO=$(usex gstreamer)
+ -DENABLE_WEB_AUDIO=$(usex gstreamer)
+ -DENABLE_INTROSPECTION=$(usex introspection)
+ -DUSE_LIBNOTIFY=$(usex libnotify)
+ -DUSE_LIBSECRET=$(usex gnome-keyring)
+ -DUSE_OPENJPEG=$(usex jpeg2k)
+ -DUSE_WOFF2=ON
+ -DENABLE_SPELLCHECK=$(usex spell)
+ -DENABLE_WAYLAND_TARGET=$(usex wayland)
+ -DUSE_WPE_RENDERER=${use_wpe_renderer} # WPE renderer is used to implement accelerated compositing under wayland
+ $(cmake-utils_use_find_package egl EGL)
+ $(cmake-utils_use_find_package opengl OpenGL)
+ -DENABLE_X11_TARGET=$(usex X)
+ -DENABLE_OPENGL=${opengl_enabled}
+ -DENABLE_WEBGL=${opengl_enabled}
+ -DENABLE_BUBBLEWRAP_SANDBOX=$(usex seccomp)
+ -DBWRAP_EXECUTABLE="${EPREFIX}"/usr/bin/bwrap # If bubblewrap[suid] then portage makes it go-r and cmake find_program fails with that
+ -DCMAKE_BUILD_TYPE=Release
+ -DPORT=GTK
+ ${ruby_interpreter}
+ )
+
+ # Allow it to use GOLD when possible as it has all the magic to
+ # detect when to use it and using gold for this concrete package has
+ # multiple advantages and is also the upstream default, bug #585788
+# if tc-ld-is-gold ; then
+# mycmakeargs+=( -DUSE_LD_GOLD=ON )
+# else
+# mycmakeargs+=( -DUSE_LD_GOLD=OFF )
+# fi
+
+ WK_USE_CCACHE=NO cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+}
+
+src_test() {
+ # Prevents test failures on PaX systems
+ pax-mark m $(list-paxables Programs/*[Tt]ests/*) # Programs/unittests/.libs/test*
+
+ cmake-utils_src_test
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ # Prevents crashes on PaX systems, bug #522808
+ pax-mark m "${ED}usr/libexec/webkit2gtk-4.0/jsc" "${ED}usr/libexec/webkit2gtk-4.0/WebKitWebProcess"
+ pax-mark m "${ED}usr/libexec/webkit2gtk-4.0/WebKitPluginProcess"
+}