summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2017-09-09 23:01:07 +1000
committerMichael Palimaka <kensington@gentoo.org>2017-09-09 23:08:35 +1000
commitcf24b5b97b76b5dcfe778064017910995466796b (patch)
tree0dab77bc729bd31a91fd990a8d335d41abd48260 /net-libs
parentnet-im/qutim: Fix manifest (diff)
downloadgentoo-cf24b5b97b76b5dcfe778064017910995466796b.tar.gz
gentoo-cf24b5b97b76b5dcfe778064017910995466796b.tar.bz2
gentoo-cf24b5b97b76b5dcfe778064017910995466796b.zip
net-libs/libaccounts-glib: version bump 1.23
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libaccounts-glib/Manifest1
-rw-r--r--net-libs/libaccounts-glib/libaccounts-glib-1.23.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/net-libs/libaccounts-glib/Manifest b/net-libs/libaccounts-glib/Manifest
index 4a7209e64ed3..4ecd427bd886 100644
--- a/net-libs/libaccounts-glib/Manifest
+++ b/net-libs/libaccounts-glib/Manifest
@@ -1 +1,2 @@
DIST libaccounts-glib-1.21.tar.gz 127061 SHA256 27cb75f3f2f0ce736b77f0fd0432f8d565297f0735846a2862577eadaec92488 SHA512 3eef882597392387a962dddbc49e4428f7e11e329fac1c3f4d39f3ef315118274b253e36095754d6392802cf298f2bfc0adf30b9a114b047082cda231bb10f60 WHIRLPOOL 46f8f04958199b4b1b91f1b03b66772e1a46440f390c30fef43c09f1171af28d41f57fb92d1303263d1771d21ff9e035729ff2396637894dd811dc0fd314f059
+DIST libaccounts-glib-1.23.tar.gz 127931 SHA256 b4686af19b86cbedc0eb6a00aceee70f2c61254013d2cadd8aba15e9c540fff7 SHA512 88fec1fed7a135375516363e4b7f1330d45a6337bbfb45dd35dabce87097ee4e550e968870541e1b496c2ee3db1bd26e0665f4155f1e64d1cc7b6b74d5b71b5c WHIRLPOOL 90d200bec667dd1bd7666d040a432494e1ce703e54ba38ceecd1850059991c3927c638228b9287e19e9d5971fbe4d8197470934c1a6542f729d0fc450b7e0377
diff --git a/net-libs/libaccounts-glib/libaccounts-glib-1.23.ebuild b/net-libs/libaccounts-glib/libaccounts-glib-1.23.ebuild
new file mode 100644
index 000000000000..928af3370a31
--- /dev/null
+++ b/net-libs/libaccounts-glib/libaccounts-glib-1.23.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools eutils vcs-snapshot xdg-utils
+
+DESCRIPTION="Accounts SSO (Single Sign-On) management library for GLib applications"
+HOMEPAGE="https://01.org/gsso/"
+SRC_URI="https://gitlab.com/accounts-sso/libaccounts-glib/repository/archive.tar.gz?ref=VERSION_${PV} -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="debug"
+
+RDEPEND="
+ dev-db/sqlite:3
+ dev-libs/glib:2
+ dev-libs/libxml2
+"
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc
+"
+
+DOCS=( AUTHORS NEWS )
+
+pkg_setup() {
+ xdg_environment_reset
+}
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-python \
+ --disable-tests \
+ $(use_enable debug)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}