summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2020-05-08 23:00:22 +0200
committerMarek Szuba <marecki@gentoo.org>2020-05-08 23:03:55 +0200
commitfcf660f89dc8bb14d39e8b1d601f41dcbfdb1ada (patch)
treec93f463d73f5663d25669b55b4cd314a9d7f869a /net-libs
parentnet-libs/xrootd: remove old (diff)
downloadgentoo-fcf660f89dc8bb14d39e8b1d601f41dcbfdb1ada.tar.gz
gentoo-fcf660f89dc8bb14d39e8b1d601f41dcbfdb1ada.tar.bz2
gentoo-fcf660f89dc8bb14d39e8b1d601f41dcbfdb1ada.zip
net-libs/xrootd-ceph: not-quite-new package
This used to be part of net-libs/xrootd but got split into a separate upstream package before version 4.10.0. Seeing as the code in question has been in the tree before (still is in fact, we've still got 4.8.4), let this package directly inherit the keywords, as well as the maintainer, of xrootd itself. Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/xrootd-ceph/Manifest1
-rw-r--r--net-libs/xrootd-ceph/metadata.xml13
-rw-r--r--net-libs/xrootd-ceph/xrootd-ceph-4.12.0.ebuild24
3 files changed, 38 insertions, 0 deletions
diff --git a/net-libs/xrootd-ceph/Manifest b/net-libs/xrootd-ceph/Manifest
new file mode 100644
index 000000000000..24eab4063e39
--- /dev/null
+++ b/net-libs/xrootd-ceph/Manifest
@@ -0,0 +1 @@
+DIST xrootd-ceph-4.12.0.tar.gz 80601 BLAKE2B 05e31ec3a03d50f36f7ef368705ca8ad064d1d9da4fc3815aaf96ce358da07348aaea264d82884da2782cf7c1069b584269fff9f2a3140057b2d4d2929639f77 SHA512 de55cc923bad3629de6428dbc4e7c7e2cb802512f03f49bcfc79f12221828cd9702f1c9a1bc28b599dce801c937146cf381dfd589c85f4f5721c4fbf13f6ad34
diff --git a/net-libs/xrootd-ceph/metadata.xml b/net-libs/xrootd-ceph/metadata.xml
new file mode 100644
index 000000000000..65cbb7c9f142
--- /dev/null
+++ b/net-libs/xrootd-ceph/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci-physics@gentoo.org</email>
+ <name>Gentoo Physics Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ This XROOTD plug-in allows it to interface with rados block devices via
+ <pkg>sys-cluster/ceph</pkg>. Until its version 4.10.0 it used to part
+ of <pkg>net-libs/xrootd</pkg> itself.
+ </longdescription>
+</pkgmetadata>
diff --git a/net-libs/xrootd-ceph/xrootd-ceph-4.12.0.ebuild b/net-libs/xrootd-ceph/xrootd-ceph-4.12.0.ebuild
new file mode 100644
index 000000000000..867190e4408b
--- /dev/null
+++ b/net-libs/xrootd-ceph/xrootd-ceph-4.12.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="xrootd OSS plug-in for interfacing with Ceph storage platform"
+HOMEPAGE="https://xrootd.slac.stanford.edu/"
+SRC_URI="https://github.com/xrootd/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="net-libs/xrootd
+ !<net-libs/xrootd-4.10.0[rbd]
+ sys-cluster/ceph"
+RDEPEND="${DEPEND}"
+
+# xrootd plugins are not intended to be linked with,
+# they are to be loaded at runtime by xrootd,
+# see https://github.com/xrootd/xrootd/issues/447
+QA_SONAME="/usr/lib.*/libXrd.*-$(ver_cut 1).so"