summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2020-09-29 20:52:31 +0200
committerHanno Böck <hanno@gentoo.org>2020-09-29 20:52:56 +0200
commit05e12805658d25c67070bda7fd9b87970ca17b45 (patch)
tree97e28fedf96fdce76de4d4b5b931e37c064f7751 /net-mail
parentdev-python/jwcrypto: Keyword 0.8.0 arm64, #745402 (diff)
downloadgentoo-05e12805658d25c67070bda7fd9b87970ca17b45.tar.gz
gentoo-05e12805658d25c67070bda7fd9b87970ca17b45.tar.bz2
gentoo-05e12805658d25c67070bda7fd9b87970ca17b45.zip
net-mail/mailman: Slot mailman
This should make transition for people still on mailman 2 smoother. Signed-off-by: Hanno Böck <hanno@gentoo.org> Package-Manager: Portage-3.0.8, Repoman-3.0.1
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/mailman/mailman-3.3.1-r1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/net-mail/mailman/mailman-3.3.1-r1.ebuild b/net-mail/mailman/mailman-3.3.1-r1.ebuild
new file mode 100644
index 000000000000..f2b0f734e408
--- /dev/null
+++ b/net-mail/mailman/mailman-3.3.1-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Mailman -- the GNU mailing list manager"
+HOMEPAGE="https://www.list.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="3"
+#KEYWORDS="~amd64 ~ppc ~x86"
+KEYWORDS="" # nothing til this is finished
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="
+ >=dev-python/aiosmtpd-1.1[${PYTHON_USEDEP}]
+ dev-python/alembic[${PYTHON_USEDEP}]
+ dev-python/atpublic[${PYTHON_USEDEP}]
+ >=dev-python/authheaders-0.13.0[${PYTHON_USEDEP}]
+ >=dev-python/authres-1.0.1[${PYTHON_USEDEP}]
+ >=dev-python/click-7.0[${PYTHON_USEDEP}]
+ >=dev-python/dnspython-1.14.0[${PYTHON_USEDEP}]
+ >=dev-python/falcon-2.0.0[${PYTHON_USEDEP}]
+ dev-python/flufl-bounce[${PYTHON_USEDEP}]
+ >=dev-python/flufl-i18n-2.0.1[${PYTHON_USEDEP}]
+ >=dev-python/flufl-lock-3.1[${PYTHON_USEDEP}]
+ >=dev-python/importlib_resources-1.5.0[${PYTHON_USEDEP}]
+ www-servers/gunicorn[${PYTHON_USEDEP}]
+ dev-python/lazr-config[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.0[${PYTHON_USEDEP}]
+ dev-python/passlib[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ >=dev-python/sqlalchemy-1.2.3[${PYTHON_USEDEP}]
+ dev-python/zope-component[${PYTHON_USEDEP}]
+ dev-python/zope-configuration[${PYTHON_USEDEP}]
+ dev-python/zope-event[${PYTHON_USEDEP}]
+ >=dev-python/zope-interface-5.0[${PYTHON_USEDEP}]
+"