summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmadeusz Żołnowski <aidecoe@gentoo.org>2015-11-15 19:13:54 +0000
committerAmadeusz Żołnowski <aidecoe@gentoo.org>2015-11-15 19:39:04 +0000
commit51d66f53a94883f26aa9837971dfa6e0522fc090 (patch)
treea455d35c4f572dfc13a7dd1812fd368d33719cf2 /net-mail
parentnet-mail/notmuch: Depend on dev-python/sphinx unconditionally (diff)
downloadgentoo-51d66f53a94883f26aa9837971dfa6e0522fc090.tar.gz
gentoo-51d66f53a94883f26aa9837971dfa6e0522fc090.tar.bz2
gentoo-51d66f53a94883f26aa9837971dfa6e0522fc090.zip
net-mail/notmuch: Bump version to 0.21
Gentoo-Bug: 565522 Package-Manager: portage-2.2.23
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/notmuch/Manifest1
-rw-r--r--net-mail/notmuch/notmuch-0.21.ebuild191
2 files changed, 192 insertions, 0 deletions
diff --git a/net-mail/notmuch/Manifest b/net-mail/notmuch/Manifest
index e9ddfc4ce6ed..1636fc8418fe 100644
--- a/net-mail/notmuch/Manifest
+++ b/net-mail/notmuch/Manifest
@@ -1,3 +1,4 @@
DIST notmuch-0.18.2.tar.gz 635438 SHA256 e99f7bfee1250aa9f23e05d926ec278316fb8dd135262b0e24f4ba1a78febc9c SHA512 f6c7c9f17b1a7560bae8d3c7023be2fa6661a1dee5d69a6449a7b7c4468730b6917a857f015b67f09e18801e084a4c65a24a01603683e0ed12fc24b9feb9250e WHIRLPOOL 40191e7078088b45deda2ab2d61a3e2448c61e63b69dd725a88ff68cfaedf68a6270f2d9171ef6a8cb475c4faefd9d84b899f7239953b53aebceede79a76199c
DIST notmuch-0.19.tar.gz 659038 SHA256 396fc6548423785ebbbe9a6cce321d957d3b2e856edb8225bb0988470833eeeb SHA512 41eba85d2e6f89693f53d607abdef837973204e709f2c7385e64507a19b316913851f17b3b6dc93d8a622c72756b3e696aad8189570a563df38994cf346791a5 WHIRLPOOL 380d2508f106fc08b31f7928d63587cfc7ed63835a0cde287d7ba09d3f6814070c789aad1d0bf6a3bab387273b2d37a8c783d939c2f4afa475b9785f2618a25a
DIST notmuch-0.20.2.tar.gz 652945 SHA256 f741a26345bff389fd8a4a119c4174c6585730f71844809583a54ef2a865adec SHA512 08ab75df324f232edd7c36f73d01d7453c058ffb55c4f548afdf9abe843317c1d7066f21e7600c66c53577f7d31787914bf69743aa5d221e239e182452681c75 WHIRLPOOL 1698cb1b09046f50a57ebf23625a2dd68f86cac7cb1142be81e77b5625e49960cb2311c8acff44de0894238bced48853cdd72b7edf34109ecee0bc53d5b086fc
+DIST notmuch-0.21.tar.gz 663600 SHA256 d06f8ffed168c7d53ffc449dd611038b5fa90f7ee22d58f3bec3b379571e25b3 SHA512 2485c422433be21f6bf89aaf997e1468c31a52029ddc8336e78a632b292c659569448c29813ea550ed27fb6815558522a451a7fa10e8fb3f87d9538b4dd7b01a WHIRLPOOL 303c6427822272834e3d95ac94760f0fbaf3f2947a984a6770a9b2918fe0fbad289ef95fb9a8300cb6db08ab3ef0ff56810b3a60879c6a2a3eac524689f0a2f0
diff --git a/net-mail/notmuch/notmuch-0.21.ebuild b/net-mail/notmuch/notmuch-0.21.ebuild
new file mode 100644
index 000000000000..92ee3ffd5467
--- /dev/null
+++ b/net-mail/notmuch/notmuch-0.21.ebuild
@@ -0,0 +1,191 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DISTUTILS_OPTIONAL=1
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit bash-completion-r1 elisp-common eutils flag-o-matic pax-utils \
+ distutils-r1 toolchain-funcs
+
+DESCRIPTION="Thread-based e-mail indexer, supporting quick search and tagging"
+HOMEPAGE="http://notmuchmail.org/"
+SRC_URI="${HOMEPAGE%/}/releases/${P}.tar.gz"
+
+LICENSE="GPL-3"
+# Sub-slot corresponds to major wersion of libnotmuch.so.X.Y. Bump of Y is
+# meant to be binary backward compatible.
+SLOT="0/4"
+KEYWORDS="~amd64 ~x86"
+REQUIRED_USE="
+ nmbug? ( python )
+ python? ( ${PYTHON_REQUIRED_USE} )
+ test? ( crypt debug emacs python )
+ "
+IUSE="crypt debug doc emacs mutt nmbug python test"
+
+CDEPEND="
+ >=app-shells/bash-completion-1.9
+ >=dev-libs/glib-2.22
+ >=dev-libs/gmime-2.6.7
+ !=dev-libs/gmime-2.6.19
+ <dev-libs/xapian-1.3
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ >=sys-libs/zlib-1.2.5.2
+ sys-libs/talloc
+ debug? ( dev-util/valgrind )
+ emacs? ( >=virtual/emacs-23 )
+ python? ( ${PYTHON_DEPS} )
+ x86? ( >=dev-libs/xapian-1.2.7-r2 )
+ "
+DEPEND="${CDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+ test? ( app-misc/dtach || ( >=app-editors/emacs-23[libxml2]
+ >=app-editors/emacs-vcs-23[libxml2] ) sys-devel/gdb )
+ "
+RDEPEND="${CDEPEND}
+ crypt? ( app-crypt/gnupg )
+ nmbug? ( dev-vcs/git )
+ mutt? ( dev-perl/File-Which dev-perl/Mail-Box dev-perl/MailTools
+ dev-perl/String-ShellQuote dev-perl/Term-ReadLine-Gnu
+ virtual/perl-Digest-SHA virtual/perl-File-Path virtual/perl-Getopt-Long
+ virtual/perl-Pod-Parser
+ )
+ "
+
+DOCS=( AUTHORS NEWS README )
+SITEFILE="50${PN}-gentoo.el"
+MY_LD_LIBRARY_PATH="${WORKDIR}/${P}/lib"
+MY_PATCHES=( )
+
+bindings() {
+ local ret=0
+
+ if use $1; then
+ pushd bindings/$1 || die
+ shift
+ "$@"
+ ret=$?
+ popd || die
+ fi
+
+ return $ret
+}
+
+pkg_pretend() {
+ if has_version '<net-mail/notmuch-0.18'; then
+ ewarn
+ ewarn "There are few not backward compatible changes between"
+ ewarn "<notmuch-0.18 and >=notmuch-0.18. See NEWS file"
+ ewarn "(0.18 section) for details before first use!"
+ ewarn
+ fi
+}
+
+pkg_setup() {
+ if use emacs; then
+ elisp-need-emacs 23 || die "Emacs version too low"
+ fi
+}
+
+src_prepare() {
+ [[ "${MY_PATCHES[@]}" ]] && epatch "${MY_PATCHES[@]}"
+
+ bindings python distutils-r1_src_prepare
+ bindings python mv README README-python || die
+ mv contrib/notmuch-mutt/README contrib/notmuch-mutt/README-mutt || die
+
+ rm -f Makefile.config # assure that new Makefile.config will be generated
+
+ if use debug; then
+ append-cflags -g
+ append-cxxflags -g
+ fi
+}
+
+src_configure() {
+ local myeconfargs=(
+ --bashcompletiondir="$(get_bashcompdir)"
+ --emacslispdir="${EPREFIX}/${SITELISP}/${PN}"
+ --emacsetcdir="${EPREFIX}/${SITEETC}/${PN}"
+ --without-ruby
+ --zshcompletiondir="${EPREFIX}/usr/share/zsh/site-functions"
+ $(use_with emacs)
+ )
+ tc-export CC CXX
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ V=1 default
+ bindings python distutils-r1_src_compile
+
+ if use mutt; then
+ pushd contrib/notmuch-mutt || die
+ emake notmuch-mutt.1
+ popd || die
+ fi
+
+ if use doc; then
+ pydocs() {
+ pushd docs || die
+ emake html
+ mv html ../python || die
+ popd || die
+ }
+ LD_LIBRARY_PATH="${MY_LD_LIBRARY_PATH}" bindings python pydocs
+ fi
+}
+
+src_test() {
+ pax-mark -m notmuch
+ emake download-test-databases
+ LD_LIBRARY_PATH="${MY_LD_LIBRARY_PATH}" default
+ pax-mark -ze notmuch
+}
+
+src_install() {
+ default
+
+ if use emacs; then
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
+ fi
+
+ if use nmbug; then
+ dobin devel/nmbug/nmbug
+ dobin devel/nmbug/nmbug-status
+ fi
+
+ if use mutt; then
+ pushd contrib/notmuch-mutt || die
+ dobin notmuch-mutt
+ doman notmuch-mutt.1
+ insinto /etc/mutt
+ doins notmuch-mutt.rc
+ dodoc README-mutt
+ popd || die
+ fi
+
+ DOCS="" bindings python distutils-r1_src_install
+ use doc && bindings python dohtml -r python
+}
+
+pkg_preinst() {
+ if use mutt && ! [[ -e ${ROOT}/etc/mutt/notmuch-mutt.rc ]]; then
+ elog "To enable notmuch support in mutt, add the following line into"
+ elog "your mutt config file, please:"
+ elog ""
+ elog " source /etc/mutt/notmuch-mutt.rc"
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}