summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaymond Jennings <shentino@gmail.com>2016-08-27 13:40:33 -0700
committerDavid Seifert <soap@gentoo.org>2016-08-29 21:07:46 +0200
commit7676b5d33e6611f855d249fb8fdeb11e467cdb77 (patch)
tree27565b63099f6d699394cab1ca4e14148958eee5 /net-misc/bopm
parentdev-util/cucumber-core: add ruby23 (diff)
downloadgentoo-7676b5d33e6611f855d249fb8fdeb11e467cdb77.tar.gz
gentoo-7676b5d33e6611f855d249fb8fdeb11e467cdb77.tar.bz2
gentoo-7676b5d33e6611f855d249fb8fdeb11e467cdb77.zip
net-misc/bopm: revbump, patch config file, and huge cleanup
Fix these issues with r1: * Upgrade to EAPI 6 * Update the homepage * Formatting cleanups in the ebuild * Remove a redundant inherit * Use fowners and fperms instead of raw chown and chperm * Nix an unneeded "|| die" call * Use einstalldocs instead of dodoc * Use ED instead of D * Document usage of datadir to store example config file * Move various operations to the proper ebuild functions And finally: * Add patch to remove njabl from example config file Closes: https://github.com/gentoo/gentoo/pull/2151 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'net-misc/bopm')
-rw-r--r--net-misc/bopm/bopm-3.1.3-r2.ebuild64
-rw-r--r--net-misc/bopm/files/bopm-3.1.3-autotools.patch130
-rw-r--r--net-misc/bopm/files/bopm-3.1.3-remove-njabl.patch28
3 files changed, 222 insertions, 0 deletions
diff --git a/net-misc/bopm/bopm-3.1.3-r2.ebuild b/net-misc/bopm/bopm-3.1.3-r2.ebuild
new file mode 100644
index 000000000000..75d5f68e78c0
--- /dev/null
+++ b/net-misc/bopm/bopm-3.1.3-r2.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools user
+
+DESCRIPTION="Blitzed Open Proxy Monitor"
+HOMEPAGE="http://github.com/blitzed-org/bopm"
+SRC_URI="http://static.blitzed.org/www.blitzed.org/${PN}/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-remove-njabl.patch
+ "${FILESDIR}"/${P}-autotools.patch
+)
+
+pkg_setup() {
+ enewuser bopm
+}
+
+src_prepare() {
+ mv bopm.conf{.sample,} || die
+ mv configure.{in,ac} || die
+ mv src/libopm/configure.{in,ac} || die
+
+ sed -i \
+ -e "s!/some/path/bopm.pid!/run/${PN}/${PN}.pid!" \
+ -e "s!/some/path/scan.log!/var/log/${PN}/scan.log!" \
+ bopm.conf || die
+
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf --localstatedir="${EPREFIX}"/var/log/${PN}
+}
+
+src_install() {
+ default
+
+ # Remove libopm related files, because bopm links statically to it
+ # If anybody wants libopm, please install net-libs/libopm
+ rm -r "${ED}"usr/$(get_libdir) "${ED}"usr/include || die
+
+ newinitd "${FILESDIR}"/bopm.init.d-r1 ${PN}
+ newconfd "${FILESDIR}"/bopm.conf.d-r1 ${PN}
+
+ dodir /var/log/bopm
+ fperms 700 /var/log/bopm
+ fowners bopm:root /var/log/bopm
+
+ fperms 600 /etc/bopm.conf
+ fowners bopm:root /etc/bopm.conf
+}
diff --git a/net-misc/bopm/files/bopm-3.1.3-autotools.patch b/net-misc/bopm/files/bopm-3.1.3-autotools.patch
new file mode 100644
index 000000000000..992a1ff86eb7
--- /dev/null
+++ b/net-misc/bopm/files/bopm-3.1.3-autotools.patch
@@ -0,0 +1,130 @@
+--- bopm-3.1.3/configure.ac
++++ bopm-3.1.3/configure.ac
+@@ -1,5 +1,6 @@
+ dnl Process this file with autoconf to produce a configure script.
+ AC_INIT(bopm, [3.1.3])
++AC_CONFIG_MACRO_DIR([src/libopm/m4])
+ AC_CONFIG_SRCDIR(src/opercmd.h)
+ AM_CONFIG_HEADER(src/setup.h)
+ AM_INIT_AUTOMAKE()
+--- bopm-3.1.3/Makefile.am
++++ bopm-3.1.3/Makefile.am
+@@ -2,22 +2,9 @@
+
+ SUBDIRS = src
+
+-data_DATA = bopm.conf.sample bopm.conf.blitzed
++dist_doc_DATA = bopm.conf.blitzed
+
+-EXTRA_DIST = ChangeLog contrib INSTALL README bopm.conf.sample bopm.conf.blitzed network-bopm
++EXTRA_DIST = ChangeLog contrib INSTALL README network-bopm
+
+-install-data-local:
+- @if test -f $(sysconfdir)/bopm.conf ; then \
+- echo "$@ will not overwrite existing $(sysconfdir)/bopm.conf"; \
+- else \
+- $(mkinstalldirs) $(sysconfdir); \
+- echo "$(INSTALL_DATA) bopm.conf.sample $(sysconfdir)/bopm.conf"; \
+- $(INSTALL_DATA) bopm.conf.sample $(sysconfdir)/bopm.conf; \
+- fi
+- $(mkinstalldirs) $(localstatedir)
++dist_sysconf_DATA = bopm.conf
+
+-uninstall-local:
+- @if test -f $(sysconfdir)/bopm.conf ; then \
+- echo "rm -f $(sysconfdir)/bopm.conf"; \
+- $(RM) -f $(sysconfdir)/bopm.conf; \
+- fi
+--- bopm-3.1.3/src/libopm/configure.ac
++++ bopm-3.1.3/src/libopm/configure.ac
+@@ -1,5 +1,6 @@
+ dnl Process this file with autoconf to produce a configure script.
+ AC_INIT(libopm, [0.1])
++AC_CONFIG_MACRO_DIR([m4])
+ AC_CONFIG_SRCDIR(src/libopm.h)
+ AM_CONFIG_HEADER(src/setup.h)
+ AM_INIT_AUTOMAKE()
+--- bopm-3.1.3/src/libopm/m4/etr_socket_nsl.m4
++++ bopm-3.1.3/src/libopm/m4/etr_socket_nsl.m4
+@@ -0,0 +1,81 @@
++dnl @synopsis ETR_SOCKET_NSL
++dnl
++dnl @obsoleted Use LIB_SOCKET_NSL instead.
++dnl
++dnl This macro figures out what libraries are required on this platform
++dnl to link sockets programs. It's usually -lsocket and/or -lnsl or
++dnl neither. We test for all three combinations.
++dnl
++dnl @category Obsolete
++dnl @author Warren Young <warren@etr-usa.com>
++dnl @version 2005-09-02
++dnl @license AllPermissive
++
++AC_DEFUN([ETR_SOCKET_NSL],
++[
++AC_CACHE_CHECK(for libraries containing socket functions,
++ac_cv_socket_libs, [
++ oCFLAGS=$CFLAGS
++
++ AC_TRY_LINK([
++ #include <sys/types.h>
++ #include <sys/socket.h>
++ #include <netinet/in.h>
++ #include <arpa/inet.h>
++ ],
++ [
++ struct in_addr add;
++ int sd = socket(AF_INET, SOCK_STREAM, 0);
++ inet_ntoa(add);
++ ],
++ ac_cv_socket_libs=-lc, ac_cv_socket_libs=no)
++
++ if test x"$ac_cv_socket_libs" = "xno"
++ then
++ CFLAGS="$oCFLAGS -lsocket"
++ AC_TRY_LINK([
++ #include <sys/types.h>
++ #include <sys/socket.h>
++ #include <netinet/in.h>
++ #include <arpa/inet.h>
++ ],
++ [
++ struct in_addr add;
++ int sd = socket(AF_INET, SOCK_STREAM, 0);
++ inet_ntoa(add);
++ ],
++ ac_cv_socket_libs=-lsocket, ac_cv_socket_libs=no)
++ fi
++
++ if test x"$ac_cv_socket_libs" = "xno"
++ then
++ CFLAGS="$oCFLAGS -lsocket -lnsl"
++ AC_TRY_LINK([
++ #include <sys/types.h>
++ #include <sys/socket.h>
++ #include <netinet/in.h>
++ #include <arpa/inet.h>
++ ],
++ [
++ struct in_addr add;
++ int sd = socket(AF_INET, SOCK_STREAM, 0);
++ inet_ntoa(add);
++ ],
++ ac_cv_socket_libs="-lsocket -lnsl", ac_cv_socket_libs=no)
++ fi
++
++ CFLAGS=$oCFLAGS
++])
++
++ if test x"$ac_cv_socket_libs" = "xno"
++ then
++ AC_MSG_ERROR([Cannot find socket libraries])
++ elif test x"$ac_cv_socket_libs" = "x-lc"
++ then
++ ETR_SOCKET_LIBS=""
++ else
++ ETR_SOCKET_LIBS="$ac_cv_socket_libs"
++ fi
++
++ AC_SUBST(ETR_SOCKET_LIBS)
++]) dnl ETR_SOCKET_NSL
diff --git a/net-misc/bopm/files/bopm-3.1.3-remove-njabl.patch b/net-misc/bopm/files/bopm-3.1.3-remove-njabl.patch
new file mode 100644
index 000000000000..588ccd66bfa5
--- /dev/null
+++ b/net-misc/bopm/files/bopm-3.1.3-remove-njabl.patch
@@ -0,0 +1,28 @@
+Remove NJABL as an example blacklist.
+
+NJABL has been shut down and bopm upstream still lists it in its default
+configuration.
+---
+diff --git a/bopm.conf b/bopm.conf
+index 74483e1..bc05bf4 100644
+--- a/bopm.conf
++++ b/bopm.conf
+@@ -363,18 +363,6 @@ OPM {
+ # };
+
+
+- /* example: NJABL - please read http://www.njabl.org/use.html before
+- * uncommenting */
+-# blacklist {
+-# name = "dnsbl.njabl.org";
+-# type = "A record reply";
+-# reply {
+-# 9 = "Open proxy";
+-# };
+-# ban_unknown = no;
+-# kline = "KLINE *@%h :Open proxy found on your host, please visit www.njabl.org/cgi-bin/lookup.cgi?query=%i";
+-# };
+-
+ /*
+ * You can report the insecure proxies you find to a DNSBL also!
+ * The remaining directives in this section are only needed if you