summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLukáš Poláček <lukas@ksp.sk>2016-06-27 08:21:57 +0200
committerYixun Lan <dlan@gentoo.org>2016-07-08 06:53:05 +0800
commit9ab1a2f12404eef7babcdc3ba906a98c091980d3 (patch)
tree4e9da93d99c4acccf3cb1fa2893c1575797c67ef /net-misc/dhcpcd-ui
parentapp-vim/foldutil: Clean up old. (diff)
downloadgentoo-9ab1a2f12404eef7babcdc3ba906a98c091980d3.tar.gz
gentoo-9ab1a2f12404eef7babcdc3ba906a98c091980d3.tar.bz2
gentoo-9ab1a2f12404eef7babcdc3ba906a98c091980d3.zip
net-misc/dhcpcd-ui: Add knotify dependency
Package fails to build when libnotify and qt4 USE flags are set. Adding knotify as a dependency fixes the issue. Gentoo-Bug: 568166 Package-Manager: portage-2.2.28 Closes: https://github.com/gentoo/gentoo/pull/1763 Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'net-misc/dhcpcd-ui')
-rw-r--r--net-misc/dhcpcd-ui/dhcpcd-ui-0.7.5-r1.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/net-misc/dhcpcd-ui/dhcpcd-ui-0.7.5-r1.ebuild b/net-misc/dhcpcd-ui/dhcpcd-ui-0.7.5-r1.ebuild
new file mode 100644
index 000000000000..78bfb2a67011
--- /dev/null
+++ b/net-misc/dhcpcd-ui/dhcpcd-ui-0.7.5-r1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit qmake-utils systemd
+
+DESCRIPTION="Desktop notification and configuration for dhcpcd"
+HOMEPAGE="http://roy.marples.name/projects/dhcpcd-ui/"
+SRC_URI="http://roy.marples.name/downloads/${PN%-ui}/${P}.tar.bz2"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug gtk gtk3 qt4 libnotify"
+
+REQUIRED_USE="
+ ?? ( gtk gtk3 qt4 )
+ gtk3? ( !gtk )
+ gtk? ( !gtk3 )"
+
+DEPEND="
+ virtual/libintl
+ libnotify? (
+ gtk? ( x11-libs/libnotify )
+ gtk3? ( x11-libs/libnotify )
+ qt4? ( kde-base/kdelibs kde-apps/knotify )
+ )
+ gtk? ( x11-libs/gtk+:2 )
+ gtk3? ( x11-libs/gtk+:3 )
+ qt4? ( dev-qt/qtgui:4 )"
+
+RDEPEND=">=net-misc/dhcpcd-6.4.4"
+
+pkg_setup() {
+ if use qt4 ; then
+ # This is required in case a user still has qt3 installed
+ export QTDIR="$(qt4_get_bindir)"
+ fi
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable debug)
+ $(usex gtk '--with-gtk=gtk+-2.0 --with-icons' '')
+ $(usex gtk3 '--with-gtk=gtk+-3.0 --with-icons' '')
+ $(usex qt4 '--with-qt --with-icons' '--without-qt')
+ $(use_enable libnotify notification)
+ $(use gtk || use gtk3 || echo '--without-gtk')
+ $(use gtk || use gtk3 || use qt4 || echo '--without-icons')
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" INSTALL_ROOT="${D}" install
+
+ systemd_dounit src/dhcpcd-online/dhcpcd-wait-online.service
+}