summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-01-16 12:58:11 +0100
committerLars Wendler <polynomial-c@gentoo.org>2018-01-16 12:59:17 +0100
commit23897cc2c85bfb2a7c6fe8cdabf819fda4e2c06d (patch)
tree37f4adc3fb57d53df33aa52f9424c8364a05159d /net-misc/rsync
parentdev-db/pspg: Bump to 0.9.2 (diff)
downloadgentoo-23897cc2c85bfb2a7c6fe8cdabf819fda4e2c06d.tar.gz
gentoo-23897cc2c85bfb2a7c6fe8cdabf819fda4e2c06d.tar.bz2
gentoo-23897cc2c85bfb2a7c6fe8cdabf819fda4e2c06d.zip
net-misc/rsync: Bump to version 3.1.3_pre1
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'net-misc/rsync')
-rw-r--r--net-misc/rsync/Manifest1
-rw-r--r--net-misc/rsync/rsync-3.1.3_pre1.ebuild92
2 files changed, 93 insertions, 0 deletions
diff --git a/net-misc/rsync/Manifest b/net-misc/rsync/Manifest
index 87500d8c226a..677260a226c7 100644
--- a/net-misc/rsync/Manifest
+++ b/net-misc/rsync/Manifest
@@ -1 +1,2 @@
DIST rsync-3.1.2.tar.gz 892724 BLAKE2B e366514ae9835ba7c201a9e09fb9342c5e52fa36d45d46300d080403de25a64ba3ed7a703e56b4f47a743a597694a2d0a50bb4bab6cfa0aa7b59a4f7b93b9f21 SHA512 4c55fd69f436ead0cb5a0b7c6fdfef9bb28ddb9c63534eb619e756b118d5b08cfc5e696498650932c86e865b37e06633da947e6720ca0c27ed5c034313ae208b
+DIST rsync-3.1.3pre1.tar.gz 905910 BLAKE2B 1823494a325181773cd14f2b8a9aae4ad6a891d70713e111f43c516a69cb9852103c7bb8ced864aec24b8d2a7a4e791c53f6e868276c6c6cc25f0aaba36ddbf2 SHA512 8e2e4623650985169d4ec2e84549f8b5f060b5544380c5b332998161eb1adcfece48216c343730eb726904079836c2d47dc85fa9707fccc02f09841eb547b597
diff --git a/net-misc/rsync/rsync-3.1.3_pre1.ebuild b/net-misc/rsync/rsync-3.1.3_pre1.ebuild
new file mode 100644
index 000000000000..a01698246090
--- /dev/null
+++ b/net-misc/rsync/rsync-3.1.3_pre1.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit flag-o-matic prefix systemd
+
+DESCRIPTION="File transfer program to keep remote files into sync"
+HOMEPAGE="https://rsync.samba.org/"
+SRC_URI="https://rsync.samba.org/ftp/rsync/src/${P}.tar.gz"
+[[ "${PV}" = *_pre* ]] && SRC_URI="https://rsync.samba.org/ftp/rsync/src-previews/${P/_/}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+if [[ ${PV} != *_pre ]] ; then
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+fi
+IUSE="acl examples iconv ipv6 static stunnel xattr"
+
+LIB_DEPEND="acl? ( virtual/acl[static-libs(+)] )
+ xattr? ( kernel_linux? ( sys-apps/attr[static-libs(+)] ) )
+ >=dev-libs/popt-1.5[static-libs(+)]"
+RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs(+)]} )
+ iconv? ( virtual/libiconv )"
+DEPEND="${RDEPEND}
+ static? ( ${LIB_DEPEND} )"
+
+S="${WORKDIR}/${P/_/}"
+
+src_configure() {
+ use static && append-ldflags -static
+ local myeconfargs=(
+ --with-rsyncd-conf="${EPREFIX}"/etc/rsyncd.conf
+ --without-included-popt
+ $(use_enable acl acl-support)
+ $(use_enable iconv)
+ $(use_enable ipv6)
+ $(use_enable xattr xattr-support)
+ )
+ econf "${myeconfargs[@]}"
+ touch proto.h-tstamp #421625
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ newconfd "${FILESDIR}"/rsyncd.conf.d rsyncd
+ newinitd "${FILESDIR}"/rsyncd.init.d-r1 rsyncd
+
+ dodoc NEWS OLDNEWS README TODO tech_report.tex
+
+ insinto /etc
+ newins "${FILESDIR}"/rsyncd.conf-3.0.9-r1 rsyncd.conf
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/rsyncd.logrotate rsyncd
+
+ insinto /etc/xinetd.d
+ newins "${FILESDIR}"/rsyncd.xinetd-3.0.9-r1 rsyncd
+
+ # Install stunnel helpers
+ if use stunnel ; then
+ emake DESTDIR="${D}" install-ssl-client
+ emake DESTDIR="${D}" install-ssl-daemon
+ fi
+
+ # Install the useful contrib scripts
+ if use examples ; then
+ exeinto /usr/share/rsync
+ doexe support/*
+ rm -f "${ED%/}"/usr/share/rsync/{Makefile*,*.c}
+ fi
+
+ eprefixify "${ED%/}"/etc/{,xinetd.d}/rsyncd*
+
+ systemd_dounit "${FILESDIR}/rsyncd.service"
+}
+
+pkg_postinst() {
+ if egrep -qis '^[[:space:]]use chroot[[:space:]]*=[[:space:]]*(no|0|false)' \
+ "${EROOT}"/etc/rsyncd.conf "${EROOT}"/etc/rsync/rsyncd.conf ; then
+ ewarn "You have disabled chroot support in your rsyncd.conf. This"
+ ewarn "is a security risk which you should fix. Please check your"
+ ewarn "/etc/rsyncd.conf file and fix the setting 'use chroot'."
+ fi
+ if use stunnel ; then
+ einfo "Please install \">=net-misc/stunnel-4\" in order to use stunnel feature."
+ einfo
+ einfo "You maybe have to update the certificates configured in"
+ einfo "${EROOT}/etc/stunnel/rsync.conf"
+ fi
+}