summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/sgopherd
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/sgopherd')
-rw-r--r--net-misc/sgopherd/Manifest1
-rw-r--r--net-misc/sgopherd/metadata.xml11
-rw-r--r--net-misc/sgopherd/sgopherd-13.01.ebuild41
3 files changed, 53 insertions, 0 deletions
diff --git a/net-misc/sgopherd/Manifest b/net-misc/sgopherd/Manifest
new file mode 100644
index 000000000000..6b1c6f588b66
--- /dev/null
+++ b/net-misc/sgopherd/Manifest
@@ -0,0 +1 @@
+DIST sgopherd-13.01.tar.gz 10524 SHA256 8a115d48fd0b78b9c3f069f2c827aacac439cfbf3d2face22f173e2920554693 SHA512 8f2864ddb263e8a437d37718a3108fee2fd7fdc1ce8e3fdb5a8db019b2dde5a52d12f574e3f32a6fe80e1ab1ca2687d87a310e6d12580f6e5d588ba13d4a5165 WHIRLPOOL af0bd9444e68191284fa50c6582f0ef84275e9e3de2d0851f2dbffb35dde1571d490fb444ff2534fbaf5d9a8da9c77d56497ce9efa01b53f14258dfaaf6559ac
diff --git a/net-misc/sgopherd/metadata.xml b/net-misc/sgopherd/metadata.xml
new file mode 100644
index 000000000000..3b9f77da53a3
--- /dev/null
+++ b/net-misc/sgopherd/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>pinkbyte@gentoo.org</email>
+ <name>Sergey Popov</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">vain/sgopherd</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-misc/sgopherd/sgopherd-13.01.ebuild b/net-misc/sgopherd/sgopherd-13.01.ebuild
new file mode 100644
index 000000000000..f190b33a1517
--- /dev/null
+++ b/net-misc/sgopherd/sgopherd-13.01.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Small Gopher Server written in GNU Bash"
+HOMEPAGE="https://github.com/vain/sgopherd"
+SRC_URI="https://github.com/vain/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="PIZZA-WARE"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=""
+RDEPEND="app-shells/bash
+ sys-apps/sed
+ sys-apps/xinetd"
+
+src_prepare() {
+ # Set default user to run sgopherd
+ sed -i -e '/user/s/http/nobody/' xinetd/xinetd-example.conf || die 'sed failed'
+
+ epatch_user
+}
+
+src_install() {
+ dodoc README
+ doman man8/"${PN}".8
+ dobin "${PN}"
+ insinto /etc/xinetd.d
+ newins xinetd/xinetd-example.conf "${PN}"
+ # TODO: add installation of systemd-related files
+}
+
+pkg_postinst() {
+ elog "${PN} can be launched through xinetd"
+ elog "Configuration options are in /etc/xinetd.d/${PN}"
+}