summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKristian Fiskerstrand <k_f@gentoo.org>2015-10-31 14:24:56 +0100
committerKristian Fiskerstrand <k_f@gentoo.org>2015-10-31 14:25:16 +0100
commit06c7a2c09636cad16fe69eb8e1779d0c7269a0d9 (patch)
tree0bfda2b0d7e63b6913d4d33d92f89061da756f6e /net-misc/sks
parentapp-office/libreoffice: drop xpdf-headers use flag requirement on poppler, th... (diff)
downloadgentoo-06c7a2c09636cad16fe69eb8e1779d0c7269a0d9.tar.gz
gentoo-06c7a2c09636cad16fe69eb8e1779d0c7269a0d9.tar.bz2
gentoo-06c7a2c09636cad16fe69eb8e1779d0c7269a0d9.zip
net-misc/sks: Revision bump, adding curve25519 encryption support
Upstream patch in issue https://bitbucket.org/skskeyserver/sks-keyserver/issues/36/curve25519-oid-for-encryption has been reviewed and is going for inclusion Package-Manager: portage-2.2.20.1
Diffstat (limited to 'net-misc/sks')
-rw-r--r--net-misc/sks/files/sks-1.1.5-curve25519.patch11
-rw-r--r--net-misc/sks/sks-1.1.5-r2.ebuild118
2 files changed, 129 insertions, 0 deletions
diff --git a/net-misc/sks/files/sks-1.1.5-curve25519.patch b/net-misc/sks/files/sks-1.1.5-curve25519.patch
new file mode 100644
index 000000000000..ccf484f45523
--- /dev/null
+++ b/net-misc/sks/files/sks-1.1.5-curve25519.patch
@@ -0,0 +1,11 @@
+diff -r 1a1b0b48e642 parsePGP.ml
+--- a/parsePGP.ml Tue May 26 12:21:29 2015 -0400
++++ b/parsePGP.ml Tue Oct 13 14:46:03 2015 +0900
+@@ -151,6 +151,7 @@
+ | "\x2b\x24\x03\x03\x02\x08\x01\x01\x0d" -> 512 (* brainpoolP512r1 *)
+ | "\x2b\x81\x04\x00\x0a" -> 256 (* secp256k1 *)
+ | "\x2b\x06\x01\x04\x01\xda\x47\x0f\x01" -> 256 (* Ed25519 *)
++ | "\x2b\x06\x01\x04\x01\x97\x55\x01\x05\x01" -> 256 (* cv25519 *)
+ | _ -> failwith "Unknown OID"
+ in
+ psize
diff --git a/net-misc/sks/sks-1.1.5-r2.ebuild b/net-misc/sks/sks-1.1.5-r2.ebuild
new file mode 100644
index 000000000000..4aa095cb09ef
--- /dev/null
+++ b/net-misc/sks/sks-1.1.5-r2.ebuild
@@ -0,0 +1,118 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit multilib user readme.gentoo systemd
+
+DESCRIPTION="An OpenPGP keyserver which is decentralized and provides highly reliable synchronization"
+HOMEPAGE="https://bitbucket.org/skskeyserver/sks-keyserver"
+SRC_URI="https://bitbucket.org/skskeyserver/sks-keyserver/downloads/${P}.tgz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="optimize test"
+DOC_CONTENTS="To get sks running, first build the database,
+start the databse, import atleast one key, then
+run a cleandb. See the sks man page for more information
+Typical DB_CONFIG file and sksconf has been installed
+in /var/lib/sks and can be used as templates by renaming
+to remove the .typical extension. The DB_CONFIG file has
+to be in place before doing the database build, or the BDB
+environment has to be manually cleared from both KDB and PTree.
+The same applies if you are upgrading to this version with an existing KDB/Ptree,
+using another version of BDB than 4.8; you need to clear the environment
+using e.g. db4.6_recover -h . and db4.6_checkpoint -1h . in both KDB and PTree
+Additionally a sample web interface has been installed as
+web.typical in /var/lib/sks that can be used by renaming it to web
+Important: It is strongly recommended to set up SKS behind a
+reverse proxy. Instructions on properly configuring SKS can be
+found at https://bitbucket.org/skskeyserver/sks-keyserver/wiki/Peering"
+
+DEPEND="dev-lang/ocaml
+ dev-ml/cryptokit
+ sys-libs/db:4.8"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ ebegin "Creating named group and user"
+ enewgroup sks
+ enewuser sks -1 -1 /var/lib/sks sks
+}
+
+src_prepare() {
+ cp Makefile.local.unused Makefile.local || die
+ sed -i \
+ -e "s:^BDBLIB=.*$:BDBLIB=-L/usr/$(get_libdir):g" \
+ -e "s:^BDBINCLUDE=.*$:BDBINCLUDE=-I/usr/include/db4.8/:g" \
+ -e "s:^LIBDB=.*$:LIBDB=-ldb-4.8:g" \
+ -e "s:^PREFIX=.*$:PREFIX=${D}/usr:g" \
+ -e "s:^MANDIR=.*$:MANDIR=${D}/usr/share/man:g" \
+ Makefile.local || die
+ sed -i \
+ -e 's:^CAMLINCLUDE= -I lib -I bdb$:CAMLINCLUDE= -I lib -I bdb -I +cryptokit:g' \
+ -e 's:-Werror-implicit-function-declaration::g' \
+ Makefile bdb/Makefile || die
+ sed -i \
+ -e 's:/usr/sbin/sks:/usr/bin/sks:g' \
+ sks_build.sh || die
+
+ epatch "${FILESDIR}/${P}-eddsa.patch"
+ epatch "${FILESDIR}/${P}-disable-warn-error-a.patch"
+ epatch "${FILESDIR}/${P}-curve25519.patch"
+}
+
+src_compile() {
+ emake dep
+ # sks build fails with paralell build in module Bdb
+ emake -j1 all
+ if use optimize; then
+ emake all.bc
+ fi
+}
+
+src_test() {
+ ./sks unit_test || die
+}
+
+src_install() {
+ if use optimize; then
+ emake install.bc
+ dosym /usr/bin/sks.bc usr/bin/sks
+ dosym /usr/bin/sks_add_mail.bc usr/bin/sks_add_mail
+ else
+ emake install
+ fi
+
+ dodoc README.md
+
+ newinitd "${FILESDIR}/sks-db.initd" sks-db
+ newinitd "${FILESDIR}/sks-recon.initd" sks-recon
+ newconfd "${FILESDIR}/sks.confd" sks
+ systemd_dounit "${FILESDIR}"/sks-db.service
+ systemd_dounit "${FILESDIR}"/sks-recon.service
+
+ dodir "/var/lib/sks/web.typical"
+ insinto /var/lib/sks
+ newins sampleConfig/DB_CONFIG DB_CONFIG.typical
+ newins sampleConfig/sksconf.typical sksconf.typical
+ insinto /var/lib/sks/web.typical
+ doins sampleWeb/HTML5/*
+
+ keepdir /var/lib/sks
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+
+ if [[ -n ${REPLACING_VERSIONS} ]]; then
+ einfo "Note when upgrading from versions of SKS earlier than 1.1.4"
+ einfo "The default values for pagesize settings have changed. To continue"
+ einfo "using an existing DB without rebuilding, explicit settings have to be"
+ einfo "added to the sksconf file."
+ einfo "pagesize: 4"
+ einfo "ptree_pagesize: 1"
+ fi;
+}